Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 18:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись в SQL через форму внешней обработки  (Прочитано 1282 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Никитa

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-18
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста новичку что делаю не так, (Нужно записывать из формы внешн. обработки в SQL )  Может примеры какие-нибуть подскажете ?
//СПЕРВА ПОДКЛЮЧЕНИЯ К БАЗЕ
&НаКлиенте
Процедура Записать(Команда)
ЗаписатьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаписатьНаСервере()


    СтрокаПодключения =
 "Provider=sqloledb;
 |User ID=nikita;
 |Pwd=12345;
 |Data Source=sql.tk-chel.ru;
 |Initial Catalog= SVCTEST";//наша database

 Connection  = Новый COMОбъект("ADODB.Connection");
 Command  = Новый COMОбъект("ADODB.Command");
 RecordSet  = Новый COMОбъект("ADODB.RecordSet");
Попытка
  Connection.Open(СокрЛП(СтрокаПодключения));
  Command.ActiveConnection   = Connection;
  //Проверка на наличие  database
  Command.CommandText = "select * from dbo_MoveH where name = 'SVCTEST'";
  RecordSet = Command.Execute();
    Если RecordSet.EOF() И RecordSet.BOF() Тогда
   //нет записей, нет такой database, нужно создать;
   Возврат;
  КонецЕсли;
 
  RecordSet.MoveFirst();
 Исключение
  Сообщить(ОписаниеОшибки());
КонецПопытки;

   // ДАЛЬШЕ ЗАПИСЬ
   


ФайлДБФ = Новый XBase(ВнешниеИсточникиДанных.ТК.Таблицы.dbo_MoveH);
ФайлДБФ.Кодировка=КодировкаXBase.OEM;
КолЗаписей = ФайлДБФ.КоличествоЗаписей();
ФайлДБФ.Первая();

Для сч = 1 По КолЗаписей Цикл
Command.CommandText =
"USE SVCTEST
|INSERT INTO dbo_MoveH  VALUES(   
|'"+12344+"',
|'"+4 +"',
|'"+Объект.Контакт+"',
|'"+Объект.Телефон+"',
|'"+Объект.Компания+"',
|'"+Объект.Страна+"',
|'"+Объект.Регион+"',
|'"+Объект.Город+"',
|'"+Объект.Улица+"',
|'"+Объект.Дом+"',
|'"+Объект.Оффис+"',
|'"+Объект.КраткоеОписание+"',
|'"+Объект.ТипОплаты+"',
|)";
Command.Execute();
ФайлДБФ.Следующая();
КонецЦикла;

ФайлДБФ.ЗакрытьФайл();
Command = Неопределено;
Connection = Неопределено;
RecordSet = Неопределено;
//Соединение.Close();

КонецПроцедуры


Последний раз редактировалось: Никитa; 21 Июл 2014, 08:50


Теги:
 

Как объединить объект в реквизите формы с типом "ДокументОбъект" и объект формы, созданной через "ПолучитьФорму()"?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 255
Последний ответ 06 Авг 2017, 21:22
от alex0402
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1373
Последний ответ 18 Янв 2017, 12:32
от sertak
Здравствуйте!!! Необходимо востановить ИБ на определенную дату. Копии через конфигуратор на эту дату не сделали, но есть файл в формате CD в rar (Это программа сама сделала резервную копию). Возможно ли востановит ее в 1с и работать (как при загрузке копи

Автор Лариса198888Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1884
Последний ответ 24 Май 2016, 17:17
от Kironten
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 515
Последний ответ 15 Май 2017, 08:59
от ZSS
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8582
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
140 Сообщений
AIFrame
70 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 450
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal