Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 09:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Необходимо найти...  (Прочитано 681 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Управляемое приложение.
Здравствуйте есть код.
При запуске кода выводит ошибку: "ошибка отображения данных". Не пойму где ошибка ?



&НаКлиенте
Процедура Команда2(Число1, Число2)

ВвестиЧисло(Число1);
ВвестиЧисло(Число2);

ЧислоМин = Мин  (Число1);
ЧислоМакс = Макс(Число2);


Для Результат = ЧислоМин По ЧислоМакс Цикл


ОткрытьЗначение(Результат);


КонецЦикла;
 
КонецПроцедуры


Последний раз редактировалось: MuI_I_Ika; 18 Июл 2014, 19:19


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте ОткрытьЗначение заменить на Сообщить и посмотреть что он там сообщит. Если там числа, то их нельзя показывать через открыть значение. Если там что-то другое, значит проблема в этом.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
к сожалению также :(
Добавлено: 18 Июл 2014, 20:00

всем спасибо вопрос сам решил.
Добавлено: 19 Июл 2014, 19:08

Я не стал создавать тему еще один вопрос есть :

Задача: написать функцию, которая принимает дату и возвращает день недели, я сделал через Процедуру , а как сделать через Функцию ?

&НаКлиенте
Процедура Команда1(Команда)
         ДатаОтПользователя = '00010101';
           ВвестиДату(ДатаОтПользователя);
           Результат =  (Формат(ДатаОтПользователя, "ДФ=дддд"));
         ОткрытьЗначение (Результат);
КонецПроцедуры

Последний раз редактировалось: cobra77777; 19 Июл 2014, 19:08. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
функция Команда1(Команда)
         ДатаОтПользователя = '00010101';
           ВвестиДату(ДатаОтПользователя);
           Результат =  (Формат(ДатаОтПользователя, "ДФ=дддд"));
         Возврат Результат;
КонецФункции
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 592
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal