Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сделать булево (галочку) всегда активной  (Прочитано 5304 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AkselDen

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-17
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток... Думаю для профи плевое дело но не сумел раскопать что да как.
1с 8.1  задача следующая ... в "реализации товаров" есть пункт "сумма включает НДС"(булево) по умолчанию галочки нет... вопрос в том как сделать что бы по умолчанию всегда стояла галочка...
Заранее спасибо.


Оффлайн lunjio

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 1
  • КПД: 13%
  • Регистрация: 2014-07-18
  • Сайт: 
  • Профессия: Программист 1С
вопрос если честно примитивный, в конфигураторе в свойствах реквезита пункт значение заполнения, по умолчанию ложь стоит, поменять на истина.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вопрос если честно примитивный, в конфигураторе в свойствах реквезита пункт значение заполнения, по умолчанию ложь стоит, поменять на истина.

В обычном приложение "значение заполнения" не отрабатывает, только для управляемого.

То Автор: в ПриОткрытии() устанавливаете этот реквизит в Истина и обрабатываете событие ПриИзменении() - пишете "СуммаВключаетНДС = Истина;"
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн AkselDen

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-17
  • Сайт: 
  • Профессия: Ученик 1С
оооо сейчас попробую ... вопрос примитивный конечно но это лишь из за недостатка знаний...
Добавлено: 22 Июл 2014, 18:11

вопрос если честно примитивный, в конфигураторе в свойствах реквезита пункт значение заполнения, по умолчанию ложь стоит, поменять на истина.

В обычном приложение "значение заполнения" не отрабатывает, только для управляемого.

То Автор: в ПриОткрытии() устанавливаете этот реквизит в Истина и обрабатываете событие ПриИзменении() - пишете "СуммаВключаетНДС = Истина;"
Мне, к сожалению, нужно разжевать... Если я правильно понял... ПриОткрытии() это процедура в модуле(формадокумента) ... "этот реквизит в Истина" - честно говоря даже не понимаю что за реквизит:
Процедура ПриОткрытии()

   // Установка кнопок заполнение ТЧ
   УстановитьКнопкиПодменюЗаполненияТЧ();

   ПолучитьСерверТО().ПодключитьКлиента(ЭтаФорма);

   РаботаСДиалогами.ПриОткрытииФормыДокумента(ЭтоНовый(), ЭтаФорма, ЭтотОбъект, глЗначениеПеременной("глТекущийПользователь"));

   // Установить печатную форму по умолчанию.
   РаботаСДиалогами.УстановитьКнопкуПечати(ЭтотОбъект, ЭтаФорма);

   Если ЭтоНовый() Тогда

      РаботаСДиалогами.УстановитьДвижениеПоОрдернойСхеме(РеализацияПоОрдернойСхеме, Склад, Ответственный);

      Модифицированность = Ложь;
   Иначе
      

   КонецЕсли;


   УправлениеВидимостью();
   
   РаботаСДиалогами.УстановитьВидимостьКолонокХарактеристикаНоменклатурыПриОткрытии(Товары,мКолонкиТовары.ХарактеристикаНоменклатуры);
   Если Безнал Тогда
      ЭлементыФормы.НадписьНомерПЛ.Видимость = Безнал;
      ЭлементыФормы.НомерПЛ.Видимость = Безнал;
       ЭлементыФормы.НадписьВодитель.Видимость = Безнал;
      ЭлементыФормы.ФИОВодителя.Видимость = Безнал;
   
   КонецЕсли;
   
   Если Безнал Тогда
      ЭлементыФормы.ДействияФормы.Кнопки.Оплата.Доступность = Ложь;
   Иначе
      ЭлементыФормы.ДействияФормы.Кнопки.Оплата.Доступность = Истина;
   КонецЕсли;
   
КонецПроцедуры // ПриОткрытии()

Это что содержится в процедуре тыкните пожалуйста пальцем ...
Добавлено: 22 Июл 2014, 18:25

Все понял сделал разобрался ... Всем огромное спасибо!

Последний раз редактировалось: AkselDen; 22 Июл 2014, 18:25. Причина: Объединение сообщений


Теги: Булево 
 

Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2032
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 223
Последний ответ 18 Авг 2017, 11:57
от ZSS
Как "Наименование" сделать числом

Автор zedikusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1730
Последний ответ 24 Авг 2015, 06:26
от cska-fanat-kz
Добрый вечер! Прошу помочь, кто знает, подскажите пож. В счете не выводит грузоотправителя и грузополучаетля. Куда их внести ? Как сделать что бы выводило ? У меня 1с 8.3 редакция 11.1 управление торговлей Спасибо!

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1967
Последний ответ 07 Фев 2016, 14:34
от pavl_vs
1 страница - портрет, 2 страница - ландшафт Подскажите как сделать?

Автор YaposhaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4561
Последний ответ 05 Апр 2012, 11:37
от Yaposha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal