Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 19:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение реквизита справочника из ТабЧасти Документа.  (Прочитано 1612 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Серега16

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-06
  • Сайт: 
На форме документа есть табЧасть с реквизитом ПроктныйНомер (ссылка справочник ТоварыПроката).При выборе товара  в ТабЧасти заполняются реквизиты выбранного товара. Один из реквизитов статус тип (перечисления.Свободен). Нужно по команде изменить статус ( Свободен на ВРаботе)в всех товарах из ТабЧасти. На воял вот такой код, но он не работает.
&НаКлиенте
Процедура Зарезервировать(Команда)
Если  Вопрос("Зарезервировать?", РежимДиалогаВопрос.ОКОтмена) = КодВозвратаДиалога.Да Тогда
Для каждого ТекСтр Из Объект.ВыбрТовара Цикл
КомандаЗарезервировать(ТекСтр.ПрокатныйНомер);
   
КонецЦикла;
КонецЕсли;
КонецПроцедуры

&НаСервере
 Процедура КомандаЗарезервировать(Элемент)

 спр=справочники.ТоварыПроката.НайтиПоНаименованию(Элемент);
 СпрОбъект = Спр.ПолучитьОбъект();
 СпрОбъект.Статус=перечисления.СтатусЗаказа.Зарезервирован;
 СпрОбъект.Записать();
 

КонецПроцедуры


Оффлайн Серега16

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-06
  • Сайт: 
Попробовал вот так ругается на если
&НаКлиенте
Процедура Зарезервировать(Команда)

    Для каждого ТекСтр Из Объект.ВыбрТовара Цикл
   
    Если ЗначениеЗаполнено(ТекСтр.ПрокатныйНомер) Тогда
    СпрОбъект = ТекСтр.ПрокатныйНомер.ПолучитьОбъект();
    СпрОбъект.Статус = Перечисления.СтатусЗаказа.Зарезервирован;
    СпрОбъект.Записать();
    КонецЕсли;                                     .
  КонецЦикла;
КонецПроцедуры

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Вообще, хранить в справочнике, динамически меняющуюся информацию неправильно,
как один из вариантов, вам надо сделать переодический регистр сведений, где будут данные
Период - ТоварПроката - Состояние (возможно еще какая доп.информация)
и соответстенно документ который выдает товар в прокат делает там запись: Товар - Занят
а документ по которому товар возвращается из проката (наверняка есть и такой, хотя в постановке о нем не слова)
делает запись Товар - Свободен,
так как регистр Периодический вы всегда сможете посмотреть историю занятости товара, и очень удобно будет по регистру строить всякие отчеты.
да и простая выборка по срезу последнего покажет вам какие товары заняты, какие свободны.

(опять же говорю, что это один из вариантов учета занятости товаров проката)
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Серега16

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-06
  • Сайт: 
Проблему решил вот так
&НаКлиенте
Процедура Зарезервировать(Команда)
Если Вопрос("Зарезервировать?", РежимДиалогаВопрос.ДаНет)=КодВозвратаДиалога.Да Тогда
КомандаЗарезервировать();
КонецЕсли;
КонецПроцедуры
 

&НаСервере
 Процедура КомандаЗарезервировать()

Объект.СтатусЗаказа=перечисления.СтатусЗаказа.Зарезервирован;

КонецПроцедуры

&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
 Для каждого ТекСтр Из Объект.ВыбрТовара Цикл
 спр=справочники.ТоварыПроката.НайтиПоНаименованию(ТекСтр.ПрокатныйНомер);
  СпрОбъект = Спр.ПолучитьОбъект();
  СпрОбъект.Статус=объект.СтатусЗаказа;
  СпрОбъект.Записать();
КонецЦикла;

КонецПроцедуры


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4471
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15920
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7741
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4778
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1581
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 355
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal