Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 00:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите решить задачу  (Прочитано 2742 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jenya1111

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-17
  • Сайт: 
  • Профессия: Программист 8.1
Имеется массив

Массив = Новый Массив (3, 4);
   Массив[0][0]=-8;  Массив[0][1]=14;  Массив[0][2]=19;  Массив[0][3]=18;
   Массив[1][0]=25;  Массив[1][1]=28;  Массив[1][2]=26;  Массив[1][3]=20;
   Массив[2][0]=11;  Массив[2][1]=18;  Массив[2][2]=20;  Массив[2][3]=25;

Необходимо вычислить разницу между максимальным и минимальным элементом массива

Напишите пожалуйста код. Потому как я примерно понимаю что нужно делать, только вот знаний синтаксиса языка 1с мне пока не хватает


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Прикольные задачки такие!
вот самый простой код

Сообщить("Разность между максимальным и минимальным значением = " + (Массив[1][1] - Массив[0][0]) );
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн DmitriyF

  • *****
  • Сообщений: 729
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Имеется массив

Массив = Новый Массив (3, 4);
   Массив[0][0]=-8;  Массив[0][1]=14;  Массив[0][2]=19;  Массив[0][3]=18;
   Массив[1][0]=25;  Массив[1][1]=28;  Массив[1][2]=26;  Массив[1][3]=20;
   Массив[2][0]=11;  Массив[2][1]=18;  Массив[2][2]=20;  Массив[2][3]=25;

Необходимо вычислить разницу между максимальным и минимальным элементом массива

Напишите пожалуйста код. Потому как я примерно понимаю что нужно делать, только вот знаний синтаксиса языка 1с мне пока не хватает
решают задачи немного в другом разделе а так хотя бы примерный свой код выложите чтобы можно было вас отправить в нужное русло. Ведь как известно если не программировать то хоть сто книг перечитай все равно не науишься

Оффлайн jenya1111

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-17
  • Сайт: 
  • Профессия: Программист 8.1
Прикольные задачки такие!
вот самый простой код

Сообщить("Разность между максимальным и минимальным значением = " + (Массив[1][1] - Массив[0][0]) );

Такой вариант увы не подойдет. Это просто задача. И поэтому решение не является верным т.к. если предположить, что в массиве на 100000000 элементов с неизвестными мне значениями, то вашим вариантом ее решить не получиться
Добавлено: 16 Июл 2014, 12:42

Имеется массив

Массив = Новый Массив (3, 4);
   Массив[0][0]=-8;  Массив[0][1]=14;  Массив[0][2]=19;  Массив[0][3]=18;
   Массив[1][0]=25;  Массив[1][1]=28;  Массив[1][2]=26;  Массив[1][3]=20;
   Массив[2][0]=11;  Массив[2][1]=18;  Массив[2][2]=20;  Массив[2][3]=25;

Необходимо вычислить разницу между максимальным и минимальным элементом массива

Напишите пожалуйста код. Потому как я примерно понимаю что нужно делать, только вот знаний синтаксиса языка 1с мне пока не хватает
решают задачи немного в другом разделе а так хотя бы примерный свой код выложите чтобы можно было вас отправить в нужное русло. Ведь как известно если не программировать то хоть сто книг перечитай все равно не науишься

На счет отправления в другой раздел был бы примного благодарен.
Кода у меня нет. Там и решение не очень длинное должно быть строк может 5-8. На счет остального не соглашусь, так как имею  иную педагогическую точку зрения ;)

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
да что вы пристали к jenya1111, человек учится не программированию 1С а менеджированию разработки проектов 1С,
а там задача как раз и стоит в том что бы не самому решать какие-то задачки,
а напрягать коллектив программистов (в нашем случае форум) для решения этих задачек!
и в эти функции как раз потом и входит, проверить код и слегка похвалить какого-то форумчанина за написанный код!!!
(и форумчанину приятно, какой он умный такую тривиальщину новичку (за новичка) решил,
и Женя рад, очередная задача решена, можно переходить к следующей)
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн jenya1111

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-17
  • Сайт: 
  • Профессия: Программист 8.1
Моя работа вообще никак не связана с 1с. Просто мне это интересно и я хочу научиться. Но я не понимаю  каким образом я могу научиться если буду сидеть и думать как написать то чего не знаю. Это же просто бессмысленно. При том я же написал в 1 сообщении что знаю  решение, я просто не знаю как все это пишется в 1с. Это то же самое что учиться какому либо языку не имея под рукой его алфавита. И только не надо мне рассказывать про синтаксис помошник. С вашей помощью. Потому как с вашей помощью все дело идет гораздо быстрее. И если у вас нет желания помочь. То зачем тратить свое и мое время.  Просто не заходите в данную тему и все.  Сюда зайдут другие люди у которых  есть желание помочь и помогут.  Разве не в этом суть данного форума??????? 

Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Ваша платформа!??

Решение на платформе 8.2:

Массив = Новый Массив (3, 4);
   Массив[0][0]=-8;  Массив[0][1]=14;  Массив[0][2]=19;  Массив[0][3]=18;
   Массив[1][0]=25;  Массив[1][1]=28;  Массив[1][2]=26;  Массив[1][3]=20;
   Массив[2][0]=11;  Массив[2][1]=18;  Массив[2][2]=20;  Массив[2][3]=25;

  // Ищем мин/макс значения
  минЗн  = Массив.Получить(0).Получить(0);
  максЗн = Массив.Получить(0).Получить(0);
  Для Каждого стр Из Массив Цикл
    Для Каждого кол Из стр Цикл
Если кол < минЗн Тогда
    минЗн = кол;
КонецЕсли;
Если кол > максЗн Тогда
    максЗн = кол;
КонецЕсли;
    КонецЦикла; 
  КонецЦикла;
  // Результат
  Сообщить("Мин/Макс значение: " + Строка(минЗн) + " / " + Строка(максЗн));
  Сообщить("Разность значений: " + Строка(максЗн - минЗн));

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Так вам, уже несколько раз решили такие задачки с массивами! Там все комманды, для решения этой задачки есть, и вы все равно не знаете как решить эту задачу. Зачем тогда присылать вам код решения этих задач, если вы его совсем не понимаете и не можете использовать для решения новых задач?
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
да что вы пристали к jenya1111, человек учится не программированию 1С а менеджированию разработки проектов 1С,
а там задача как раз и стоит в том что бы не самому решать какие-то задачки,
а напрягать коллектив программистов (в нашем случае форум) для решения этих задачек!
и в эти функции как раз потом и входит, проверить код и слегка похвалить какого-то форумчанина за написанный код!!!
(и форумчанину приятно, какой он умный такую тривиальщину новичку (за новичка) решил,
и Женя рад, очередная задача решена, можно переходить к следующей)

Менеджер проектов 1С, не умеющий программить? ну ну.
Форум (по мне) несколько другим целям служит.
Не делать за кого-то, а направлять на правильный путь.

Без похвалы от новичка - я как нить переживу...

Мое стойкое мнение, что большинство тех кто отвечает на вопросы - работающие 1Сники.
И имея свои реальные рабочие задачи времени как раз и остается на "...проверить код и слегка похвалить какого-то форумчанина за написанный код..."
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Так вам, уже несколько раз решили такие задачки с массивами! Там все комманды, для решения этой задачки есть, и вы все равно не знаете как решить эту задачу. Зачем тогда присылать вам код решения этих задач, если вы его совсем не понимаете и не можете использовать для решения новых задач?
В данном случае 2-мерный массив - работа с ним имеет особенности.
Проще дать код, чем впустую столько слов.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4376
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 190
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal