Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 16:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Срочно нужна помошь, чайнику... тема легкотня  (Прочитано 1271 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Azamat Faizov

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
В Обработке в форме которой при нажатии нужной кнопки табличная часть сохраняется в документе, не выставляются в полях документа такие реквизиты номенклатуры как: Код, Артикул, Поставщик, Бренд, Статус. Всё это нужно брать из уже созданного регистра сведений "Матрица".


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Azamat Faizov

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-25
  • Сайт: 
  • Профессия: Ученик 1С
(0) код ПОКАЖИ.

Процедура кнЗаказНажатие(Элемент)
   Если флВозврата Тогда
      Возврат;
   КонецЕсли;
   
   Если тчТМЦ.Количество() > 0 Тогда
      Если Вопрос("Отправить заказ?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
         Возврат;
      КонецЕсли;
      ДокЧек.тчТМЦ.Очистить();          
      ДокЧек1   = Документы.ЗаказИзМагазина.СоздатьДокумент();
      ДокЧек1.Дата   = ТекущаяДата();
      ДокЧек1.УстановитьНовыйНомер();
      ДокЧек1.МестоХранения = ДокЧек.МестоХранения;
      ДокЧек1.Фирма = ДокЧек.Фирма;
      
      Для Каждого Строка Из тчТМЦ Цикл
         СтрокаТЧ   = ДокЧек1.тчТМЦ.Добавить();
         ЗаполнитьЗначенияСвойств(СтрокаТЧ,Строка);

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
(0) код ПОКАЖИ.

Процедура кнЗаказНажатие(Элемент)
   Если флВозврата Тогда
      Возврат;
   КонецЕсли;
   
   Если тчТМЦ.Количество() > 0 Тогда
      Если Вопрос("Отправить заказ?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
         Возврат;
      КонецЕсли;
      ДокЧек.тчТМЦ.Очистить();          
      ДокЧек1   = Документы.ЗаказИзМагазина.СоздатьДокумент();
      ДокЧек1.Дата   = ТекущаяДата();
      ДокЧек1.УстановитьНовыйНомер();
      ДокЧек1.МестоХранения = ДокЧек.МестоХранения;
      ДокЧек1.Фирма = ДокЧек.Фирма;
      
      Для Каждого Строка Из тчТМЦ Цикл
         СтрокаТЧ   = ДокЧек1.тчТМЦ.Добавить();
         ЗаполнитьЗначенияСвойств(СтрокаТЧ,Строка);

Конечно у вас не чего не будет попадать, вы же табличную часть почистили!

ДокЧек.тчТМЦ.Очистить();

И вы пишите про регистр а сами получаете данные из документа!?

 

Добавлено: 16 Июл 2014, 09:14

И если вы работаете с документом то пишите тогда одни переменные
ДокЧек.тчТМЦ
и у вас не весь код мы не телепаты!
Помогли, отблагодари!

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(2) В КАКОМ месте ПОКАЗАННОГО кода происходит заполнение
реквизиты номенклатуры как: Код, Артикул, Поставщик, Бренд, Статус.

?????????????
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


 

Нужна помощь про "Отчет о смене без гашение" и "Z отчет"

Автор Serg85Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3761
Последний ответ 23 Ноя 2014, 12:36
от дфтын
Нужна помощь по "Управление торговлей 10.3"

Автор werstakРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1973
Последний ответ 26 Мар 2011, 12:50
от werstak
Нужна ВПФ - дайте рыбу "СчетНаОплатуПокупателю" для 1с 8.2. УТ 10

Автор Anton99Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3329
Последний ответ 09 Окт 2011, 20:25
от Anton99
Кому нужна инф. по конфе "Конвертация"

Автор ВоронкинРаздел Закрытые темы

Ответов: 2
Просмотров: 3818
Последний ответ 09 Фев 2012, 19:38
от Столяр
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2094
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 607
  • Точка Скрытых: 1
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal