Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 16:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сменить цыет формы в УП  (Прочитано 1014 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Добрый вечер, ребят... подскажите как во внешней обработке для управляемых приложений настроить функцию смены цвета.
Нужно изменить ЦветФона и ЦветПанель (ЦветПанель - это Стринцы с закладками + цвета кнопок на форме).
В обычном приложении работало так:
(обращаемся из модуля объекта внешней обработки)
Форма.Панель1.ЦветФона=ЦветФона;   

Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/


Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
вверх
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
ЭлементыФормы - не пробовали?
Помогли, отблагодари!

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Пробую так:
                 
Для Каждого эл Из Форма.Элементы Цикл
Если эл.Вид = ВидГруппыФормы.ОбычнаяГруппа Тогда
    Попытка эл.ЦветФонаШапки=Цвет_База; Исключение КонецПопытки;
КонецЕсли;
КонецЦикла;
так вот в УП нет ЦветФонаШапки, только ЦветТекстаЗаголовка.
Добавлено: 16 Июл 2014, 09:49

Кажется не много разобрался, ЦветФона есть, но не у всех элементов формы.

Если эл.Вид = ВидГруппыФормы.ГруппаКнопок Тогда
    Попытка эл.ЦветФона = Цвет_Панель; Исключение КонецПопытки;
КонецЕсли;
через отладчик эл.Вид имеет значение "Обычная кнопка". Пытаюсь отловить кнопку... как это сделать?


Добавлено: 16 Июл 2014, 09:50

Условие
 эл.Вид = ВидГруппыФормы.ГруппаКнопок
не работает.
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Последний раз редактировалось: Gendelf; 16 Июл 2014, 09:50. Причина: Объединение сообщений


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 638
Последний ответ 21 Сен 2017, 10:33
от Insider
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 158
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5259
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3803
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5800
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
55 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 222
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal