Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 13:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как при изменении объекта изменить значение всех элементов табличной части.  (Прочитано 2411 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Серега16

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-06
  • Сайт: 
День Добрый как сделать чтоб при изменении Объекта в форме изменялась цена в ТабличнойЧасти формы?
Есть вот такой код
Процедура КоличествоДнейПриИзменении(Элемент)
  ТабСтрока=элементы.ВыбрТовара.ТекущиеДанные;
  ТабСтрока.Цена = ПолучениеЦеныПроката(ТабСтрока.ПрокатныйНомер);
  ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
 
КонецПроцедуры

Но он действует только на тот элемент табличной части который выделен, а остальные остаются не именными.
Пробывал добавить
Для каждого стр Из Объект.ВыбрТовара Цикл
   
   ТабСтрока.ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
 
  КонецЦикла;
Не помогло.


Оффлайн wise

  • *****
  • Сообщений: 510
  • РЕПУТАЦИЯ: 65
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0)мысль ПРАВИЛЬНАЯ!
Для каждого стр Из Объект.ВыбрТовара Цикл
   
   ТабСтрока.ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
    
  КонецЦикла;

Процедура КоличествоДнейПриИзменении(Элемент)
    Для каждого ТекСтр Из Объект.ВыбрТовара Цикл   
        Цена = ПолучениеЦеныПроката(ТекСтр.ПрокатныйНомер)
       ТекСтр.ЦенаИтог = Цена * КоличествоДней;
   КонецЦикла;
КонецПроцедуры
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Серега16

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-06
  • Сайт: 
(0)мысль ПРАВИЛЬНАЯ!
Для каждого стр Из Объект.ВыбрТовара Цикл
   
   ТабСтрока.ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
     
  КонецЦикла;

Процедура КоличествоДнейПриИзменении(Элемент)
    Для каждого ТекСтр Из Объект.ВыбрТовара Цикл   
        Цена = ПолучениеЦеныПроката(ТекСтр.ПрокатныйНомер)
       ТекСтр.ЦенаИтог = Цена * КоличествоДней;
   КонецЦикла;
КонецПроцедуры
Спасибо помогло. Правда у меня он выглядит так
Для каждого ТекСтр Из Объект.ВыбрТовара Цикл   
        ТекСтр.Цена = ПолучениеЦеныПроката(ТекСтр.ПрокатныйНомер);
        ТекСтр.ЦенаИтог = ТекСтр.Цена *Объект.КоличествоДней ;
   КонецЦикла;


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7930
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4151
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1311
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1441
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10301
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
73 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
41 Сообщений
wise wise
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
Анюта17
25 Сообщений

* Кто онлайн

  • Точка Гостей: 782
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal