Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 17:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как при изменении объекта изменить значение всех элементов табличной части.  (Прочитано 2029 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Серега16

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-06
  • Сайт: 
День Добрый как сделать чтоб при изменении Объекта в форме изменялась цена в ТабличнойЧасти формы?
Есть вот такой код
Процедура КоличествоДнейПриИзменении(Элемент)
  ТабСтрока=элементы.ВыбрТовара.ТекущиеДанные;
  ТабСтрока.Цена = ПолучениеЦеныПроката(ТабСтрока.ПрокатныйНомер);
  ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
 
КонецПроцедуры

Но он действует только на тот элемент табличной части который выделен, а остальные остаются не именными.
Пробывал добавить
Для каждого стр Из Объект.ВыбрТовара Цикл
   
   ТабСтрока.ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
 
  КонецЦикла;
Не помогло.


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0)мысль ПРАВИЛЬНАЯ!
Для каждого стр Из Объект.ВыбрТовара Цикл
   
   ТабСтрока.ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
    
  КонецЦикла;

Процедура КоличествоДнейПриИзменении(Элемент)
    Для каждого ТекСтр Из Объект.ВыбрТовара Цикл   
        Цена = ПолучениеЦеныПроката(ТекСтр.ПрокатныйНомер)
       ТекСтр.ЦенаИтог = Цена * КоличествоДней;
   КонецЦикла;
КонецПроцедуры
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Серега16

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-06
  • Сайт: 
(0)мысль ПРАВИЛЬНАЯ!
Для каждого стр Из Объект.ВыбрТовара Цикл
   
   ТабСтрока.ЦенаИтог= ТабСтрока.Цена*объект.КоличествоДней;
     
  КонецЦикла;

Процедура КоличествоДнейПриИзменении(Элемент)
    Для каждого ТекСтр Из Объект.ВыбрТовара Цикл   
        Цена = ПолучениеЦеныПроката(ТекСтр.ПрокатныйНомер)
       ТекСтр.ЦенаИтог = Цена * КоличествоДней;
   КонецЦикла;
КонецПроцедуры
Спасибо помогло. Правда у меня он выглядит так
Для каждого ТекСтр Из Объект.ВыбрТовара Цикл   
        ТекСтр.Цена = ПолучениеЦеныПроката(ТекСтр.ПрокатныйНомер);
        ТекСтр.ЦенаИтог = ТекСтр.Цена *Объект.КоличествоДней ;
   КонецЦикла;


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6870
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3237
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 972
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1086
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8531
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 239
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal