Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 18:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть форму документа и поставить курсор на заданую строку  (Прочитано 4824 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Из одного документа Док1 открывается документ Док2
Причем активной становится Страница2, и нужно поставить курсор на определенную строку.
Не понимаю почему не срабатывает этот код:
&НаКлиенте
Процедура ИнфоДок2Нажатие(Элемент)
ТекДанные = Элементы.Док2.ТекущиеДанные;
Если ТекДанные = Неопределено Тогда
Сообщить("не выбрана Док2...");
Возврат;
КонецЕсли;

Параметр = Новый Структура("Ключ",ТекДанные.Док2);
Форма = ПолучитьФорму("Документ.Док2.Форма.УПФормаДокумента",Параметр);

Если Элементы.Док2.ТекущиеДанные.НомерСтр = 0 ТОгда
  Сообщить("не выбрана строка Док2...");
  Иначе
Форма.Элементы.Страницы.ТекущаяСтраница=Форма.Элементы.Страницы.ПодчиненныеЭлементы.Страница2;
// проверяю в отладчике -  Элементы.Док2.ТекущиеДанные.ПолучитьИдентификатор() число 2 он же номер строки. Но при открытии формы курсор не становится на 2 строку.
 Форма.Элементы.Док2.ТекущаяСтрока = Элементы.Док2.ТекущиеДанные.ПолучитьИдентификатор();
КонецЕсли;
 
Форма.Открыть();
КонецПроцедуры



Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Так я вроде так и делаю. Получаю идентификатор и ставлю на такую строку в другом документе. А не выходит .

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
значит СМОТРИ, что делается ПриОткрытии() в форме.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15946
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4202
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7751
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4787
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 245
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal