Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 17:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите написать код  (Прочитано 1666 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jenya1111

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-17
  • Сайт: 
  • Профессия: Программист 8.1
Есть такая задача
Массив = Новый Массив(7);
Массив[0]=5;
Массив[1]=-5;
Массив[2]=6;
Массив[3]=1;
Массив[4]=6;
Массив[5]=6;
Массив[6]=4;

необходимо сообщить номер наименьшего числа


Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
самый просотой пример,  допиши код 
 Сообщить(Массив.Получить(1));

Оффлайн jenya1111

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-17
  • Сайт: 
  • Профессия: Программист 8.1
Не понятно. Можно подробнее?

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
самый просотой пример,  допиши код 
 Сообщить(Массив.Получить(1));

в итоге Вам система выдаст сообщение -5. 

Оффлайн jenya1111

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-17
  • Сайт: 
  • Профессия: Программист 8.1
Блин извини. Мы просто друк друга не так поняли. Мне нужно чтобы программа мне показала не значение наименьшего индекса а его если можно можно так выразиться "порядковый номер"

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
тогда немного по другому

Сообщить("Номер: " + Массив.Найти(-5));

я проверил, на вашем массиве, все работает! просто супер!
1С рулит! :D
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн jenya1111

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-17
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо все получилось

Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Спасибо все получилось
Что-то непонятно что же "получилось". Я, например, понял задачу как "найти минимальное значение и сообщить его номер (или индекс)".
Задача в моем понимании решается так:

arr = Новый Массив (7);
arr[0] = 5;
arr[1] = -5;
arr[2] = 6;
arr[3] = 1;
arr[4] = 6;
arr[5] = 6;
arr[6] = 4;

Для Каждого i Из arr Цикл
  Сообщить("Элемент массива: " + i);
КонецЦикла;

// ищем минимальное значение и его индекс
min = arr[0]; indx = -1;
Для Каждого i Из arr Цикл
  indx = indx + 1;
  Если i < min Тогда
    min = i;
    nMin = indx;
  КонецЕсли;
КонецЦикла;
Сообщить("------");
// результат
Сообщить("Индекс мин. значения: " + nMin);
Сообщить("Минимальное значение: " + min);

В окне сообщения Вы получите:
- массив;
и через разделитель
- Индекс мин. значения: 1;
- Минимальное значение: -5.
Если нужен номер - добавьте к индексу "1".


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4294
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5891
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4374
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 578
  • Точка Скрытых: 1
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal