Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 00:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Корректно отобразить расшифровку по строке  (Прочитано 983 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
В табличной части  Документа есть реквизит ТТН.
В управляемой форме при перемещении по строкам табличной части, надо расшифровать данные по реквизиту ТТН.
Делаю так
&НаКлиенте
Процедура ТТНПриАктивизацииСтроки(Элемент)

Расшифровка =Элементы.ТТН.ТекущиеДанные.ТТН;

Если Элемент.ТекущиеДанные <> Неопределено Тогда
Если Элемент.ТекущиеДанные.ТТН <> Неопределено Тогда
Элементы.ИнфоТТН.Заголовок=ПолучитьЗаголовокТТН(Элемент.ТекущиеДанные.ТТН);
КонецЕсли;
КонецЕсли;

КонецПроцедуры


&НаСервере
Функция ПолучитьЗаголовокТТН(Р)
   Отбор = Новый Структура();
   Отбор.Вставить("Ссылка", Р);
   НайденноеЗначение = Документы.ТТН.НайтиПоРеквизиту(Отбор);
   
   Возврат НайденноеЗначение.Культура;

КонецФункции

Отладчик показывает что все зациклилось. Подскажи, пожалуйста, в чем ошибка?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вместо

       Отбор = Новый Структура();
       Отбор.Вставить("Ссылка", Р);
       НайденноеЗначение = Документы.ТТН.НайтиПоРеквизиту(Отбор);
       
       Возврат НайденноеЗначение.Культура;

достаточно

       Возврат Р.Культура;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6829
Последний ответ 18 Сен 2011, 16:07
от Хеля
В строке "1" табличной части "Состав набора": Не заполнено значение реквизитов Цена

Автор rusalkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2431
Последний ответ 11 Апр 2014, 16:52
от rusalka
УНФ планировщик выдает на план-графике вместо контрагентов <Точка 1>, <Точка 2> и т.д. Как можно отобразить наименования контрагентов вместо точек?

Автор olesya9393Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 494
Последний ответ 09 Янв 2017, 12:55
от olesya9393
Адрес в строке "Грузополучатель" в счете-фактуре

Автор МаксиРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1742
Последний ответ 04 Дек 2015, 11:05
от Макси
в строке номер документа основания (108)не сохраняется "0"

Автор NadinAstraРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 1558
Последний ответ 04 Май 2016, 14:23
от Игорь Иванов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 179
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal