Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 14:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как добавить пробелы  (Прочитано 5861 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Denka

  • ***
  • Сообщений: 126
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-02
  • Сайт: 
Добрый день. Я вывожу индекс, как мне програмно поставить пробелы между цифрами. Спасибо


Оффлайн freez1301

  • ***
  • Сообщений: 130
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2014-04-25
  • Сайт: 
  • Профессия: Ученик 1С
ДлинаСтрока = СтрДлина(СтрокаИндекс);
Для Счетчик = 1 По ДлинаСтрока Цикл
СтрокаСПробелами = Лев(СтрокаИндекс, Счетчик);
СтрокаСПробелами = СтрокаСПробелами + " " + Лев(СтрокаИндекс, Счетчик)
Счетчик = Счетчик +1;
КонецЦикла;

Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
так короче и понятнее,

СтрокаСПробелами="";
ДлинаСтроки = СтрДлина(СтрокаИндекс);
Для Счетчик = 1 По ДлинаСтроки Цикл
   СтрокаСПробелами = СтрокаСПробелами + Сред(СтрокаИндекс, Счетчик, 1)+ " ";
КонецЦикла;
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Denka

  • ***
  • Сообщений: 126
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-02
  • Сайт: 
так короче и понятнее,

СтрокаСПробелами="";
ДлинаСтроки = СтрДлина(СтрокаИндекс);
Для Счетчик = 1 По ДлинаСтроки Цикл
   СтрокаСПробелами = СтрокаСПробелами + Сред(СтрокаИндекс, Счетчик, 1)+ " ";
КонецЦикла;

не понятно)
Добавлено: 08 Июл 2014, 10:38

ДлинаСтрока = СтрДлина(СтрокаИндекс);
Для Счетчик = 1 По ДлинаСтрока Цикл
СтрокаСПробелами = Лев(СтрокаИндекс, Счетчик);
СтрокаСПробелами = СтрокаСПробелами + " " + Лев(СтрокаИндекс, Счетчик)
Счетчик = Счетчик +1;
КонецЦикла;
спасибо
Добавлено: 08 Июл 2014, 10:39

так короче и понятнее,

СтрокаСПробелами="";
ДлинаСтроки = СтрДлина(СтрокаИндекс);
Для Счетчик = 1 По ДлинаСтроки Цикл
   СтрокаСПробелами = СтрокаСПробелами + Сред(СтрокаИндекс, Счетчик, 1)+ " ";
КонецЦикла;
что куда писать?не догоняю

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
С моей точки зрения строка с каждым пробелом увеличивается на 1 символ, поэтому мне кажется нужно учитывать символ или разбивать строку на массив символов, а затем складывать строку из массива добавляя пробел. Т.е. приблизительно знаем длину через СтрДлина(СокрЛП(ИсхСтрока)), а дальше уже работа с по разбиению и слиянию символов с пробелами.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
что куда писать?не догоняю

... нас не догонят !!!

все зависит как вы программируете, если вам эти пробелы нужны в одном только месте целой кофигурации, то прямо в то место программы и вставляете этот кусочек кода, и у вас получается СтрокаСПробелами это ваш индекс с пробелами.

если индексы или другие строки надо частенько разбавлять пробелами, то лучше сделать экспортную функцию в общем модуле
Функция ВставитьПробелы(СтрокаБезПробелов)Экспорт
... (код см.выше)
Возврат СтрокаСПробелами;
КонецФункции

а у себя в программе пишите следующий код

ИндексСПробелами = ВставитьПробелы(Индекс);

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Denka

  • ***
  • Сообщений: 126
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-02
  • Сайт: 
Цитировать
что куда писать?не догоняю

... нас не догонят !!!

все зависит как вы программируете, если вам эти пробелы нужны в одном только месте целой кофигурации, то прямо в то место программы и вставляете этот кусочек кода, и у вас получается СтрокаСПробелами это ваш индекс с пробелами.

если индексы или другие строки надо частенько разбавлять пробелами, то лучше сделать экспортную функцию в общем модуле
Функция ВставитьПробелы(СтрокаБезПробелов)Экспорт
... (код см.выше)
Возврат СтрокаСПробелами;
КонецФункции

а у себя в программе пишите следующий код

ИндексСПробелами = ВставитьПробелы(Индекс);


все разобрался спасибо

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
так короче и понятнее,

СтрокаСПробелами="";
ДлинаСтроки = СтрДлина(СтрокаИндекс);
Для Счетчик = 1 По ДлинаСтроки Цикл
   СтрокаСПробелами = СтрокаСПробелами + Сред(СтрокаИндекс, Счетчик, 1)+ " ";
КонецЦикла;


Тока надо не забыть "откусить" последний пробел тем же СокрЛП() ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Тока надо не забыть "откусить" последний пробел тем же СокрЛП()
Автор куда то на печать выводит такой "разбавленый" индекс, действительно что бы цифры не сливались, поэтому последний пробел не актуален, при печати его все равно не видно.
а если уже нормально писать "раздвижку" то надо еще контролировать и количество вставляемых пробелов (или задавать их количество параметром), что бы два раза(и более) нельзя было вставить больше нужного пробелов.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Цитировать
Тока надо не забыть "откусить" последний пробел тем же СокрЛП()
Автор куда то на печать выводит такой "разбавленый" индекс, действительно что бы цифры не сливались, поэтому последний пробел не актуален, при печати его все равно не видно.
а если уже нормально писать "раздвижку" то надо еще контролировать и количество вставляемых пробелов (или задавать их количество параметром), что бы два раза(и более) нельзя было вставить больше нужного пробелов.

Вот я и предложил разложить в массив символов, а потом пробежаться складывая бутербродом с пробелом массив символов. Например так
// получили массив индексов до этого из индекса разбиением на символы
СтрокаСпробелами = Массив[1];
Для Номер = 2 По (КонецМассива) Цикл
  СтрокаСпробелами = СтрокаСпробелами  + " " + Массив[Номер];
КонецЦикла;
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 

Добавить поле "Свойство" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 312
Последний ответ 24 Фев 2018, 14:40
от useronforum
Добавить поле "Комментарий" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 272
Последний ответ 03 Мар 2018, 16:14
от useronforum
Как добавить столбец "Номенклатура" в таблицу "Реализация товаров и услуг"

Автор ZanderBlackРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10907
Последний ответ 19 Ноя 2012, 11:12
от Gunner
Не активны кнопки "Добавить" и "Удалить" дополнительные строки в отчете по НДС

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 316
Последний ответ 25 Янв 2018, 14:50
от kiksi
Документ "Поступление товаров и услуг" - как добавить графу "единица измерения"

Автор asolРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6558
Последний ответ 29 Мар 2012, 14:40
от Essential

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
AIFrame AIFrame
56 Сообщений
oleg-x
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 235
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal