Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 18:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрет редактирования спецификаций  (Прочитано 4033 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EgorL

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-04
  • Сайт: 
  • Профессия: Ученик 1С
Возникла задача запретить пользователям УПП редактировать утверждённые спецификации. Создал роль, по подписке на запись делаю проверку поля "состояние" -- если "Утверждён", посылаем пользователя к руководству. Но так пользователь может изменить поле "Состояние" на другое значение и сохранить изменённую спецификацию.
Подскажите, как можно узнать сохранённое состояние спецификации, а не то которое в форме?
Процедура ЗапретИзмененияСпецификаций(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
Если Строка(Источник.Состояние) = "Утвержден" Тогда
                Разрешить = РольДоступна("ИзменениеСпецификаций");
                Если НЕ Разрешить Тогда
                         Отказ = Истина;
                         Сообщить("У вас нет прав на изменение Утверждённых спецификаций!", СтатусСообщения.Важное);
                КонецЕсли;
КонецЕсли;
КонецПроцедуры


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Надо в форме в событии перед открытием проверить Состояние, если утверждено то форму открыть в режиме только просмотр
пример

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
...
Если Состояние = "Утверждено" Тогда
ЭтаФорма.ТолькоПросмотр = Истина;   
КонецЕсли;
...
КонецПроцедуры
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн EgorL

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-04
  • Сайт: 
  • Профессия: Ученик 1С
Надо в форме в событии перед открытием проверить Состояние, если утверждено то форму открыть в режиме только просмотр
пример

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
...
Если Состояние = "Утверждено" Тогда
ЭтаФорма.ТолькоПросмотр = Истина;   
КонецЕсли;
...
КонецПроцедуры

К сожалению нет такого события ("ПередОткрытием") в подписке на спецификацию...

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
да при чем здесь подписка? в форме документа, это событие!
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн EgorL

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-04
  • Сайт: 
  • Профессия: Ученик 1С
да при чем здесь подписка? в форме документа, это событие!
Я пока не готов править конфигурацию.

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
:D :D ну насмешили, чуть со стула не упал :D:D
Цитировать
Я пока не готов править конфигурацию.

а создание роли
Цитировать
Создал роль,

а редактирование подписки на событие,
Цитировать
по подписке на запись делаю проверку поля "состояние"

это тогда что?
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Можно проверить в ПередЗаписью - сравнить объект с объектом в базе, и уже принимать решение - разрешать запись или нет.

LexaK, это ДОБАВЛЕНИЕ новых объектов, автор, видимо, не хочет влазить в типовые объекты.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
можно попробовать еще через роль(добавленную), в правах на документ Спецификация на право Изменение в ограничении добавить условие
...
Статус <> "Утверждено"
...

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн EgorL

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-04
  • Сайт: 
  • Профессия: Ученик 1С
LexaK, это ДОБАВЛЕНИЕ новых объектов, автор, видимо, не хочет влазить в типовые объекты.
Совершенно верно.
quote author=Klyacksa link=topic=40936.msg115172#msg115172 date=1404458921]
можно попробовать еще через роль(добавленную), в правах на документ Спецификация на право Изменение в ограничении добавить условие
...
Статус <> "Утверждено"
...
[/quote]
Если я правильно понял, тогда придётся эту роль всем пользователям назначать, кроме тех кому можно. Так можно кого нить упустить.
Можно проверить в ПередЗаписью - сравнить объект с объектом в базе, и уже принимать решение - разрешать запись или нет.
А вот как это сделать?

Последний раз редактировалось: EgorL; 04 Июл 2014, 11:50

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Сделайте подписку на событие ПередЗаписью. В ней у вас есть Источник - это уже измененный объект, по идее. У него есть Ссылка. По Ссылке получаете еще не измененный объект.
В итоге Источник.Состояние - это новое состояние, Источник.Ссылка.Состояние - старое состояние.
Проверьте отладчиком.

...
Статус <> "Утверждено"
...
Вот, кстати, тоже вариант.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги: УПП подписка 
 

Для редактирования цены выберите вид цены "<произвольная>"

Автор klassic89Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2114
Последний ответ 18 Фев 2015, 11:16
от SitnovaMarina
Запрет на изменение "справочники - предприятие"

Автор maskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 948
Последний ответ 25 Июл 2016, 09:09
от SGIRG
Как восстановить в ИБ запрет изменения с поддержкой (восстановить серый замочек)

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 992
Последний ответ 06 Июл 2016, 14:55
от ktu78
Установил запрет на редактирование проведенных документов, но продавцы научились его "обходить"

Автор technopartnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3474
Последний ответ 07 Сен 2014, 22:33
от Besart
Запрет на редактирование документов = Автоматизированный выпуск документов строгой отчётности

Автор ПашёкРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 899
Последний ответ 06 Сен 2014, 10:15
от Пашёк

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 461
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal