Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу получить ссылку на элемент справочника из списка значений 1с8.3  (Прочитано 6804 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн krasdok

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-19
  • Сайт: 
  • Профессия: Программист 1С
Немогу получить значения элемента справочника который был помещен в список значений для присвоения их элементам другого справочника.
Ошибка:
{Справочник.Пациенты.Форма.ФормаЭлемента.Форма(36)}: Метод объекта не обнаружен (ПолучитьОбъект)
 Сп=Сп.Значение.ПолучитьОбъект();
 
Делаю так:
 
&НаСервере
Функция ПатологияДобавить()
 // Вставить содержимое обработчика.
  Список = Новый СписокЗначений();
  Список.Очистить();
  Выборка = Справочники.ЗначенияПатологии.Выбрать();
  Пока Выборка.Следующий() Цикл
   Список.Добавить(Выборка.Ссылка, Выборка.Аналит, Истина);
 сообщить("" + Выборка.Аналит);
 КонецЦикла;
  Возврат Список
КонецФункции
 
&НаКлиенте
Процедура ПатологияПриИзменении(Элемент)
 // Вставить содержимое обработчика.
  Список=ПатологияДобавить();
  Для Каждого Элемент Из Список Цикл
  ЭлементСписок=Элемент.Значение;
  ЭлементСписок=ЭлементСписок.ПолучитьОбъект();
  Строка=объект.ТаблицаПоказателей.Добавить();
  Строка.Коэффициент=ЭлементСписок.Коэффициент;

        КонецЦикла;
КонецПроцедуры
 
Голову сломал...
Очень жду помощи!!!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
А где у вас в приведенном коде
"Сп=Сп.Значение.ПолучитьОбъект();"?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн krasdok

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-19
  • Сайт: 
  • Профессия: Программист 1С
Без Сп=Сп.Значение.ПолучитьОбъект(); на другой код ругается.
Вот последняя ошибка...
Что не так делаю???
{Справочник.Пациенты.Форма.ФормаЭлемента.Форма(42)}: Метод объекта не обнаружен (ПолучитьОбъект)
       ЭлементСписок=ЭлементСписок.ПолучитьОбъект();
Добавлено: 03 Июл 2014, 19:16

Одним словом надо значения из одного справочника отобрать и поместить на форму другого справочника при создании элемента.
Добавлено: 04 Июл 2014, 08:46

Одним словом надо элементы одного справочника отсортировать и добавить в таблицу элемента другого справочника при его создании.
Пробую через список значений но не могу добраться из этого списка к реквизитам справочника чтобы их вставить.
Плиз прошу совета и помощи...

Последний раз редактировалось: krasdok; 04 Июл 2014, 08:46. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ПолучитьОбъект() недоступен на клиенте.
Работу с данными осуществляйте только на сервере.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн krasdok

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-19
  • Сайт: 
  • Профессия: Программист 1С
Я уже понял тогда как мне заполнить таблицу справочника используя значеня из другого???
Добавлено: 07 Июл 2014, 18:18

Что посоветуете?
Добавлено: 07 Июл 2014, 19:29

&НаСервере
Процедура ПатологияДобавить()
Выборка = Справочники.ЗначенияПатологии.Выбрать();
Пока Выборка.Следующий() Цикл
       Строка = Объект.ТаблицаПоказателей.Добавить();
       Строка.Показатель=Справочники.Аналиты.НайтиПоНаименованию(Выборка.Наименование).Ссылка;
       Строка.Коэффициент = Выборка.Коэффициент;
КонецЦикла; 

КонецПроцедуры



&НаКлиенте
Процедура ПатологияПриИзменении(Элемент)
  ПатологияДобавить();
  элементы.ТаблицаПоказателей.Обновить();
  КонецПроцедуры

Добавлено: 07 Июл 2014, 19:30

Вот так все заработало...

Последний раз редактировалось: krasdok; 07 Июл 2014, 19:30. Причина: Объединение сообщений


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6501
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4203
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2048
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3896
Последний ответ 15 Дек 2011, 00:04
от Vit1501

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 143
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal