Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 05:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Функция возврата значения реквизита  (Прочитано 3139 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
Здравствуйте, ситуация следующая.
Имеется Документ, в нем ТЧ. В ТЧ есть два реквизита ФИО и Телефон.
ФИО- Тип: СправочникСсылка.КонтактныеЛица.
В Метаданных в Справочнике есть Таблица КонтактныеДанные в ней реквизит Представление в котором хранится номер телефона.  В запросе:
ВЫБРАТЬ
Представление
ИЗ
Справочник.контактныеЛица.КонтактныеДанные
Показано, значение.
Вот код в УФ.
&НаСервере
функция   ТелефонЛица(КонтактныеЛица)
   КонтактныеЛица=КонтактныеЛица.КонтактнаяИнформация;
возврат КонтактныеЛица.Представление;
   
КонецФункции// ТелефонЛица()

&НаКлиенте
Процедура ЗагрузкаВыгрузкаФИОНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Телефон=ТелефонЛица(Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.ФИО);
КонецПроцедуры
Ошибка:
Поле объекта не обнаружено (Представление)
возврат КонтактныеЛица.Представление;

Что не так? Моет кто то сталкивался с этим в БП 3.0. Спасибо


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Хотя бы вот так...

КонтактныеЛица=КонтактныеЛица.КонтактнаяИнформация[0];
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
{Документ.ЗаявкаНаТранспортноеСредство.Форма.ФормаДокумента.Форма(753)}: Ошибка при вызове метода контекста (ТелефонЛица)
  Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Телефон=ТелефонЛица(Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.ФИО);
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
   форма: Элемент
   имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'СправочникТабличнаяЧастьСтрока.КонтактныеЛица.КонтактнаяИнформация'
Добавлено: 02 Июл 2014, 09:41

{Документ.ЗаявкаНаТранспортноеСредство.Форма.ФормаДокумента.Форма(753)}: Ошибка при вызове метода контекста (ТелефонЛица)
  Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Телефон=ТелефонЛица(Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.ФИО);
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
   форма: Элемент
   имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'СправочникТабличнаяЧастьСтрока.КонтактныеЛица.КонтактнаяИнформация'


&НаСервере
функция ТелефонЛица(КонтактныеЛица)
 КонтактныеЛица=КонтактныеЛица.КонтактнаяИнформация[0];
возврат КонтактныеЛица;

КонецФункции// ТелефонЛица()

&НаКлиенте
Процедура ЗагрузкаВыгрузкаФИОНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   СтандартнаяОбработка=Ложь;
  Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Телефон=ТелефонЛица(Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.ФИО);
 
КонецПроцедуры

Добавлено: 02 Июл 2014, 10:24

Сделал, тема закрыта.
Код кому интересно , как это

&НаСервере
Функция ТелефонЛица(ФИО)
   Запрос = новый запрос();
        Запрос.Текст ="ВЫБРАТЬ             
            
            |     Лицо.Ссылка КАК ОбъектВладелец,
            |     Лицо.Представление КАК Представление
            |     ИЗ
            |     Справочник.КонтактныеЛица.КонтактнаяИнформация КАК Лицо
            |    ГДЕ Лицо.Ссылка=&ФизическиеЛица";
            
 Запрос.Параметры.Вставить("ФизическиеЛица", ФИО);
 Рез = Запрос.Выполнить().Выбрать();
  рез.Следующий();
 Возврат рез.Представление;
КонецФункции// ТелефонЛица()

&НаКлиенте
Процедура ЗагрузкаВыгрузкаФИОНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Телефон=ТелефонЛица(Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.ФИО);
КонецПроцедуры

Последний раз редактировалось: denis-moscow1987; 02 Июл 2014, 10:24. Причина: Объединение сообщений


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 332
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1054
Последний ответ 11 Июл 2016, 09:00
от vitasw
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1158
Последний ответ 02 Дек 2016, 12:58
от Jalib
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 453
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
КД, Перенос Реквизита справочника (7.7) в ТЧ справочника 8.2.

Автор EvgenyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3782
Последний ответ 17 Сен 2014, 13:39
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 121
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal