Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 14:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск и удаление ссылок на объект  (Прочитано 6239 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн StrelokCJ

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-01
  • Сайт: 
  • Профессия: Программист 1С
Пытаюсь осуществить внешнюю обработку по поиску и удалению объектов. Выбираем номенклатуру из списка, и по ссылке на номенклатуру ищем и удаляем. Вот сам код:
&НаКлиенте
Процедура Удалить(Команда)
Если (Объект.СсылкаНаОбъект.Пустая() = Истина) Тогда
        Сообщить("Выберите номенклатуру"); 
    Иначе
Ссылки = Новый Массив;
Ссылки.Добавить(Объект.СсылкаНаОбъект);
НайтиПоСсылкамНаСервере(Ссылки);
    КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура НайтиПоСсылкамНаСервере(Ссылки)
ТабСсылок = НайтиПоСсылкам(Ссылки);
Для Каждого Ссылка Из ТабСсылок Цикл 
ЗаписьДок = Ложь;
Объект = Ссылка.ПолучитьОбъект();
КолВо = Объект.ТЧ.Количество();
Пока КолВо > 0 Цикл
Ик = Объект.ТЧ[КолВо-1];
Если Ик.СсылкаНаСправочник<>Объект.СсылкаНаСправочник Тогда Перейти ~Енд;КонецЕсли;
Объект.ТЧ.Удалить(Ик);
~Енд:;
КолВо = КолВо - 1;
КонецЦикла;
Если ЗаписьДок Тогда
режЗаписи=?(Объект.Проведен,РежимзаписиДокумента.Проведение,РежимзаписиДокумента.Запись);
Объект.Записать(режЗаписи);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

С кодом цикла перебора мне помогли на другом форуме, но выскакивает ошибка при выполнении:
{Форма.Форма.Форма(22)}: Метод объекта не обнаружен (ПолучитьОбъект)
Объект = Ссылка.ПолучитьОбъект();
Подскажите в чем дело и как исправить?


Оффлайн andryscha92

  • ****
  • Сообщений: 267
  • РЕПУТАЦИЯ: 4
  • КПД: 1%
  • Регистрация: 2012-01-31
  • Сайт: 
  • Профессия: Программист 1С
Поставь точку останова в цикле и проверь что содержит "ТабСсылок" видимо Неопределено и система не может получить объект так, как нет ссылки.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Видимо в Ссылке - запись регистра, у которой нет метода ПолучитьОбъект().
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
cska-fanat-kz, ээээ, а почему именно запись регистра?))
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Процедура НайтиПоСсылкам возвращает ТЗ с тремя колонками, так что кроме Строки ТЗ еще и номер колонки надо указывать по которому вы пытаетесь получить объект.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
cska-fanat-kz, ээээ, а почему именно запись регистра?))

как один из вариантов )
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 268
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal