Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 18:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Значение не является значением объектного типа (ПолучитьОбласть)  (Прочитано 3296 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tarpet

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-01
  • Сайт: 
  • Профессия: Программист 8.1
Хочу сделать простейшую печатную форму документа, не судите строго я учусь и только начал этим заниматься. Я создал команду в форме документа и описал ее в модуле формы документа, но при нажатии в предприятии на кнопку вылетает ошибка:

&НаСервере
  Функция ПолучитьМакетНаСервере()
  РеквизитФормыВЗначение("Объект").ПолучитьМакет("Печать");
КонецФункции


&НаКлиенте
Процедура ПечатьЛиста(Команда);
  ТабДок = Новый ТабличныйДокумент;

  Макет = ПолучитьМакетНаСервере();

  ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
  ОбластьПодвалЗадания = Макет.ПолучитьОбласть("ПодвалЗадания");
  ОбластьШапкаДокумента = Макет.ПолучитьОбласть("ШапкаДокумента");
  ОбластьЗаданиеВодителю = Макет.ПолучитьОбласть("ЗаданиеВодителю");
  ОбластьТелоЗадания = Макет.ПолучитьОбласть("ТелоЗадания");

  ТабДок.Вывести("ОбластьЗаголовок");
  ТабДок.Вывести("ОбластьПодвалЗадания");
  ТабДок.Вывести("ОбластьШапкаДокумента");
  ТабДок.Вывести("ОбластьЗаданиеВодителю");
  ТабДок.Вывести("ОбластьТелоЗадания");

КонецПроцедуры

Сама ошибка в конфигураторе не вылетает, она вылезает когда в самом предприятии нажимаю на кнопку "Печать листа" и тогда она мне указывает ошибку:
{Документ.МаршрутныйЛист.Форма.ФормаДокумента.Форма(16)}: Значение не является значением объектного типа (ПолучитьОбласть)
  ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок")


Оффлайн DmitriyF

  • *****
  • Сообщений: 741
  • РЕПУТАЦИЯ: 48
  • КПД: 6%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Хочу сделать простейшую печатную форму документа, не судите строго я учусь и только начал этим заниматься. Я создал команду в форме документа и описал ее в модуле формы документа, но при нажатии в предприятии на кнопку вылетает ошибка:

&НаСервере
  Функция ПолучитьМакетНаСервере()
  РеквизитФормыВЗначение("Объект").ПолучитьМакет("Печать");
КонецФункции


&НаКлиенте
Процедура ПечатьЛиста(Команда);
  ТабДок = Новый ТабличныйДокумент;

  Макет = ПолучитьМакетНаСервере();

  ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
  ОбластьПодвалЗадания = Макет.ПолучитьОбласть("ПодвалЗадания");
  ОбластьШапкаДокумента = Макет.ПолучитьОбласть("ШапкаДокумента");
  ОбластьЗаданиеВодителю = Макет.ПолучитьОбласть("ЗаданиеВодителю");
  ОбластьТелоЗадания = Макет.ПолучитьОбласть("ТелоЗадания");

  ТабДок.Вывести("ОбластьЗаголовок");
  ТабДок.Вывести("ОбластьПодвалЗадания");
  ТабДок.Вывести("ОбластьШапкаДокумента");
  ТабДок.Вывести("ОбластьЗаданиеВодителю");
  ТабДок.Вывести("ОбластьТелоЗадания");

КонецПроцедуры

Сама ошибка в конфигураторе не вылетает, она вылезает когда в самом предприятии нажимаю на кнопку "Печать листа" и тогда она мне указывает ошибку:
{Документ.МаршрутныйЛист.Форма.ФормаДокумента.Форма(16)}: Значение не является значением объектного типа (ПолучитьОбласть)
  ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок")
Может попробовать делать на сервере

Доступность:
Сервер, толстый клиент, внешнее соединение.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Хочу сделать простейшую печатную форму документа

ну так и сделайте ее конструктором печати,
заодно увидите, где что создается...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7952
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4173
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1322
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1450
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10323
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
AIFrame AIFrame
56 Сообщений
oleg-x
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 238
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal