Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 06:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как в 1С 8.2 при проведении документа заполнить элемент справочника информацией из документа?  (Прочитано 6072 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Галина55555

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-01
  • Сайт: 
  • Профессия: Программист 1С
В конфигурации создан документ "Регистрация договоров". В нем задаются контрагент, номер и дата регистрации договора, вид договора (договор подряда, договор покупки и т.д.), валюта договора, информация о форме оплаты, сумма договора.
Необходимо, чтобы при его проведении выполнялось следующее:
1)   В справочнике Договора создавался новый элемент, владельцем которого является контрагент,
2)   В справочник записались номер и дата регистрации, вид договора, валюта договора, ссылка на документ, создавший эту запись в    справочнике.
3)   В документ записалась ссылка на этот элемент справочника.
4)   Если в дальнейшем будут внесены корректировки в документ, необходимо, чтобы соответствующие изменения были сделаны и в элементе справочника.


Оффлайн Галина55555

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-01
  • Сайт: 
  • Профессия: Программист 1С
Всем спасибо. Сама себе ответила. Может это будет кому-то полезно

Процедура ПередЗаписью(Отказ)
   // Вставить содержимое обработчика.
   Если СсылкаНаДоговор.Пустая()= Истина Тогда
      ТекСпрДоговор=Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
      ТекСпрДоговор.Владелец=Контрагент;
      ТекСпрДоговор.Дата=Дата;
      ТекСпрДоговор.Номер=Номер;
      ТекСпрДоговор.Наименование=""+ВидДоговораОрганизации.Наименование+" № "+Номер+" от "+Дата;
      ТекСпрДоговор.ВалютаВзаиморасчетов=ВалютаВзаиморасчетов;
      ТекСпрДоговор.ВидУсловийДоговора=Перечисления.ВидыУсловийДоговоровВзаиморасчетов.БезДополнительныхУсловий;
      ТекСпрДоговор.ВидДоговора=ВидДоговораОрганизации.ВидДоговора;
      ТекСпрДоговор.СсылкаНаДокументРегистрацияДоговораОрганизации=Ссылка;
      ТекСпрДоговор.Записать();
      СсылкаНаДоговор=ТекСпрДоговор.Ссылка;
   Иначе
      
      ТекСпрДоговор = СсылкаНаДоговор.ПолучитьОбъект();
      Если ТекСпрДоговор = Справочники.ДоговорыКонтрагентов.ПустаяСсылка() Тогда
          Сообщить(" еще нет");
      Иначе
         ТекСпрДоговор.Владелец=Контрагент;
         ТекСпрДоговор.Дата=Дата;
         ТекСпрДоговор.Номер=Номер;
         ТекСпрДоговор.Наименование=""+ВидДоговораОрганизации.Наименование+" № "+Номер+" от "+Дата;
         ТекСпрДоговор.ВалютаВзаиморасчетов=ВалютаВзаиморасчетов;
         ТекСпрДоговор.ВидУсловийДоговора=Перечисления.ВидыУсловийДоговоровВзаиморасчетов.БезДополнительныхУсловий;
         ТекСпрДоговор.ВидДоговора=ВидДоговораОрганизации.ВидДоговора;
         ТекСпрДоговор.СсылкаНаДокументРегистрацияДоговораОрганизации=Ссылка;
         ТекСпрДоговор.Записать();
      КонецЕсли;

   КонецЕсли;   

КонецПроцедуры


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6879
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2495
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4244
Последний ответ 15 Дек 2011, 00:04
от Vit1501
Чистка справочника "Налоги и взносы"

Автор dim3740Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 642
Последний ответ 17 Май 2017, 17:55
от Геннадий ОбьГЭС
Загрузка из Excel , Загрузка справочника физ.лица и сотрудники

Автор yojРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 270
Последний ответ 24 Янв 2018, 02:55
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
oleg-x
68 Сообщений
alex0402
64 Сообщений
AIFrame AIFrame
59 Сообщений
wise wise
39 Сообщений
buketov.av buketov.av
36 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 317
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal