Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 12:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как в 1С 8.2 при проведении документа заполнить элемент справочника информацией из документа?  (Прочитано 5525 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Галина55555

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-01
  • Сайт: 
  • Профессия: Программист 1С
В конфигурации создан документ "Регистрация договоров". В нем задаются контрагент, номер и дата регистрации договора, вид договора (договор подряда, договор покупки и т.д.), валюта договора, информация о форме оплаты, сумма договора.
Необходимо, чтобы при его проведении выполнялось следующее:
1)   В справочнике Договора создавался новый элемент, владельцем которого является контрагент,
2)   В справочник записались номер и дата регистрации, вид договора, валюта договора, ссылка на документ, создавший эту запись в    справочнике.
3)   В документ записалась ссылка на этот элемент справочника.
4)   Если в дальнейшем будут внесены корректировки в документ, необходимо, чтобы соответствующие изменения были сделаны и в элементе справочника.


Оффлайн Галина55555

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-01
  • Сайт: 
  • Профессия: Программист 1С
Всем спасибо. Сама себе ответила. Может это будет кому-то полезно

Процедура ПередЗаписью(Отказ)
   // Вставить содержимое обработчика.
   Если СсылкаНаДоговор.Пустая()= Истина Тогда
      ТекСпрДоговор=Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
      ТекСпрДоговор.Владелец=Контрагент;
      ТекСпрДоговор.Дата=Дата;
      ТекСпрДоговор.Номер=Номер;
      ТекСпрДоговор.Наименование=""+ВидДоговораОрганизации.Наименование+" № "+Номер+" от "+Дата;
      ТекСпрДоговор.ВалютаВзаиморасчетов=ВалютаВзаиморасчетов;
      ТекСпрДоговор.ВидУсловийДоговора=Перечисления.ВидыУсловийДоговоровВзаиморасчетов.БезДополнительныхУсловий;
      ТекСпрДоговор.ВидДоговора=ВидДоговораОрганизации.ВидДоговора;
      ТекСпрДоговор.СсылкаНаДокументРегистрацияДоговораОрганизации=Ссылка;
      ТекСпрДоговор.Записать();
      СсылкаНаДоговор=ТекСпрДоговор.Ссылка;
   Иначе
      
      ТекСпрДоговор = СсылкаНаДоговор.ПолучитьОбъект();
      Если ТекСпрДоговор = Справочники.ДоговорыКонтрагентов.ПустаяСсылка() Тогда
          Сообщить(" еще нет");
      Иначе
         ТекСпрДоговор.Владелец=Контрагент;
         ТекСпрДоговор.Дата=Дата;
         ТекСпрДоговор.Номер=Номер;
         ТекСпрДоговор.Наименование=""+ВидДоговораОрганизации.Наименование+" № "+Номер+" от "+Дата;
         ТекСпрДоговор.ВалютаВзаиморасчетов=ВалютаВзаиморасчетов;
         ТекСпрДоговор.ВидУсловийДоговора=Перечисления.ВидыУсловийДоговоровВзаиморасчетов.БезДополнительныхУсловий;
         ТекСпрДоговор.ВидДоговора=ВидДоговораОрганизации.ВидДоговора;
         ТекСпрДоговор.СсылкаНаДокументРегистрацияДоговораОрганизации=Ссылка;
         ТекСпрДоговор.Записать();
      КонецЕсли;

   КонецЕсли;   

КонецПроцедуры


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6484
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2026
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3885
Последний ответ 15 Дек 2011, 00:04
от Vit1501
Чистка справочника "Налоги и взносы"

Автор dim3740Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 391
Последний ответ 17 Май 2017, 17:55
от Геннадий ОбьГЭС
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3598
Последний ответ 02 Фев 2014, 21:37
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 834
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal