Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 14:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отчёт по заказам покупателя  (Прочитано 2108 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nikolya228

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Всем Привет!
При формировании отчёта ,программка почему-то выводит всю номенклатуру и при чём несколько раз подряд и не по алфавиту,а не ту которая в заказе покупателя!!! Хотя на мой взгляд Запрос2 составлен правильно!! Подскажите ,что делать ,что бы у меня выводило
заказ покупателя и номенклатуру из этого заказа!Заранее благодарен!

Функция  Печать(Контрагент,ТабДок) Экспорт 
 
   

  ТабДок.Очистить();
   ТабДок.ФиксацияСверху = 3;
      Макет = ПолучитьМакет("Макет");
  ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
  ОбластьДанные = Макет.ПолучитьОбласть("Данные");
      ОбластьДанные2 = Макет.ПолучитьОбласть("Данные2");
      ТабДок.Вывести(ОбластьШапки);
      Запрос = новый Запрос;
  Запрос.УстановитьПараметр("Контрагент",Контрагент);
  Запрос.Текст = "ВЫБРАТЬ
  |   ЗаказПокупателя.Ссылка
  |ИЗ
  | Документ.ЗаказПокупателя КАК ЗаказПокупателя
  |ГДЕ
  |  ЗаказПокупателя.Контрагент = &Контрагент";
  Выборка = Запрос.Выполнить().Выбрать();
  Пока Выборка.Следующий() Цикл
  ОбластьДанные.Параметры.Контрагент = Контрагент;
  ОбластьДанные.Параметры.Ссылка  = Выборка.Ссылка;
 
  ТабДок.Вывести(ОбластьДанные);

 
  Запрос2 = новый запрос;
  Запрос2.УстановитьПараметр("Ссылка",Выборка.Ссылка);
                 Запрос2.Текст = "
  |ВЫБРАТЬ
            |ЗаказПокупателяТовары.Номенклатура
                    |ИЗ
            |Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары,
            |Документ.ЗаказПокупателя КАК ЗаказПокупателя
                |ГДЕ
            |ЗаказПокупателя.Ссылка = &Ссылка";
  Выборка2 = Запрос2.Выполнить().Выбрать();
  Пока Выборка2.Следующий() Цикл
    ОбластьДанные2.Параметры.Номенклатура = Выборка2.Номенклатура;
   
    ТабДок.Вывести(ОбластьДанные2);
  КонецЦикла;
КонецЦикла;
      возврат ТабДок;
КонецФункции;


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
  |ИЗ
               |Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары,
               |Документ.ЗаказПокупателя КАК ЗаказПокупателя
                |ГДЕ
               |ЗаказПокупателя.Ссылка = &Ссылка";

На

  |ИЗ
               |Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары
                |ГДЕ
               |ЗаказПокупателяТовары.Ссылка.Ссылка = &Ссылка";

Но! С таким построением алгоритмов вам не сдать на 1С:Специалист:)
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Достаточно одного запроса:
ВЫБРАТЬ
ЗаказПокупателяТовары.Ссылка КАК Ссылка,
ЗаказПокупателяТовары.Номенклатура
ИЗ
Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары
ГДЕ
ЗаказПокупателяТовары.Ссылка.Контрагент = &Контрагент

СГРУППИРОВАТЬ ПО
ЗаказПокупателяТовары.Ссылка,
ЗаказПокупателяТовары.Номенклатура
ИТОГИ ПО
Ссылка";
Далее - добавляете нужную сортировку и обход запроса по группировкам.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
22 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 1039
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal