Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 13:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрет выбора значений в табличной части  (Прочитано 1809 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Мне необходимо запретить выбор некоторых значений в табличной части. Формы обычные. На нужную ячейку навесила обработчик событий:
Процедура ОбязательствоЛитераОбработкаВыбора(Элемент,  ВыбранноеЗначение, СтандартнаяОбработка)
   
    ПроверкаЗапрета = ПроверитьЗапретНаЛитеры(Дата, ВыбранноеЗначение);
   
    Если НЕ ПроверкаЗапрета = Неопределено Тогда 
        СтандартнаяОбработка=Ложь;
        Предупреждение(Строка(ПроверкаЗапрета.ЗапретУстановил)+" закрыл кодирование на литеру "+СокрЛП(ВыбранноеЗначение)+" с " + Формат(ПроверкаЗапрета.Период, "ДЛФ=Д"));
    КонецЕсли;
   
КонецПроцедуры
 
Все отлично отрабатывает. Но при вводе текста вручную, эта проверка не срабатывает. использовать "ОкончаниеВводаТекста"? но там мы имеем только текст и старое значение...Как правильно выйти из ситуации? спасибо.




Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
неоходимо обрабатывать в событие ПриИзменении
примерно такой код, подправите по ходу отладки

Процедура ОбязательствоЛитераПриИзменении(Элемент)

    ТекущаяСтрока = ЭлементыФормы.ВАШАТАБЛИЧНАЯЧАСТЬ.ТекущаяСтрока;
    Если ПроверитьЗапретНаЛитеры(Дата, ТекущаяСтрока.Литера ) <> Неопределено Тогда
        ТекущаяСтрока.Литера = Неопределено;
    КонецЕсли;
...
КонецПроцедуры

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Да, но тогда потеряется старое значение.
Снимите галку "Редактирование текста", и не парьтесь
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Да, но тогда потеряется старое значение...

Да, но есть событие ПередНачаломРедактирования()
Сохраняйте там станые значения сколько нужно, (в одном документе я так и делаю, сразу всю строчку сохраняю, потом по мере редактирования полей делаю разные проверки, очень удобно)
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Да, но есть событие ПередНачаломРедактирования()
Да, но тогда и советуйте человеку целиком описывая механизм! :)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Огромное спасибо за помощь!!! сделала ПриИзменении)


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1956
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3064
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3098
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 669
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 250
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
56 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 255
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal