Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 06:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Функция передает только одно значение  (Прочитано 4906 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
&НаКлиенте
Процедура ЗагрузкаВыгрузкаАдресНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
ММаршрут= новый СписокЗначений();
ММаршрут.Добавить(Адрес());
         ММаршрут.ОтметитьЭлементы("");
      СписокСтрока = "";
 Для каждого стр из ММаршрут цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Значение + ", ";
   КонецЕсли;
КонецЦикла;
СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Адрес=СписокСтрока;



КонецПроцедуры
&НаСервере
Функция   Адрес()

   
   Запрос = новый запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   КонтактнаяИнформация.Представление как Представление
                  |ИЗ
                  |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация";

   Рез = запрос.Выполнить().Выбрать();

   Пока рез.Следующий() цикл
      Авто=стр.Представление;
   Возврат Авто;   
   КонецЦикла;   

КонецФункции

В РС 4 Значения, а передается только 1, подскажите в чем проблема?
Спасибо.


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Пока рез.Следующий() цикл
    Авто=стр.Представление;
    Возврат Авто;   
КонецЦикла;
 

Вот в этом

Оффлайн Snaky

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 5
  • КПД: 10%
  • Регистрация: 2014-06-18
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ЗагрузкаВыгрузкаАдресНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
ММаршрут= новый СписокЗначений();
ММаршрут.Добавить(Адрес());
         ММаршрут.ОтметитьЭлементы("");
      СписокСтрока = "";
 Для каждого стр из ММаршрут цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Значение + ", ";
   КонецЕсли;
КонецЦикла;
СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Адрес=СписокСтрока;



КонецПроцедуры
&НаСервере
Функция   Адрес()

   
   Запрос = новый запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   КонтактнаяИнформация.Представление как Представление
                  |ИЗ
                  |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация";

   Рез = запрос.Выполнить().Выбрать();

   Пока рез.Следующий() цикл
      Авто=стр.Представление;
   Возврат Авто;   
   КонецЦикла;   

КонецФункции

В РС 4 Значения, а передается только 1, подскажите в чем проблема?
Спасибо.
Функция не может возвращать несколько значений, загоните Ваши результаты в массив и верните его.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В РС 4 Значения, а передается только 1, подскажите в чем проблема?
Спасибо.

Как Вы себе в принципе представляете "цикличное возвращение функцией нескольких значений"???
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
&НаКлиенте
Процедура ЗагрузкаВыгрузкаАдресНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
ММаршрут= новый СписокЗначений();
ММаршрут.Добавить(Адрес());
         ММаршрут.ОтметитьЭлементы("");
      СписокСтрока = "";
 Для каждого стр из ММаршрут цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Значение + ", ";
   КонецЕсли;
КонецЦикла;
СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Адрес=СписокСтрока;

КонецПроцедуры
&НаСервере
Функция   Адрес()

   
   Запрос = новый запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   КонтактнаяИнформация.Представление как Представление
                  |ИЗ
                  |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация";

   Рез = запрос.Выполнить().Выбрать();

   Пока рез.Следующий() цикл
      Авто=стр.Представление;
   Возврат Авто;   
   КонецЦикла;   

КонецФункции

В РС 4 Значения, а передается только 1, подскажите в чем проблема?
Спасибо.
Функция не может возвращать несколько значений, загоните Ваши результаты в массив и верните его.



	Запрос = новый запрос;
Запрос.Текст = "ВЫБРАТЬ
               | КонтактнаяИнформация.Представление как Представление
       
               |ИЗ
               | РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация";


Рез = запрос.Выполнить().Выбрать();


Пока рез.Следующий() цикл
Массив=Новый Массив;

Авто=Рез.Представление;
Массив.Добавить(Авто);

КонецЦикла;

Возврат Массив;


СтандартнаяОбработка=Ложь;
ММаршрут= новый СписокЗначений();
ММаршрут.Добавить(Адрес());
         ММаршрут.ОтметитьЭлементы("");
      СписокСтрока = "";
 Для каждого стр из ММаршрут цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Значение + ", ";
   КонецЕсли;
КонецЦикла;
СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Адрес=СписокСтрока;

Возвращает пустой массив.
Уточните в чем проблема, что не так?

Последний раз редактировалось: Klyacksa; 25 Июн 2014, 11:28. Причина: Не забывайте использовать тег [code]

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Пока рез.Следующий() цикл
      Массив=Новый Массив;

      Авто=Рез.Представление;
      Массив.Добавить(Авто);   
   
КонецЦикла;


а должно быть...

Массив=Новый Массив;
Пока рез.Следующий() цикл
     
      Авто=Рез.Представление;
      Массив.Добавить(Авто);   
   
КонецЦикла;


должен быть не пустой а с последним значением из запроса...

а это

СтандартнаяОбработка=Ложь;
ММаршрут= новый СписокЗначений();
ММаршрут.Добавить(Адрес());
         ММаршрут.ОтметитьЭлементы("");
      СписокСтрока = "";
 Для каждого стр из ММаршрут цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Значение + ", ";
   КонецЕсли;
КонецЦикла;
СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Адрес=СписокСтрока;

к чему?
в любом случае после "Возврат Массив;" ничего из этого не выполнится НИ КОГ ДА...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
Пока рез.Следующий() цикл
      Массив=Новый Массив;

      Авто=Рез.Представление;
      Массив.Добавить(Авто);   
   
КонецЦикла;


а должно быть...

Массив=Новый Массив;
Пока рез.Следующий() цикл
     
      Авто=Рез.Представление;
      Массив.Добавить(Авто);   
   
КонецЦикла;


должен быть не пустой а с последним значением из запроса...

а это

СтандартнаяОбработка=Ложь;
ММаршрут= новый СписокЗначений();
ММаршрут.Добавить(Адрес());
         ММаршрут.ОтметитьЭлементы("");
      СписокСтрока = "";
 Для каждого стр из ММаршрут цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Значение + ", ";
   КонецЕсли;
КонецЦикла;
СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Элементы.ЗагрузкаВыгрузка.ТекущиеДанные.Адрес=СписокСтрока;

к чему?
в любом случае после "Возврат Массив;" ничего из этого не выполнится НИ КОГ ДА...

Массив=Новый Массив;
Пока рез.Следующий() цикл
     
      Авто=Рез.Представление;
      Массив.Добавить(Авто);   
   
КонецЦикла;

Так а как мне передать на форму список значений помещенных в массив?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
точно не помню...

СписокЗнач = Новый СписокЗначений;
СписокЗнач.Загрузить(Массив);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
мне просто лень докапываться, в чем именно задача состоит.....
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
Тема закрыта , спасибо Snaky


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7063
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3428
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1035
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1151
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8930
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
100 Сообщений
alex0402
30 Сообщений
kiksi
19 Сообщений
pavl_vs
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
BuhRust
12 Сообщений

* Кто онлайн

  • Точка Гостей: 262
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal