Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 03:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Своя нумерация при создании документа  (Прочитано 5450 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день, подскажите пожалуйста как можно создать свою нумерацию документа, чтобы он начинался с № Д0000000001 след. Д0000000002 и т.д.?


Оффлайн Snaky

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 5
  • КПД: 10%
  • Регистрация: 2014-06-18
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, подскажите пожалуйста как можно создать свою нумерацию документа, чтобы он начинался с № Д0000000001 след. Д0000000002 и т.д.?
Модуль документа, событие ПриУстановкеНовогоНомера, там есть параметр "Префикс"

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
     СтандартнаяОбработка = Ложь;
     Префикс = "Д";
     Номер = 0000000108;
КонецПроцедуры

Не получилось

Оффлайн Snaky

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 5
  • КПД: 10%
  • Регистрация: 2014-06-18
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
     СтандартнаяОбработка = Ложь;
     Префикс = "Д";
     Номер = 0000000108;
КонецПроцедуры

Не получилось
Вы задали номер насильно и хотите что бы программа Вас правильно поняла

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
вообще префикс настраивается в элементе справочника Организации, и если РИБ в настройках узла
если хотите использовать свой независимый префикс, необходимо:

1. в документе прописать
Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
   Префикс = "А";
КонецПроцедуры

2. найти подписку на события ПриУстановкеНовогоНомераДокумента и там из источника удалить/исключить ваш документ

тогда все будет работать
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Если сделать так, чтобы номер с префиксом "Д" был старшим (по сортировке языка), то каждый следующий номер автоматически будет присваиваться с префиксом Д.
Например, если есть номера А0000000001, В0000000123, Д0000000001, то старшим по сортировке будет номер Д0000000001, и следующим автоматически присвоится номер Д0000000002. Правда, когда цифры закончатся, далее будет номер с префиксом Е.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Тогда по другому спрошу как можно задать насильно номер документа чтобы он начинался с Д000000109, а  с след был уже 110?

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
вариантов множество, вот один из них

1.в процедуре документа

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
...
//добавить такой код
УстановитьНовыйНомер();   
Если НуженСвойПрефикс() Тогда
Номер = "Д" + Сред(Номер,2);
КонецЕсли;
...
КонецПроцедуры // ПередЗаписью

2. при этом у документа ДОЛЖНА быть стандартная подписка на событие
ПриУстановкеНовогоНомераДокумента

проверил, отлично работает, номера получаются
00000000120
Д0000000121
00000000122


Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Тогда по другому спрошу как можно задать насильно номер документа чтобы он начинался с Д000000109, а  с след был уже 110?
Проще всего один раз "ручками" задать или программно, если этот номер будет "старше" остальных, следующие номера будут формироваться инкрементально от этого.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Всем спасибо разобрался


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15901
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 617
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7734
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 188
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal