Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 23:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сумма прописью в расходнике.  (Прочитано 4407 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн serj37

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-13
  • Сайт: 
  • Профессия: Консультант 1С
Добрый день! Наши бухгалтера ссылаясь на - http://www.consultant.ru/document/cons_doc_LAW_163618/ говорят, что получатель денег теперь не обязан писать прописью сумму, а она должна быть обязательно в этой строке расходника. Во-первых, пропись это как бы калиграфически и вручную. Во-вторых ни разу не сталкиваься в 1С чтобы цифры переводились в текст. Кто-нибудь сталкивался с этой проблемой?


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Ну вообще-то представление числа прописью - задача типовая. В 1С 8.х есть даже встроенная функция ЧислоПрописью. Про 7.7 уже не помню, смотреть надо, там, возможно, встроенной нет, но обязательно должно быть что-то где-то, может в глобальном модуле, или может быть компонентой V7plus подключается. В общем не помню, искать надо :) Но факт что такое должно быть.
Добавлено: [time][/time]

погуляв по просторам интернета нашел вот такой вариант
Сообщить(СокрЛП(Формат(Сумма,“Ч 19.0”))+” – “+Формат(Сумма,“ЧПД”));
не уверен, что он рабочий, но попробуйте, поэкспериментируйте.

Оффлайн serj37

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-13
  • Сайт: 
  • Профессия: Консультант 1С
Ну вообще-то представление числа прописью - задача типовая. В 1С 8.х есть даже встроенная функция ЧислоПрописью. Про 7.7 уже не помню, смотреть надо, там, возможно, встроенной нет, но обязательно должно быть что-то где-то, может в глобальном модуле, или может быть компонентой V7plus подключается. В общем не помню, искать надо :) Но факт что такое должно быть.
Добавлено: [time][/time]

погуляв по просторам интернета нашел вот такой вариант
Сообщить(СокрЛП(Формат(Сумма,“Ч 19.0”))+” – “+Формат(Сумма,“ЧПД”));
не уверен, что он рабочий, но попробуйте, поэкспериментируйте.
Спасибо! Будем пробовать.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Из глобального модуля 1С ТиС
Функция глСуммаПрописью(Сумма, Валюта) Экспорт

Если Валюта <> глРубли Тогда

Если ФС.СуществуетФайл(КаталогИБ() + Валюта.ИмяФайлаПрописи) = 1 Тогда
Пропись(Валюта.ИмяФайлаПрописи);
Иначе
Сообщить("Для валюты " + Валюта + " отсутствует файл прописей." +
         РазделительСтрок +
"Сумма прописью сформирована в национальной валюте.");
КонецЕсли;

КонецЕсли;

СтрокаСуммы = Формат(Сумма, "ЧПДС");

// установим пропись по умолчанию
Пропись("");
Возврат СтрокаСуммы;

КонецФункции // глСуммаПрописью()


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 260
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal