Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 23:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поле объекта не обнаружено.  (Прочитано 5446 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 176
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Форма Управляемая.
Пытаюсь прочитать файл, после чего выдаёт ошибку:


{Обработка.ТаблицаЗначений.Форма.Форма.Форма(30)}: Поле объекта не обнаружено (СтраховойНомер)[/size]НовСтр.СтраховойНомер = Файл.Значение;


Что неправильно ?


Есть код:





&НаКлиенте
Процедура ТаблицаЗначений(Команда)
   ТЗ ()
КонецПроцедуры


&НаСервереБезКонтекста
Процедура ТЗ ()
                                                        
Чтение = Новый ЧтениеXML;




ТЗ = Новый ТаблицаЗначений;




ТЗ.Очистить();


Файл = Новый ЧтениеXML;
Файл.ОткрытьФайл("c:\1.xml");
ИмяУзла = "";


Пока Файл.Прочитать() Цикл


Если Файл.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
ИмяУзла = Файл.Имя;
КонецЕсли;


Если Файл.ТипУзла = ТипУзлаXML.Текст и ИмяУзла = "СтраховойНомер" Тогда
НовСтр = ТЗ.Добавить();
НовСтр.СтраховойНомер = Файл.Значение;
КонецЕсли;


Если Файл.ТипУзла = ТипУзлаXML.Текст и ИмяУзла = "Фамилия" Тогда
НовСтр = ТЗ.Добавить();
НовСтр.Фамилия = Файл.Значение;
КонецЕсли;


Если Файл.ТипУзла = ТипУзлаXML.Текст и ИмяУзла = "Имя" Тогда
НовСтр = ТЗ.Добавить();
НовСтр.Имя = Файл.Значение;
КонецЕсли;


Если Файл.ТипУзла = ТипУзлаXML.Текст и ИмяУзла = "Отчество" Тогда
НовСтр = ТЗ.Добавить();
НовСтр.Отчество = Файл.Значение;
КонецЕсли;


КонецЦикла;


Файл.Закрыть();


   
КонецПроцедуры

[/color]


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Не устаю повторять: ошибка означает буквально то, что написано в тексте сообщения.
Поле объекта не обнаружено (СтраховойНомер)[/size]НовСтр.СтраховойНомер
говорит о том, что нет у вас поля СтраховойНомер у объекта НовСтр.

Предчувствуя следующий вопрос отвечу заранее: просмотрел ваш код, НовСтр - это строка таблицы значений. Пустой таблицы значений. Совсем пустой. Без колонок. Логично, что колонки СтраховойНомер там тоже нет, так как нет вообще никаких колонок.

Оффлайн cobra77777

  • ***
  • Сообщений: 176
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
прикладываю скрин.
Добавлено: 23 Июн 2014, 13:59

прикладываю скрин, что не так?

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
а при чем собственно тут форма, если у вас сине-красным по белому написано:
ТЗ = Новый ТаблицаЗначений;

Оффлайн cobra77777

  • ***
  • Сообщений: 176
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
да точно. :(
Добавлено: 23 Июн 2014, 17:37

могли бы подсказать как выгрузить из ТаблЗначений в XLS в след.формате:

Стр.№   Фамилия Имя Отчество

Спасибо

Последний раз редактировалось: cobra77777; 23 Июн 2014, 17:37. Причина: Объединение сообщений


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 7828
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 629
Последний ответ 10 Окт 2017, 12:33
от kiksi
Добавить поле "Свойство" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 306
Последний ответ 24 Фев 2018, 14:40
от useronforum
Добавить поле "Комментарий" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 270
Последний ответ 03 Мар 2018, 16:14
от useronforum
Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 7395
Последний ответ 10 Июл 2014, 15:16
от virtus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
ilyay ilyay
29 Сообщений
Alter
29 Сообщений
Анюта17
29 Сообщений

* Кто онлайн

  • Точка Гостей: 278
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal