Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 12:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Универсальный передаточный документ  (Прочитано 2648 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex56

  • *****
  • Сообщений: 828
  • РЕПУТАЦИЯ: 11
  • КПД: 1%
  • Регистрация: 2013-10-02
  • Сайт: itoren.ucoz.ru
  • Профессия: Ученик 1С
Здравствуйте, не печатается тара в УПД только товар.
Может кто знает в новых релизах эта функция добавлена?
Не могу найти этот макет


Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь) Экспорт

   Если ЭтоНовый() Тогда
      Предупреждение(НСтр("ru = 'Документ можно распечатать только после его записи'"));
      Возврат;
   ИначеЕсли Не УправлениеДопПравамиПользователей.РазрешитьПечатьНепроведенныхДокументов(Проведен) Тогда
      Предупреждение(НСтр("ru = Недостаточно полномочий для печати непроведенного документа!'"));
      Возврат;
   КонецЕсли;

   Если Не РаботаСДиалогами.ПроверитьМодифицированность(ЭтотОбъект) Тогда
      Возврат;
   КонецЕсли;

   // Получить экземпляр документа на печать
   Если ИмяМакета = "ОС14упр" тогда

      // Унифицированная форма М-4 (Акт о приеме оборудования) по данным упручета
      ТабДокумент = ПечатьОС14();

   ИначеЕсли ИмяМакета = "ОС14бух" тогда
      
      // Унифицированная форма М-4 (Акт о приеме оборудования) по данным бухучета
      ТабДокумент = ПечатьОС14(Ложь);

   ИначеЕсли ИмяМакета = "СправкаРасчетВал" тогда

      // Справка-расчет формирования рублевой суммы документа в валюте
      БухгалтерскийУчетРасчетовСКонтрагентами.НапечататьСправкуРасчетРублеваяСуммаДокументаВВалюте(Ссылка);
      Возврат;
   ИначеЕсли ИмяМакета = "Бланк" Тогда

      ТабДокумент = ПечатьБланк(НаПринтер);
   ИначеЕсли ИмяМакета = "Ценники" Тогда
      ТабДокумент = ПечатьЦенников();
   ИначеЕсли ИмяМакета = "Этикетки" Тогда
      ПечататьЭтикетки();
      Возврат;
   ИначеЕсли ИмяМакета = "СерийныеНомера" Тогда
   
      ТабДокумент = УчетСерийныхНомеров.ПечатьСерийныхНомеров(Ссылка, "Товары");
   
   ИначеЕсли ТипЗнч(ИмяМакета) = Тип("ДвоичныеДанные") Тогда

      ТабДокумент = УниверсальныеМеханизмы.НапечататьВнешнююФорму(Ссылка, ИмяМакета);

      Если ТабДокумент = Неопределено Тогда
         Возврат;
      КонецЕсли;
   Иначе
      //Формы Накладная, ТОРГ4, М4, ТОРГ12 печатаются из модуля менеджера
      ПараметрКоманды = Новый Массив;
      ПараметрКоманды.Добавить(Ссылка);
      
      Если НаПринтер Тогда
         УправлениеПечатьюКлиент.ВыполнитьКомандуПечатиНаПринтер("Документ.ПоступлениеТоваровУслуг", ИмяМакета,
                              ПараметрКоманды, Неопределено);
      Иначе
         УправлениеПечатьюКлиент.ВыполнитьКомандуПечати("Документ.ПоступлениеТоваровУслуг", ИмяМакета,
                              ПараметрКоманды, Неопределено, Неопределено);
      КонецЕсли;
      Возврат;
   КонецЕсли;

   УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект, Строка(ВидОперации)), Ссылка);



Подскажите где он?
Нужно постоянно трудиться.


Оффлайн Alex56

  • *****
  • Сообщений: 828
  • РЕПУТАЦИЯ: 11
  • КПД: 1%
  • Регистрация: 2013-10-02
  • Сайт: itoren.ucoz.ru
  • Профессия: Ученик 1С
Комплексная автоматизация, редакция 1.1 (1.1.46.2)
Добавлено: 23 Июн 2014, 10:29

Оказывается в модуле менеджера эта функция.
Нужно постоянно трудиться.

Последний раз редактировалось: Ildar Ziganshin; 23 Июн 2014, 10:29. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В конфе есть супер кнопка - Глобальный поиск
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 231
Последний ответ 23 Окт 2017, 23:14
от Ivan94
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4394
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9324
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3900
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 19005
Последний ответ 10 Ноя 2010, 14:08
от Lexius

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 842
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal