Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Июн 2018, 02:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ТОРГ-29 для оптового склада УТ 10.3  (Прочитано 3018 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tattoo_master

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-21
  • Сайт: 
  • Профессия: Ученик 1С
День добрый! Помогите кто может. Сделал отчет для оптового склада УТ 10.3, документы туда попадают правильно, но вот беда он не в какую не хочет показывать остатки на период формирования отчета. То есть на начало отчета и на конец. Уже весь мозг вынес, а склады хотят этот отчет.


Оффлайн tattoo_master

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-21
  • Сайт: 
  • Профессия: Ученик 1С
День добрый! Помогите кто может. Сделал отчет для оптового склада УТ 10.3, документы туда попадают правильно, но вот беда он не в какую не хочет показывать остатки на период формирования отчета. То есть на начало отчета и на конец. Уже весь мозг вынес, а склады хотят этот отчет.

Оффлайн wise

  • *****
  • Сообщений: 523
  • РЕПУТАЦИЯ: 69
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
   "ВЫБРАТЬ
   |   ТоварыНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток,
   |   ТоварыНаСкладахОстаткиИОбороты.Регистратор,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход,
   |   ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток
   |ИЗ
   |   РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&НачДата, &КонДата, Регистратор, , ) КАК ТоварыНаСкладахОстаткиИОбороты
   |
   |УПОРЯДОЧИТЬ ПО
   |   Номенклатура"
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн tattoo_master

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-21
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо! Но хотелось бы видеть суммовой учет а не количественный.
Вот как у меня выглядит обработка, чего в ней не хватает и что лишнее?
Процедура ОбновитьОтчет() Экспорт

Если Не ЗначениеЗаполнено(ДатаНач) ИлИ Не ЗначениеЗаполнено(ДатаКон) Тогда
Предупреждение("Не выбран период!");
Возврат;
КонецЕсли;

Если Не ЗначениеЗаполнено(Склад) Тогда
Предупреждение("Не выбран склад!");
Возврат;
КонецЕсли;

Если Не ЗначениеЗаполнено(ТипЦен) Тогда
Предупреждение("Не выбран тип цен!");
Возврат;
КонецЕсли;


мТабДок = ЭлементыФормы.ДокументРезультат;

мТабДок.Очистить();

Макет = ЭтотОбъект.ПолучитьМакет("Макет");

СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Организация, ДатаКон);

ВыбМОЛ = РегистрыСведений.ОтветственныеЛица.ПолучитьПоследнее(КонецДня(ДатаКон), Новый Структура("СтруктурнаяЕдиница", Склад)).ФизическоеЛицо;

ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.ОрганизацияПредставление = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе);
ОбластьМакета.Параметры.ДатаСоставления = РабочаяДата;
ОбластьМакета.Параметры.ДатаНачала = ДатаНач;
ОбластьМакета.Параметры.ДатаКонца = ДатаКон;
ОбластьМакета.Параметры.ОрганизацияПоОКПО = СведенияОПокупателе.КодПоОКПО;
ОбластьМакета.Параметры.МОЛ = ?(ЗначениеЗаполнено(ВыбМОЛ), ВыбМОЛ, "");
ОбластьМакета.Параметры.МОЛТабельныйНомер = ?(Не ЗначениеЗаполнено(ВыбМОЛ), "", ВыбМОЛ.Код);

ОбластьМакета.Параметры.Номер = НомерОтчета;
ВысотаЗаголовка = ОбластьМакета.ВысотаТаблицы;

мТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ПовторятьПриПечатиСтроки = мТабДок.Область(1 + ВысотаЗаголовка, ,2 + ВысотаЗаголовка);

мТабДок.Вывести(ОбластьМакета);


Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Дата1", НачалоДня(ДатаНач));
Запрос.УстановитьПараметр("Дата2", КонецДня(ДатаКон));
Запрос.УстановитьПараметр("Склад", Склад);
    Запрос.УстановитьПараметр("ТипЦен", ТипЦен);

Если Склад.ВидСклада = Перечисления.ВидыСкладов.Розничный Тогда
ТекстЗапроса = "
|ВЫБРАТЬ РАЗРЕШЕННЫЕ
| NULL КАК Док,
| NULL КАК ДатаДок,
| NULL КАК НомерДок,
| СУММА(ОстаткиТоваров.СуммаПродажнаяНачальныйОстаток) КАК НачОст,
| СУММА(ОстаткиТоваров.СуммаПродажнаяКонечныйОстаток) КАК КонОст,
| СУММА(
| ВЫБОР КОГДА ОстаткиТоваров.СуммаПродажнаяПриход - ОстаткиТоваров.СуммаПродажнаяРасход > 0 ТОГДА
| ОстаткиТоваров.СуммаПродажнаяПриход - ОстаткиТоваров.СуммаПродажнаяРасход
| ИНАЧЕ
| 0
| КОНЕЦ
| ) КАК Приход,
| СУММА(
| ВЫБОР КОГДА ОстаткиТоваров.СуммаПродажнаяРасход - ОстаткиТоваров.СуммаПродажнаяПриход > 0 ТОГДА
| ОстаткиТоваров.СуммаПродажнаяРасход - ОстаткиТоваров.СуммаПродажнаяПриход
| ИНАЧЕ
| 0
| КОНЕЦ
| ) КАК Расход
|ИЗ
| РегистрНакопления.ТоварыВРознице.ОстаткиИОбороты(&Дата1, &Дата2, , , Склад = &Склад) КАК ОстаткиТоваров
|ИМЕЮЩИЕ
| СУММА(ОстаткиТоваров.СуммаПродажнаяНачальныйОстаток) <> 0.00
| ИЛИ СУММА(ОстаткиТоваров.СуммаПродажнаяКонечныйОстаток) <> 0.00
| ИЛИ СУММА(ВЫБОР КОГДА ОстаткиТоваров.СуммаПродажнаяПриход - ОстаткиТоваров.СуммаПродажнаяРасход > 0 ТОГДА
| ОстаткиТоваров.СуммаПродажнаяПриход - ОстаткиТоваров.СуммаПродажнаяРасход ИНАЧЕ 0.00 КОНЕЦ) <> 0.00
| ИЛИ СУММА(ВЫБОР КОГДА ОстаткиТоваров.СуммаПродажнаяРасход - ОстаткиТоваров.СуммаПродажнаяПриход > 0 ТОГДА
| ОстаткиТоваров.СуммаПродажнаяРасход - ОстаткиТоваров.СуммаПродажнаяПриход ИНАЧЕ 0.00 КОНЕЦ) <> 0.00
|;
|ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ОстаткиТоваров.Регистратор КАК Док,
| ОстаткиТоваров.Период КАК ДатаДок,
| ОстаткиТоваров.Регистратор.Номер КАК НомерДок,
| СУММА(ОстаткиТоваров.СуммаПродажнаяНачальныйОстаток) КАК НачОст,
| СУММА(ОстаткиТоваров.СуммаПродажнаяКонечныйОстаток) КАК КонОст,
| СУММА(
| ВЫБОР КОГДА ОстаткиТоваров.СуммаПродажнаяПриход - ОстаткиТоваров.СуммаПродажнаяРасход > 0 ТОГДА
| ОстаткиТоваров.СуммаПродажнаяПриход - ОстаткиТоваров.СуммаПродажнаяРасход
| ИНАЧЕ
| 0
| КОНЕЦ
| ) КАК Приход,
| СУММА(
| ВЫБОР КОГДА ОстаткиТоваров.СуммаПродажнаяРасход - ОстаткиТоваров.СуммаПродажнаяПриход > 0 ТОГДА
| ОстаткиТоваров.СуммаПродажнаяРасход - ОстаткиТоваров.СуммаПродажнаяПриход
| ИНАЧЕ
| 0
| КОНЕЦ
| ) КАК Расход
|ИЗ
| РегистрНакопления.ТоварыВРознице.ОстаткиИОбороты(&Дата1, &Дата2, Регистратор, , Склад = &Склад) КАК ОстаткиТоваров
|СГРУППИРОВАТЬ ПО
| ОстаткиТоваров.Регистратор,
| ОстаткиТоваров.Период,
| ОстаткиТоваров.Регистратор.Номер
|УПОРЯДОЧИТЬ ПО
| ОстаткиТоваров.Период
|";
Иначе
        ТекстЗапроса ="ВЫБРАТЬ
        | ЦеныНоменклатуры.Период КАК ПериодНачало,
        | МИНИМУМ(ЦеныНоменклатурыКопия.Период) КАК ПериодКонец,
        | ЦеныНоменклатуры.Номенклатура,
        | ЦеныНоменклатуры.Цена
        |ПОМЕСТИТЬ ПредварительнаяВыборка
        |ИЗ
        | РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
        | ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатурыКопия
        | ПО ЦеныНоменклатуры.Номенклатура = ЦеныНоменклатурыКопия.Номенклатура
        | И ЦеныНоменклатуры.ЕдиницаИзмерения = ЦеныНоменклатурыКопия.ЕдиницаИзмерения
        | И ЦеныНоменклатуры.ХарактеристикаНоменклатуры = ЦеныНоменклатурыКопия.ХарактеристикаНоменклатуры
        | И ЦеныНоменклатуры.Валюта = ЦеныНоменклатурыКопия.Валюта
        | И ЦеныНоменклатуры.ТипЦен = ЦеныНоменклатурыКопия.ТипЦен
        | И ЦеныНоменклатуры.Период < ЦеныНоменклатурыКопия.Период
        |ГДЕ
        | ЦеныНоменклатуры.ТипЦен = &ТипЦен
        |
        |СГРУППИРОВАТЬ ПО
        | ЦеныНоменклатуры.Период,
        | ЦеныНоменклатуры.Номенклатура,
        | ЦеныНоменклатуры.Цена
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        | ЦеныПоПериодам.ПериодНачало КАК ПериодНачало,
        | КОНЕЦПЕРИОДА(ЕСТЬNULL(ДОБАВИТЬКДАТЕ(ЦеныПоПериодам.ПериодКонец, ДЕНЬ, -1), ДАТАВРЕМЯ(3999, 12, 31)), ДЕНЬ) КАК ПериодКонец,
        | ЦеныПоПериодам.Номенклатура КАК Номенклатура,
        | ЦеныПоПериодам.Цена
        |ПОМЕСТИТЬ Цены
        |ИЗ
        | ПредварительнаяВыборка КАК ЦеныПоПериодам
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ РАЗРЕШЕННЫЕ
        | NULL КАК Док,
        | NULL КАК ДатаДок,
    | NULL КАК НомерДок,
        | СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток * ЕСТЬNULL(Цены.Цена, 0)) КАК НачОст,
        | СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток * ЕСТЬNULL(Цены.Цена, 0)) КАК КонОст,
        | СУММА(ВЫБОР
        | КОГДА ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход - ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход > 0
        | ТОГДА (ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход - ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход) * ЕСТЬNULL(Цены.Цена, 0)
        | ИНАЧЕ 0
        | КОНЕЦ) КАК Приход,
        | СУММА(ВЫБОР
        | КОГДА ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход - ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход > 0
        | ТОГДА (ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход - ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход) * ЕСТЬNULL(Цены.Цена, 0)
        | ИНАЧЕ 0
        | КОНЕЦ) КАК Расход,
        | ТоварыНаСкладахОстаткиИОбороты.Регистратор.СуммаДокумента КАК СуммаДокумента
        |ИЗ
        | РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&Дата1, &Дата2, Регистратор, , Склад = &Склад) КАК ТоварыНаСкладахОстаткиИОбороты
    | ЛЕВОЕ СОЕДИНЕНИЕ Цены КАК Цены
        | ПО ТоварыНаСкладахОстаткиИОбороты.Номенклатура = Цены.Номенклатура
        | И ТоварыНаСкладахОстаткиИОбороты.Период >= Цены.ПериодНачало
        | И ТоварыНаСкладахОстаткиИОбороты.Период <= Цены.ПериодКонец
        |
        |СГРУППИРОВАТЬ ПО
        | ТоварыНаСкладахОстаткиИОбороты.Регистратор.СуммаДокумента
        |
        |ИМЕЮЩИЕ
        | (СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток * ЕСТЬNULL(Цены.Цена, 0)) <> 0
        | ИЛИ СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток * ЕСТЬNULL(Цены.Цена, 0)) <> 0
        | ИЛИ СУММА(ВЫБОР
        | КОГДА ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход - ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход > 0
    | ТОГДА (ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход - ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход) * ЕСТЬNULL(Цены.Цена, 0)
        | ИНАЧЕ 0
        | КОНЕЦ) <> 0
        | ИЛИ СУММА(ВЫБОР
        | КОГДА ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход - ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход > 0
        | ТОГДА (ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход - ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход) * ЕСТЬNULL(Цены.Цена, 0)
        | ИНАЧЕ 0
        | КОНЕЦ) <> 0)
        |;
        |
    |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ РАЗРЕШЕННЫЕ
        | СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток * ЕСТЬNULL(Цены.Цена, 0)) КАК НачОст,
        | СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток * ЕСТЬNULL(Цены.Цена, 0)) КАК КонОст,
        | СУММА(ВЫБОР
        | КОГДА ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход - ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход > 0
        | ТОГДА (ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход - ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход) * ЕСТЬNULL(Цены.Цена, 0)
        | ИНАЧЕ 0
        | КОНЕЦ) КАК Приход,
        | СУММА(ВЫБОР
        | КОГДА ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход - ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход > 0
        | ТОГДА (ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход - ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход) * ЕСТЬNULL(Цены.Цена, 0)
        | ИНАЧЕ 0
        | КОНЕЦ) КАК Расход,
        | ТоварыНаСкладахОстаткиИОбороты.Период КАК ДатаДок,
        | ТоварыНаСкладахОстаткиИОбороты.Регистратор.Номер КАК НомерДок,
        | ТоварыНаСкладахОстаткиИОбороты.Регистратор КАК Док,
        | ТоварыНаСкладахОстаткиИОбороты.Регистратор.СуммаДокумента КАК СуммаДокумента
        |ИЗ
        | РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&Дата1, &Дата2, Регистратор, , Склад = &Склад) КАК ТоварыНаСкладахОстаткиИОбороты
        | ЛЕВОЕ СОЕДИНЕНИЕ Цены КАК Цены
        | ПО ТоварыНаСкладахОстаткиИОбороты.Номенклатура = Цены.Номенклатура
        | И ТоварыНаСкладахОстаткиИОбороты.Период >= Цены.ПериодНачало
        | И ТоварыНаСкладахОстаткиИОбороты.Период <= Цены.ПериодКонец
        |
        |СГРУППИРОВАТЬ ПО
        | ТоварыНаСкладахОстаткиИОбороты.Период,
        | ТоварыНаСкладахОстаткиИОбороты.Регистратор.Номер,
        | ТоварыНаСкладахОстаткиИОбороты.Регистратор
        |
        |УПОРЯДОЧИТЬ ПО
        | ДатаДок";
КонецЕсли;

Запрос.Текст = ТекстЗапроса;

МассивРезультатов = Запрос.ВыполнитьПакет();
РезултатОстаков = МассивРезультатов[2];
РезультатЗапроса = МассивРезультатов[3];

Если РезултатОстаков.Пустой() Тогда
НачОст = 0;
КонОст = 0;
Иначе
ВыборкаСтрокаОстатков = РезултатОстаков.Выбрать();
ВыборкаСтрокаОстатков.Следующий();
НачОст = ВыборкаСтрокаОстатков.НачОст;
КонОст = ВыборкаСтрокаОстатков.КонОст;
КонецЕсли;

ОбластьМакета = Макет.ПолучитьОбласть("ОстатокНачала");
ОбластьМакета.Параметры.ДатаНачала = "Остаток на " + Формат(ДатаНач, "ДЛФ=Д");
ОбластьМакета.Параметры.НачСтоимостьВсего = ОбщегоНазначения.ФорматСумм(НачОст);
мТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Приход");
мТабДок.Вывести(ОбластьМакета);

ТЗПриходы = ОбщегоНазначения.ОтобратьСтрокиПоКритериям(РезультатЗапроса, Новый Структура("Приход", 0),
            Новый Структура("Приход", ВидСравнения.НеРавно)).Выгрузить();

ТЗПриходы.Сортировать("ДатаДок Возр");

ОбластьМакета = Макет.ПолучитьОбласть("Строка");

Для Каждого СтрокаПрихода Из ТЗПриходы Цикл
ОбластьМакета.Параметры.НомерДокумента = "";
Если ТипЗнч(СтрокаПрихода.Док) = Тип("ДокументСсылка.ПеремещениеТоваров") Тогда
ОбластьМакета.Параметры.Докум = "Перемещение из " + СокрЛП(СтрокаПрихода.Док.СкладОтправитель);
ОбластьМакета.Параметры.НомерДокумента = СтрокаПрихода.НомерДок;
ИначеЕсли ТипЗнч(СтрокаПрихода.Док) = Тип("ДокументСсылка.ПоступлениеТоваровУслуг") Тогда
ОбластьМакета.Параметры.Докум = "ПоступлениеТоваровУслуг " + Лев(СтрокаПрихода.Док.Контрагент, 50);
ОбластьМакета.Параметры.НомерДокумента = СтрокаПрихода.Док.НомерВходящегоДокумента;
Иначе
ОбластьМакета.Параметры.Докум = СтрокаПрихода.Док.ПолучитьОбъект().Метаданные().Синоним;
КонецЕсли;
ОбластьМакета.Параметры.Расшифровка = СтрокаПрихода.Док;
ОбластьМакета.Параметры.ДатаДокумента = СтрокаПрихода.ДатаДок;

Если ТипЗнч(СтрокаПрихода.Док)=Тип("ДокументСсылка.ОтчетОРозничныхПродажах")Тогда
ОбластьМакета.Параметры.СуммаТовара = ОбщегоНазначения.ФорматСумм(СтрокаПрихода.СуммаДокумента);
КонецЕсли;

ОбластьМакета.Параметры.СуммаТовара = ОбщегоНазначения.ФорматСумм(СтрокаПрихода.Приход);

ОбластьМакета.Параметры.СуммаТары = ОбщегоНазначения.ФорматСумм(0);
мТабДок.Вывести(ОбластьМакета);
КонецЦикла;

Приход = ТЗПриходы.Итог("Приход");

ОбластьМакета = Макет.ПолучитьОбласть("ИтогоПриход");
ОбластьМакета.Параметры.ПрихСтоимостьВсего = ОбщегоНазначения.ФорматСумм(Приход);
мТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("ВсегоПриход");
ОбластьМакета.Параметры.ПриходСОстатком = ОбщегоНазначения.ФорматСумм(Приход + НачОст);
мТабДок.Вывести(ОбластьМакета);

мТабДок.ВывестиГоризонтальныйРазделительСтраниц();

ОбластьМакета = Макет.ПолучитьОбласть("Расход");
мТабДок.Вывести(ОбластьМакета);

ТЗРасходы = ОбщегоНазначения.ОтобратьСтрокиПоКритериям(РезультатЗапроса, Новый Структура("Расход", 0),
            Новый Структура("Расход", ВидСравнения.НеРавно)).Выгрузить();

ТЗРасходы.Сортировать("ДатаДок Возр");

ОбластьМакета = Макет.ПолучитьОбласть("Строка");

Для Каждого СтрокаРасхода Из ТЗРасходы Цикл
ОбластьМакета.Параметры.НомерДокумента = "";
Если ТипЗнч(СтрокаРасхода.Док) = Тип("ДокументСсылка.ПеремещениеТоваров") Тогда
ОбластьМакета.Параметры.Докум = "Перемещение в " + СокрЛП(СтрокаРасхода.Док.СкладПолучатель);
ИначеЕсли ТипЗнч(СтрокаРасхода.Док) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
ОбластьМакета.Параметры.Докум = "РеализацияТоваровУслуг " + Лев(СтрокаРасхода.Док.Контрагент, 50);
Иначе
ОбластьМакета.Параметры.Докум = СтрокаРасхода.Док.ПолучитьОбъект().Метаданные().Синоним;
КонецЕсли;
ОбластьМакета.Параметры.Расшифровка = СтрокаРасхода.Док;
ОбластьМакета.Параметры.ДатаДокумента = СтрокаРасхода.ДатаДок;
ОбластьМакета.Параметры.НомерДокумента = СтрокаРасхода.НомерДок;
Если ТипЗнч(СтрокаПрихода.Док)=Тип("ДокументСсылка.ОтчетОРозничныхПродажах")Тогда
           ОбластьМакета.Параметры.СуммаТовара = ОбщегоНазначения.ФорматСумм(СтрокаРасхода.СуммаДокумента);
КонецЕсли;
   ОбластьМакета.Параметры.СуммаТовара = ОбщегоНазначения.ФорматСумм(СтрокаРасхода.Расход);

ОбластьМакета.Параметры.СуммаТары = ОбщегоНазначения.ФорматСумм(0);
мТабДок.Вывести(ОбластьМакета);
КонецЦикла;

Расход = ТЗРасходы.Итог("Расход");

ОбластьМакета = Макет.ПолучитьОбласть("ИтогоРасход");
ОбластьМакета.Параметры.РасхСтоимостьВсего = ОбщегоНазначения.ФорматСумм(Расход);
мТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("ОстатокКонец");
ОбластьМакета.Параметры.ДатаКонца = "Остаток на " + Формат(ДатаКон, "ДЛФ=Д");
ОбластьМакета.Параметры.КонСтоимостьВсего = ОбщегоНазначения.ФорматСумм(КонОст);
мТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ОбластьМакета.Параметры.МОЛ = ?(ЗначениеЗаполнено(ВыбМОЛ), ВыбМОЛ, "");
мТабДок.Вывести(ОбластьМакета);

мТабДок.ПовторятьПриПечатиСтроки = ПовторятьПриПечатиСтроки;

НомерОтчета = НомерОтчета + 1;

КонецПроцедуры // ОбновитьОтчет()
Добавлено: 24 Июн 2014, 12:41

Не ужели не кто не может помочь с моим отчетом?

Последний раз редактировалось: tattoo_master; 24 Июн 2014, 12:41. Причина: Объединение сообщений


Теги:
 

Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8308
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
ТОРГ-12 и документ "Ордер на отражение недостач"

Автор deringpavelРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 8665
Последний ответ 08 Апр 2013, 15:41
от Besart
В форме ТОРГ-12 и счет-фактуре в качестве грузоотправителя должно быть одно лицо

Автор newsРаздел Новости

Ответов: 0
Просмотров: 845
Последний ответ 17 Сен 2014, 12:01
от news
Импорт данных о товарах в 1с Упраление торг 11.1 через файл в формате CommerceML

Автор Евгений ОлеговичРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1446
Последний ответ 19 Ноя 2015, 10:11
от Евгений Олегович
Внешняя печатная форма Торг-12 для Документа возварт товара поставщику

Автор denis-moscow1987Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1369
Последний ответ 16 Июл 2014, 10:01
от denis-moscow1987

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
132 Сообщений
AIFrame AIFrame
126 Сообщений
alexandr_ll
59 Сообщений
alex0402
47 Сообщений
pavl_vs
47 Сообщений
buketov.av buketov.av
43 Сообщений
ilyay ilyay
37 Сообщений
trialex3
24 Сообщений
magnifico61
21 Сообщений
wise wise
15 Сообщений

* Кто онлайн

  • Точка Гостей: 195
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal