Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 13:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать реестра сефтификатов  (Прочитано 713 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nikolya228

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Функция Печать() Экспорт

ТабДок        = Новый ТабличныйДокумент;
Макет         = ПолучитьМакет("Сертификат");
ОбластьШапки  = Макет.ПолучитьОбласть("Шапка");
ОбластьДанные = Макет.ПолучитьОбласть("Данные");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

ОбластьШапки.Параметры.ТекстЗаголовка = "Приложение к расходной накладной № " + СсылкаНаОбъект.Номер;
ТабДок.Вывести(ОбластьШапки);


ОбластьДанные.Параметры.НомерСтроки =0;
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
Запрос.Текст =
"ВЫБРАТЬ
| РеализацияТоваровУслугТовары.Номенклатура
|ИЗ
| Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
|ГДЕ
| РеализацияТоваровУслугТовары.Ссылка = &Ссылка";
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ЗаполнитьЗначенияСвойств(ОбластьДанные.Параметры, Выборка);
Товар = Выборка.Номенклатура;
         ОбластьДанные.Параметры.НомерСтроки =ОбластьДанные.Параметры.НомерСтроки +1;
Запрос1 = Новый Запрос;
Запрос1.УстановитьПараметр("Номенклатура", Товар);
Запрос1.Текст =
"ВЫБРАТЬ
| СерииНоменклатуры.Сертификат,
|   СерииНоменклатуры.СрокГодности
|ИЗ
| Справочник.СерииНоменклатуры КАК СерииНоменклатуры
|ГДЕ
| СерииНоменклатуры.Владелец = &Номенклатура";

       
      Выборка2 = Запрос1.Выполнить().Выбрать();

Пока Выборка2.Следующий() Цикл
         
ОбластьДанные.Параметры.СрокГодности = Выборка2.СрокГодности;
ОбластьДанные.Параметры.Сертификат = Выборка2.Сертификат;


КонецЦикла;

  ТабДок.Вывести(ОбластьДанные);
КонецЦикла;
Возврат ТабДок;

КонецФункции

Помогите пожалуйста...Проблема в том ,что если у товара нет сертификата то выводится тот сертификат который был у предыдущего,а мне надо так ,если нет у товара сертификата,то товар не должен появлятся в печатной форме вообще!!!!


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Выборка2 = Запрос1.Выполнить().Выбрать();
Если Выборка2.Количество() = 0 Тогда
   Продолжить;
КонецЕсли;         
Пока Выборка2.Следующий() Цикл
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
181 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 759
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal