Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 05:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Фильтр на тип реквизита Табличной части  (Прочитано 3514 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
У реквизита табличной части стоит тип " СправочникСсылка.Транспорт, Строка"
Как избавиться от выбора при заполнении элемента на форме, если точно известно что при определенных условия тип "СправочникСсылка.Транспорт", а при других "Строка".


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6571
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Как только узнали что тип Трансопрт указывайте в значении пустую ссылку на этот справочник и выбора типа не будет. Как только узнали что строка устанавливайте пустую строку.

Оффлайн LexaK

  • *****
  • Сообщений: 1280
  • РЕПУТАЦИЯ: 352
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
в форме на табличной части на событие При начале редактирования строки, назначаете следующую функцию,
при добавлении новой строки, сработает эта процедура, вам только нужно сделать/запрограммировать вашу функцию НужнаСтрока(...)
происходит первоначальная инициализация поля переменной нужного типа,
соответственно строку сразу можно будет вводить, справочник сразу выбирать, если что, в поле, можно нажать кнопку очистка значения
  • и вернетесь в режим выбора типа.


Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)

   Если Элемент.ТекущаяСтрока.Транспорт = Неопределено и НужнаСтрока(...) Тогда
      Элемент.ТекущаяСтрока.Транспорт= "";
   Иначе
      Элемент.ТекущаяСтрока.Транспорт= Справочники.Транспорт.ПустаяСсылка();
   КонецЕсли;

КонецПроцедуры
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Принцип выше описанного понятен, но при реализации не получилось. У меня управляемое приложение.
Для начала попыталась установить тип только справочник. Ставлю точку останова - не срабатывает процедура ПриНачалеРеадкатирования для табличной части.
&НаСервере
Процедура ТТНПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Элементы.ТТН.ТекущаяСтрока.ГосНомер = Справочники.Транспорт.ПустаяСсылка();
КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаСервере
А она разве не на клиенте должна быть?? Вы ее привязали к самому элементу формы на вкладке СОБЫТИЯ???
Элементы.ТТН.ТекущаяСтрока.ГосНомер
Это тоже не правильно
&НаКлиенте
Процедура ТТНПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
Если НоваяСтрока и НЕ Копирование Тогда
   Элемент.ТекущиеДанные.ГосНомер = ПредопределенноеЗначение("Справочник.Транспорт.ПустаяСсылка");
КонецЕсли;
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Snaky

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 5
  • КПД: 10%
  • Регистрация: 2014-06-18
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток.
У реквизита табличной части стоит тип " СправочникСсылка.Транспорт, Строка"
Как избавиться от выбора при заполнении элемента на форме, если точно известно что при определенных условия тип "СправочникСсылка.Транспорт", а при других "Строка".
Попробуйте установить значение реквизита либо : Пустая строка ("") либо пустая ссылка справочника (Справочник.[ИмяСправочника].ПустаяСсылка()), причем не при начале редактирования, а при выполнении условий, т.е. если условие имеет тип Булево, то на событие добавления строки в ТЧ, если же условие в самой этой строке то ориентируйтесь на её изменение.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Исправила ошибки, как сказал Dethmontt. Все заработало.


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2033
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3123
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1152
Последний ответ 02 Дек 2016, 12:58
от Jalib
КД, Перенос Реквизита справочника (7.7) в ТЧ справочника 8.2.

Автор EvgenyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3770
Последний ответ 17 Сен 2014, 13:39
от Kironten
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3175
Последний ответ 02 Июл 2012, 13:11
от totutotam

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 208
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal