Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 19:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как перепровести документ в 1с 8.3 и печатная форма  (Прочитано 8857 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
Здравствуйте, возможно кто то сталкивался с подобными ситуациями
1.
Имеется документ1 после заполнения которого при нажатии на кнопку Выполнить создается документ2.
Проходит время, в документ1 ранее созданный вносятся корректировки, если нажать на кнопку выполнить он создаст новый документ2, а ранее созданный документ2 будет уже не нужен.
Возник вопрос: Как сделать так , чтобы при изменении документ1 при нажатии на кнопку Выполнить перезаписывался ранее созданный документ2, а не плодились копии?
2.
Ранее стояла БП 2.0. был создан документ "Заявка" для него была создана хитрая печатная форма. Весь код формирования данной заявки лежит в Модуле объекта
2-е функции которые отвечают за формирования двух печатных форм( не экспортные) и одна экспортная которая осуществляет печать документа.
В модуле формы имеется процедура

Процедура УстановитьКнопкиПечати()
   
   мДеревоМакетов = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, ПолучитьСтруктуруПечатныхФормИсх(), Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));

   УниверсальныеМеханизмы.УстановитьПодменюПечати    (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
   УниверсальныеМеханизмы.УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));

   Если Не мПодменюПечати = Неопределено Тогда
      УниверсальныеМеханизмы.СформироватьПодменю(мДеревоМакетов, мПодменюПечати,Истина,Истина);
   КонецЕсли;
   
КонецПроцедуры

Вот тут у меня вообще нет мыслей даже как поступить чтобы все это перевести на УФ для БП 3.0

Спасибо за помощь.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура УстановитьКнопкиПечати()
   
   мДеревоМакетов = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, ПолучитьСтруктуруПечатныхФормИсх(), Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));

   УниверсальныеМеханизмы.УстановитьПодменюПечати    (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
   УниверсальныеМеханизмы.УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));

   Если Не мПодменюПечати = Неопределено Тогда
      УниверсальныеМеханизмы.СформироватьПодменю(мДеревоМакетов, мПодменюПечати,Истина,Истина);
   КонецЕсли;
   
КонецПроцедуры
Зачем это переписывать, это БСП и есть уже в БП 3.0
(только немного по другому реализовано)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
Процедура УстановитьКнопкиПечати()
   
   мДеревоМакетов = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, ПолучитьСтруктуруПечатныхФормИсх(), Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));

   УниверсальныеМеханизмы.УстановитьПодменюПечати    (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
   УниверсальныеМеханизмы.УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));

   Если Не мПодменюПечати = Неопределено Тогда
      УниверсальныеМеханизмы.СформироватьПодменю(мДеревоМакетов, мПодменюПечати,Истина,Истина);
   КонецЕсли;
   
КонецПроцедуры
Зачем это переписывать, это БСП и есть уже в БП 3.0
(только немного по другому реализовано)

можете написать к примеру как...а то я не могу разобраться с этим кодом...впервые столкнулся с такой задачей...

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. сперва необходимо сделать увязку Док1 и Док2. Например в Док2 создаем реквизит ДокументОснование и заполняем его Док1. Теперь при перезаписи Док1 по этой связке можно найти созданный док и перезаполнить.

2. от старой печатной формы вам нужна только процедура формирования самого табличного документа. Эти процедуры в обычном и управляемом приложениях более менее совпадают. Далее ищем пример внешней печатной формы для 3.0 и подсовываем старую процедуру печати
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
1. сперва необходимо сделать увязку Док1 и Док2. Например в Док2 создаем реквизит ДокументОснование и заполняем его Док1. Теперь при перезаписи Док1 по этой связке можно найти созданный док и перезаполнить.

2. от старой печатной формы вам нужна только процедура формирования самого табличного документа. Эти процедуры в обычном и управляемом приложениях более менее совпадают. Далее ищем пример внешней печатной формы для 3.0 и подсовываем старую процедуру печати

1. Связь идет по Реквизитам Номер и Дата.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
По ссылке - вернее будет...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
По ссылке - вернее будет...
пример привести можете?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
чего именно пример?! :xfbnsdfb:

Док = документы.СчетНаОплатуПокупателю.СоздатьДокумент();

СтрМаршрут =СтрМаршрутДляСФ();
Если Объект.СчетНаОплату.Пустая() тогда
   Док = документы.СчетНаОплатуПокупателю.СоздатьДокумент();
      Док.Дата = объект.Дата;
      Док.Номер=Объект.Номер;
      Док.Записать();
      объект.СчетНаОплату = Док.Ссылка;
      Записать();
   Иначе
      Док = объект.СчетНаОплату.Ссылка.ПолучитьОбъект();
      Док.ПометкаУдаления = Ложь;                         
      Док.Записать();
   КонецЕсли;

   Док.Ссылка=Объект.Ссылка;      
   Док.Дата=ОБъект.Дата;
   Док.Номер=объект.Номер;
   Док.Контрагент = Объект.Контрагент;
   Док.склад = справочники.Склады.НайтиПоКоду("000000001");
   Док.ДоговорКонтрагента = Объект.ДоговорКонтрагента;
   Док.Комментарий = Объект.Комментарий;
Док.Записать(РежимЗаписиДокумента.Проведение);
Вот тут формируется СчетФактура на основании Заявки.
Как сделать,чтобы при изменении данных в заявке в ранее сформированном сф также изменились данные.
Прошу помочь,спасибо

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Так вот же у вас все написано!
у вас у Заявки есть реквизит СчетНаОплату и вы проверяете: если заполнен, то получаете объект, если нет - создаете...

Что не так то? :dfbsdfbsdf:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 249
Последний ответ 23 Окт 2017, 23:14
от Ivan94
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4412
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9384
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3943
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 19081
Последний ответ 10 Ноя 2010, 14:08
от Lexius

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 262
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal