Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 17:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Список запросов  (Прочитано 906 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
ПолеСписка1=Новый список запросов();
        ПолеСписка1.Добавить(0,"Создать документ");
   ПолеСписка1.Добавить(1,"Создать документ2");   
        ПолеСписка1.Добавить(2,"Создать документ");
Для каждого стр из ПолеСписка1 цикл
   Если Стр.Пометка=Истина Тогда
      Сообщить(Стр.Представление);
   КонецЕсли;
КонецЦикла;
В данной ситуации в сообщении выведит все отмеченные элемент из списка.
НО:
Если я напишу
Объект.РеквизитФормы=Стр.Представление;
РеквизитФормы - реквизит формы тип-строка.
Сюда попадет только последнее отмеченное значение, в случаи если я отмечу 2 значения сразу.
Как сделать так. чтобы в реквищит формы попали и отобразились все отмеченные значения из Списка значения.
Спасибо.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Список запросов
« Ответ #1: 16 Июн 2014, 07:29 »
СписокСтрока = "";
Для каждого стр из ПолеСписка1 цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Представление + ", ";
   КонецЕсли;
КонецЦикла;

СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Объект.РеквизитФормы=СписокСтрока;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн denis-moscow1987

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-16
  • Сайт: 
Re: Список запросов
« Ответ #2: 16 Июн 2014, 07:38 »
СписокСтрока = "";
Для каждого стр из ПолеСписка1 цикл
   Если Стр.Пометка=Истина Тогда
      СписокСтрока = СписокСтрока + Стр.Представление + ", ";
   КонецЕсли;
КонецЦикла;

СписокСтрока = Лев(СписокСтрока, СтрДлина(СписокСтрока)-2);
Объект.РеквизитФормы=СписокСтрока;

Спасибо большое все работает.


 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6791
Последний ответ 23 Дек 2011, 16:43
от sergeevds
Массив, Таблица значений и Список значений

Автор Константин163Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5880
Последний ответ 25 Мар 2015, 16:02
от cska-fanat-kz
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 126
Последний ответ 15 Дек 2017, 14:36
от alex0402
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1684
Последний ответ 21 Сен 2016, 08:16
от GadLex
Отчет "Штатно-должностной список"

Автор SashenkaРаздел Закрытые темы

Ответов: 0
Просмотров: 2207
Последний ответ 08 Апр 2010, 03:00
от Sashenka

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 235
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal