Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 21:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нужна помощь по Управляемому приложению  (Прочитано 1993 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maxm R.

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-21
  • Сайт: 
  • Профессия: Бухгалтер
Добрый день!
Задача такая.....
1с 8.3 Конфигурация розница 8.1
Есть Документ.ЧекККМ и есть управляемое приложение РМК.
Нужно осуществить на управляемом приложении печать сразу последней товарной накладной по кнопке, без печатных форм и прочего. Нажал на кнопку, распечатало.

На гуглил, нафорумился, мозг взорван. Подскажите пожалуйста, как мне правильно обратиться из УП РМК к функции которая формирует табличный документ накладной...

// Функция формирует табличный документ с печатной формой.
//
// Возвращаемое значение:
//  ТабличныйДокумент - печатная форма.
//
//Функция ПечатьЧека(МассивОбъектов, ОбъектыПечати) Экспорт


... Так что бы я мог его записать в переменную или в массив, что бы потом по комманде с клиента ее можно было распечатать, по нажатию на кнопку(без вызова печатной формы).....

Любая помощь, подсказки и наводки очень сильно приветствуеться







Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТабДок = ИмяМодуляГдеРасположенаФункция.ПечатьЧека(МассивДокументовДляПечати, Неопределено);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!
Задача такая.....
1с 8.3 Конфигурация розница 8.1
Есть Документ.ЧекККМ и есть управляемое приложение РМК.
Нужно осуществить на управляемом приложении печать сразу последней товарной накладной по кнопке, без печатных форм и прочего. Нажал на кнопку, распечатало.

На гуглил, нафорумился, мозг взорван. Подскажите пожалуйста, как мне правильно обратиться из УП РМК к функции которая формирует табличный документ накладной...

// Функция формирует табличный документ с печатной формой.
//
// Возвращаемое значение:
//  ТабличныйДокумент - печатная форма.
//
//Функция ПечатьЧека(МассивОбъектов, ОбъектыПечати) Экспорт


... Так что бы я мог его записать в переменную или в массив, что бы потом по комманде с клиента ее можно было распечатать, по нажатию на кнопку(без вызова печатной формы).....

Любая помощь, подсказки и наводки очень сильно приветствуеться

Находишь последнюю и печатаешь :bleh:

Оффлайн Maxm R.

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-21
  • Сайт: 
  • Профессия: Бухгалтер
Спасибо! то что нужно. Но есть проблема ... вот кусочек кода
&НаКлиенте
Процедура ПечатьЧекаНаПД(Команда)
ТабличныйДокумент = Новый ТабличныйДокумент;
СерверЗаполнитьТабличныйДокумент(ТабличныйДокумент);
ТабличныйДокумент.Напечатать(РежимИспользованияДиалогаПечати.Использовать); //НужноПечататьМакет()
КонецПроцедуры

&НаСервере
Функция СерверЗаполнитьТабличныйДокумент(ТабличныйДокумент)
ТабличныйДокумент = Документы.ЧекККМ.ПечатьЧека(ТабличныйДокумент,);
Возврат ТабличныйДокумент
КонецФункции

На сервере ТабличныйДокумент = Документы.ЧекККМ.ПечатьЧека(ТабличныйДокумент,); все ок, инфа есть, а
На клиенте СерверЗаполнитьТабличныйДокумент(ТабличныйДокумент); нет

Не могу понять, что я делаю не так?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ПечатьЧекаНаПД(Команда)
   ТабличныйДокумент = СерверЗаполнитьТабличныйДокумент(СсылкаНаДокумент) //ДокументСсылка на тот что пытаемся напечатать;
   ТабличныйДокумент.Напечатать(РежимИспользованияДиалогаПечати.Использовать);   //НужноПечататьМакет()
КонецПроцедуры

&НаСервере
Функция СерверЗаполнитьТабличныйДокумент(ТабличныйДокумент)
   ТабличныйДокумент = Документы.ЧекККМ.ПечатьЧека(ТабличныйДокумент,Неопределено);
   Возврат ТабличныйДокумент;
КонецФункции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Maxm R.

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-21
  • Сайт: 
  • Профессия: Бухгалтер
Вобщем, колдовал-колдовал, так ничего и не вышло
&НаКлиенте
Процедура ПечатьЧекаНаПД(Команда)
ТабличныйДокумент = СерверЗаполнитьТабличныйДокумент(РеквизитЧекККМ.УникальныйИдентификатор());
    ТабличныйДокумент.Напечатать(РежимИспользованияДиалогаПечати.Использовать);   
КонецПроцедуры

&НаСервере
Функция СерверЗаполнитьТабличныйДокумент(ТабличныйДокумент)
   ТабличныйДокумент = Документы.ЧекККМ.ПечатьЧека(ТабличныйДокумент,Неопределено);
   Возврат ТабличныйДокумент;
КонецФункции

После нажатия на кнопку печати 1с закрывается с ошибкой.
в реквизитах формы, наделал ссылок на документ, но результатов не дает, пытался по разному.
с помощью функции тоже ничего не получается, ПолучитьСсылку() она что-то получает непонятное.
Может я не правильно делаю ссылку на документ?
да и как он узнает что мне именно последний чек, то есть документ нужно печатать?
Вопросов возникает больше чем ответов.... не поможешь разобраться с этим?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПечатьЧекаНаПД(Команда)

Откуда это вызывается? т.е. где находиться команда? На форме чего?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Maxm R.

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-21
  • Сайт: 
  • Профессия: Бухгалтер
Форма управляемого приложения (РМК) в Рознице 2.1. Кнопку разместил на основной форме кассира, к ней привязал команду ПечатьЧекаНаПД. в реквизитах формы добавил реквизит с типом значения ДокументСсылка.ЧекККМ. Но как выясняется это все не то

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Выведи этот реквизит на форму и выбери любой документ. Попробуй распечатать.
ТабличныйДокумент = СерверЗаполнитьТабличныйДокумент(РеквизитЧекККМ);

Добавлено: 15 Июн 2014, 05:39

А так тебе уже подсказали давно
Находишь последнюю и печатаешь

Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 327
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal