Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как работать с табличным документом?  (Прочитано 3014 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте!


Скажите пожалуйста как при считывании xml файла чтобы данные отображались в табл.документе ?


Есть код:



&НаСервереБезКонтекста
[size=78%]Процедура ТД ()[/size]


Чтение = Новый ЧтениеXML;


ТабДокумент  = Новый ТабличныйДокумент;


Чтение.ОткрытьФайл("c:\1.xml");
Спр="";
// чтение осуществляется по одному тегу
Пока Чтение.Прочитать() Цикл
   // анализируем тип элемента и его имя
   Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
       ИмяУзла = Чтение.Имя;
   КонецЕсли;      
           
   Если ИмяУзла = "СтраховойНомер" и Чтение.ТипУзла = ТипУзлаXML.Текст Тогда


      дальше непонятно :( ????
      
   КонецЕсли;   
 ...........................
...........................
........



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ОбластьСтрокаДанных = Макет.ПолучитьОбласть("СтрокаДанных");
ОбластьСтрокаДанных.параметры.СтраховойНомер = <<ПрочитанныйСтраховойНомер>>;
ТабДок.Вывести(ОбластьСтрокаДанных);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
ОбластьСтрокаДанных = Макет.ПолучитьОбласть("СтрокаДанных");
ОбластьСтрокаДанных.параметры.СтраховойНомер = <<ПрочитанныйСтраховойНомер>>;
ТабДок.Вывести(ОбластьСтрокаДанных);
Но, мне не нужно чтобы это отражалось в Макете.Можно это сделать чтобы ТД это было визуально видно?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
описана типовая работа с табличным документом...
примерно как печатные формы выводятся...
никто не мешает работать с ТД "напрямую" - через координаты (номер стобца и номер строки) нужной ячейки...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
cska-fanat-kz можно небольшой пример как это выглядит при добавлении строки на моём примере ?
Спасибо.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТД.Область("R1C1").Текст = <<ПрочитанныйСтраховойНомер>>
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
ТД.Область("R1C1").Текст = <<ПрочитанныйСтраховойНомер>>
Хорошо, а если выбросить ТД и сделать всё на ТаблицеЗначений:


&НаКлиенте
Процедура ТаблицаЗначений(Команда)
   ТЗ ()
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ТЗ ()
                 
Чтение = Новый ЧтениеXML;

ТЗНаФорме = Новый ТаблицаЗначений;

Чтение.ОткрытьФайл("c:\1.xml");
Пока Чтение.Прочитать() Цикл
   // анализируем тип элемента и его имя
   Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
       ИмяУзла = Чтение.Имя;
   КонецЕсли;    
   
   Если ИмяУзла = "СтраховойНомер" и Чтение.ТипУзла = ТипУзлаXML.Текст Тогда

   Для Каждого СтрокаТЗ из ТЗНаФорме Цикл   
     НоваяСтрока = ТЗНаФорме.Добавить();
          НоваяСтрока.СтраховойНомер = ??????????? ;
       КонецЦикла;
   КонецЕсли;   
КонецЦикла;
   
КонецПроцедуры

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(6)
НоваяСтрока.СтраховойНомер = ??????????? ;

Чтение.Значение

но вообще-то В Вашей ВНОВЬ созданной ТЗ {
ТЗНаФорме = Новый ТаблицаЗначений;
} НЕТ ни одной колонки...
т.е. НоваяСтрока.СтраховойНомер ??

Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
(6)
НоваяСтрока.СтраховойНомер = ??????????? ;

Чтение.Значение

но вообще-то В Вашей ВНОВЬ созданной ТЗ {
ТЗНаФорме = Новый ТаблицаЗначений;
} НЕТ ни одной колонки...
т.е. НоваяСтрока.СтраховойНомер ??
Да визуально не отображается :(



Теги:
 

Здравствуйте!!! Необходимо востановить ИБ на определенную дату. Копии через конфигуратор на эту дату не сделали, но есть файл в формате CD в rar (Это программа сама сделала резервную копию). Возможно ли востановит ее в 1с и работать (как при загрузке копи

Автор Лариса198888Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1883
Последний ответ 24 Май 2016, 17:17
от Kironten
Как понять почему перестало работать регламентное задание - "отправка отчетов"?

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2183
Последний ответ 26 Июл 2014, 16:00
от virtus
Преобразовать Структуру в Объект XDTO, или как работать с объектом XDTO Structur

Автор znepokРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 14816
Последний ответ 31 Окт 2011, 09:16
от sergeevds
Физлицо может провести регистрацию ИП и приобрести патент в один день и работать по ПСН до конца календарного года

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1003
Последний ответ 13 Май 2014, 11:41
от news
Перенесено: Каким документом в конфе "Бухгалтерия сельхоз предпр" начисляется налог на землю

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 673
Последний ответ 05 Май 2016, 05:58
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 231
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal