Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 17:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пересчет суммы НДС в документе «Реализация товаров и услуг»  (Прочитано 4740 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 99format

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-03
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. В 1с 8.2 КА 1.1 стоит задача пересчитать сумму НДС в документе «Реализация товаров и услуг» по определенному отбору, через «Групповую обработку справочников и документов» не получается (сумма пересчитывается только если вручную «перещелкать» проценты). Решил попробовать написать внешний обработчик (второй раз в жизни). С помощью Конструктора запроса делаю выборку ссылок документа по наименование контрагента и организации

Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   РеализацияТоваровУслуг.Ссылка
      |ИЗ
      |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
      |ГДЕ
      |   РеализацияТоваровУслуг.Организация.Наименование = ""АААА""
      |   И РеализацияТоваровУслуг.Контрагент.Наименование = ""ББББ""";

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      // Вставить обработку выборки ВыборкаДетальныеЗаписи
   КонецЦикла;

Так же нашел процедуру ТоварыСтавкаНДСПриИзменении() , как понимаю это то что нужно, проблема как их совместить вместе ? Сразу прошу прощения за дилетантизм — нашел нужный мне обработчик на http://katalog.forum-1c.ru — но он там платный стоит одно ихнее у.е. - а купить этих у.е. нужно минимум 10 штук (т. е. 1000р) — так как время на решении этой задачи есть — решил попробовать решить ее самостоятельно (с помощью Вашей помощи :-) )

Спасибо.

Последний раз редактировалось: MuI_I_Ika; 29 Июн 2017, 16:06


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
внутри вашего цикла
1. получаете объект документа
2. крутим цикл по табличной части
3. если ставка не равно "без ндс", то СтрокаТЧ.СуммаНДС = СтрокаТЧ.Сумма * СТАВКА / 100+СТАВКА
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн 99format

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-03
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн 99format

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-03
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите еще плз, делаю следующим образом:


Процедура КнопкаВыполнитьНажатие(Кнопка)
   Запрос = Новый Запрос;
   Запрос.Текст =

// Для теста выбираю один документ
      "ВЫБРАТЬ
      |   РеализацияТоваровУслуг.Ссылка
      |ИЗ
      |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
      |ГДЕ
      |   РеализацияТоваровУслуг.Номер = ""Трк00000876""";

   Выборка = Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл
   Документ = Выборка.Ссылка.ПолучитьОбъект();
   Документ = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
   ТабЧасть = Документ.Товары;
   Для Каждого СтрокаТЧ Из ТабЧасть Цикл
//Для теста хочу просто поменять число в колонке суммаНДС
      СтрокаТЧ.СуммаНДС = 100;
   КонецЦикла;
//   Документ.Дата = ТекущаяДата();
   Документ.Записать(РежимЗаписиДокумента.Запись);
   КонецЦикла;

КонецПроцедуры

Проблема в том, что ошибок (кроме пустой даты) 1с не пишет, но и не меняет значение, документ выбирается точно так как при РежимиЗаписиДокумента.Проведение - он проводится. Как я понимаю, я просто не правильно перебираю табличную часть ??

Спасибо.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Документ = Выборка.Ссылка.ПолучитьОбъект();
Документ = Документы.РеализацияТоваровУслуг.СоздатьДокумент();

Объясните ЭТО

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн 99format

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-03
  • Сайт: 
  • Профессия: Ученик 1С
:-) Честно скажу - взял из примера нашедшего на форуме про обработку выборки...
Ошибку исправил, сделал вот так.


Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   
   "ВЫБРАТЬ
   |   РеализацияТоваровУслуг.Ссылка,
   |   РеализацияТоваровУслуг.Товары.(
   |      СуммаНДС
   |   )
   |ИЗ
   |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
   |ГДЕ
   |   РеализацияТоваровУслуг.Контрагент.Наименование = ""XXXXXX""
   |   И РеализацияТоваровУслуг.Организация.Наименование = ""YYYYYY""";   
   
   Выборка = Запрос.Выполнить().Выбрать();
   Цк = 1;
   
   Пока Выборка.Следующий() Цикл
      Сообщить(Цк);
      
      Документ = Выборка.Ссылка.ПолучитьОбъект();
      
      ТабЧасть = Документ.Товары;
      
      Для Каждого СтрокаТЧ Из ТабЧасть Цикл
// У меня везде есть НДС и он везде 10 %

         СтрокаТЧ.СуммаНДС = СтрокаТЧ.Сумма*10/100+10;
         
      КонецЦикла;
      
      Документ.Записать(РежимЗаписиДокумента.Запись);
      
      КонецЦикла;

КонецПроцедуры


Все работает - нужные данные меняются и записываются (я с бухом только по поводу формулы уточню).

ОГРОМНОЕ спасибо - cska-fanat-kz :-)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
должно быть вот так:

СтрокаТЧ.СуммаНДС = СтрокаТЧ.Сумма*10/(100+10);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 473
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
Перенос товаров из д-та "Поступление Т и У" в "Отчет о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5161
Последний ответ 01 Июн 2011, 16:31
от Eugeneer
Отчет "Динамика закупок" ("Анализ себестоимости товаров") в Управлении Торговлей 11

Автор GunnerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1953
Последний ответ 19 Фев 2016, 10:24
от Надеждда
ошибка проведения реализации "При списании комиссионных товаров не определены параметры партии ""

Автор WelllaryРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3735
Последний ответ 15 Апр 2015, 17:58
от Дмитрий@
Бух 3.0 Возврат "товаров от покупателей"

Автор Elena_2015Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1717
Последний ответ 26 Фев 2015, 12:15
от Elena_2015

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 583
  • Точка Скрытых: 1
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal