Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 16:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка печати "Метод объекта не обнаружен"  (Прочитано 3801 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Роза Гамильтоновна

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-17
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Помогите решить проблему. В программировании в 1С я новичок.
При нажатии на печать сметы выдает ошибку.
Вот код:
{Документ.Смета.Команда.ПечатьСметы.МодульКоманды(18)}: Метод объекта не обнаружен (СметаПечать)
    Документы.Смета.СметаПечать(ТабДок, ПараметрКоманды);
Как добавить метод (СметаПечать), чтобы все выводилось на печать и проводилось в док-те Смета?
Помогите Пожалуйста.


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
ПРИЙДЁТСЯ, наверное, программиста пригласить...
потому что НАДО маленько ПОПРОГРАММИРОВАТЬ...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Роза Гамильтоновна

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-17
  • Сайт: 
  • Профессия: Ученик 1С
Вот код полностью:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //{{_КОНСТРУКТОР_ПЕЧАТИ(СметаПечать)
    ТабДок = Новый ТабличныйДокумент;
    СметаПечать(ТабДок, ПараметрКоманды);
 
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать();
    //}}
КонецПроцедуры
 
&НаСервере
Процедура СметаПечать(ТабДок, ПараметрКоманды)
    Документы.Смета.СметаПечать(ТабДок, ПараметрКоманды);
КонецПроцедуры
Скажите хоть как метод добавить то(

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(2)ЭТО {
&НаСервере
Процедура СметаПечать(ТабДок, ПараметрКоманды)
    Документы.Смета.СметаПечать(ТабДок, ПараметрКоманды);
КонецПроцедуры
}
ЛИШНЕЕ.

в модуле менеджера создайте ЭКСПОРТНУЮ процедуру печати с именем "СметаПечать",
а в ней НАДО написать программный код заполнения табличного документа,
который и будет распечатываться на принтере.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 

Закрытие месеца, ошибка при закрытие 26сч

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4115
Последний ответ 26 Июл 2013, 11:00
от Gendelf
ОШИБКА 1С 8.3. Файл не найден в хранилище файлов. Возможно файл удален антивирусной программой. Обратитесь к администратору

Автор Сергей БатуринРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 6337
Последний ответ 18 Май 2016, 18:18
от Сергей Батурин
При попытке проведения документов по НДФЛ (справка 2 НДФЛ ) вылезает ошибка:

Автор klaus38Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2814
Последний ответ 19 Фев 2015, 20:54
от vitasw
При входе пользователя 1с77 по RDP (Server2008) выдается ошибка и выпадает 1с77

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1650
Последний ответ 07 Дек 2016, 09:17
от alex0402
Как создать в 1С 8.2 группы контроагентов когда при ножатие папочки с плюсом выходит ошибка при устоновке значения атрибута текста (ОсновнойМенеджерПокупателя)

Автор fat001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2764
Последний ответ 02 Апр 2014, 23:11
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal