Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка XML файла  (Прочитано 2915 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте!
Есть файл XML след.структуры (привожу в сокращённой форме):
Задача вывести в ТЗ показать колонки: Страх.Номер, Фамилия, Имя, Отчество, [size=78%]ДатаНачалаПериода, [/size][/size][size=78%]ДатаКонцаПериода.[/size]
Затем все это Экспортировать в Excell (c полями показанные выше).
Есть код и несколько вопросов:
1. Как показать в ТЗ поля;
2. Как вывести в XLS.



Процедура КнопкаВыполнитьНажатие(Кнопка)
   Попытка
      ЧтениеXML = Новый ЧтениеXML;
      ЧтениеXML.ОткрытьФайл(ПутьКФайлу);
      Пока ЧтениеXML.Прочитать() Цикл
         Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
            Имя = ЧтениеXML.Имя;
         КонецЕсли;
         Если Имя = "СтраховойНомер" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
            Сообщить(ЧтениеXML.Значение);
         КонецЕсли;
         Если Имя = "Фамилия" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
            Сообщить(ЧтениеXML.Значение);
         КонецЕсли;
         Если Имя = "Имя" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
            Сообщить(ЧтениеXML.Значение);
         КонецЕсли;
            Если Имя = "Отчество" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
            Сообщить(ЧтениеXML.Значение);
         КонецЕсли;
        КонецЦикла;   
      ЧтениеXML.Закрыть();   
   Исключение
      Сообщить(ОписаниеОшибки());
   КонецПопытки;
КонецПроцедуры




ФАЙЛ ИМЕЕТ СЛЕД.СТРУКТУРУ:



<Год>2010</Год>
    </ОтчетныйПериод>
   <СтраховойНомер>123-111-222 33</СтраховойНомер>
    <ФИО>
    <Фамилия>Иванов</Фамилия>
    <Имя>Иван</Имя>
    <Отчество>Иванович</Отчество>
    </ФИО>
[/size][size=78%]    <НомерСтроки>1</НомерСтроки>[/size]
    <ДатаНачалаПериода>01.01.2010</ДатаНачалаПериода>
    <ДатаКонцаПериода>31.12.2010</ДатаКонцаПериода>


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) почитай работа с XML
 1. Как показать в ТЗ поля {
если колонки известны ЗАРАНЕЕ, то и создай их СРАЗУ в ТЗ на форме
}
2. Как вывести в XLS {
создай табличный документ и запиши его указав параметр - тип файла XLS.
}

Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
пишется диалог выбора файла. У меня выдает такое сообщение :
{Справочник.Клиенты.Форма.ФормаСписка.Форма(31,1)}: Неопознанный оператор
<<?>>&НаКлиенте (Проверка: Сервер)
{Справочник.Клиенты.Форма.ФормаСписка.Форма(34,30)}: Тип не определен (ДиалогВыбораФайла)
   ДиалогОткрытияФайла = Новый <<?>>ДиалогВыбораФайла(Режим);  (Проверка: Сервер)
{Справочник.Клиенты.Форма.ФормаСписка.Форма(31,1)}: Неопознанный оператор
<<?>>&НаКлиенте (Проверка: Тонкий клиент)

Что неправильно делаю ?

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(2)твоя процедура компилируется на сервере, а на сервере "ДиалогВыбораФайла" НЕ доступен.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
можно небольшой пример как "связать" Таблицу Значений и XML ?

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
никто не знает ?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 144
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal