Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 23:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Передача БУЛЕВО из реквизита справочника в табличную часть документа  (Прочитано 2426 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beztrud

Здравствуйте! 1с 8.3 управляемая форма самописная конфигурация. Есть справочник Номенклатура с реквизитами, один из которых имеет тип булево. И есть обработка с табличной частью ИсходныеДанные. Так вот в этой табличной части есть реквизит Номенклатура - Справочник.Номенклатура. При его изменении (или при изменении любого другого реквизита) в строке табличной части должны подтягиваться данные из справочника номенклатура. Все данные строкового и числового типа тащу с сервера например так:
&НаКлиенте
Процедура ИсходныеДанныеВысотаПриИзменении(Элемент)
СтрокаТабличнойЧасти=Элементы.ИсходныеДанные.ТекущиеДанные;
СтрокаТабличнойЧасти.Толщина = ПолучитьТолщинуКромки(СтрокаТабличнойЧасти.КромочныйМатериал);

.........
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьТолщинуКромки(Номенклатура)
Возврат Номенклатура.Толщина;
КонецФункции
С булевым такое не прокатывает. Единственное до чего додумался - ввести в справочник номенклатура доп.реквизит тип строка и заполнять его значение ДА/НЕТ в зависимости от состояния флажка. А затем получать ДА/НЕТ через функцию. Но это как-то коряво! Наверняка должно быть более изящное решение. Спасибо!


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
С булевым такое не прокатывает.

как это ?
и ЧТО возвращает, например, [Номенклатура.Услуга] ??
в отладчике... КАКОЙ ТипЗнч?
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн beztrud

{Обработка.ОбработкаПластика.Форма.Форма.Форма(156)}: Значение не является значением объектного типа (Кант)
   Возврат Номенклатура.Кант;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Реквизит типа булево абсолютно ничем не отличается от реквизитов типа строка или число.
Лучше приведите код где вы получаете реквизит этого типа.
А то как получать реквизит номенклатуры на сервере - мы и так знаем ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн beztrud

&НаКлиенте
Процедура ИсходныеДанныеВысотаПриИзменении(Элемент)
СтрокаТабличнойЧасти=Элементы.ИсходныеДанные.ТекущиеДанные;
Если СтрокаТабличнойЧасти.КромочныйМатериал.Пустая()
Тогда
Предупреждение("Необходимо выбрать кромочный материал", ,"Внимание!");
Иначе
СтрокаТабличнойЧасти.Толщина = ПолучитьТолщинуКромки(СтрокаТабличнойЧасти.КромочныйМатериал);
СтрокаТабличнойЧасти.ШиринаКромки = ПолучитьШиринуКромки(СтрокаТабличнойЧасти.КромочныйМатериал);
СтрокаТабличнойЧасти.Свес = ПолучитьСвес(СтрокаТабличнойЧасти.КромочныйМатериал);
СтрокаТабличнойЧасти.ПрипускНаПодрезку = ПолучитьПрипускНаПодрезку(СтрокаТабличнойЧасти.КромочныйМатериал);
                СтрокаТабличнойЧасти.Кант=ПолучитьКант(СтрокаТабличнойЧасти.КромочныйМатериал);
                    КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьКант(Номенклатура)
Возврат Номенклатура.Кант;
КонецФункции
Добавлено: 04 Июн 2014, 19:58

Извиняюсь за беспокойство, сам разобрался, все работает!!!

Последний раз редактировалось: beztrud; 04 Июн 2014, 19:58. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15949
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7751
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4787
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1591
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal