Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: КД и отбор  (Прочитано 3059 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Создаю правила выгрузки справочника, как можно сделать отбор по элементам справочника, которые находятся в конкретной группе?
Спасибо.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: КД и отбор
« Ответ #1: 03 Июн 2014, 12:20 »
добавляете параметр типа СправочникСсылка. можно указать что отобразить его на форме УнивесальногоОбменаХМЛ. Туда выбираете нужную группу. Ну или устанавливаете параметр программно.

В ПКО, по которому выгружаем справочник, в событии ПередВыгрузкойДанных() пишем
Если Источник.Родитель <> Параметры.ГруппаСправочника Тогда
    Отказ = Истина;
КонецЕсли;

Единственное - не будут выгружаться элементы из нужной группы, которые находятся еще в какой нить группе.
В этом случае в ПВД меняем "стандартную выборку" на "произвольный запрос"...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Re: КД и отбор
« Ответ #2: 03 Июн 2014, 12:28 »
добавляете параметр типа СправочникСсылка. можно указать что отобразить его на форме УнивесальногоОбменаХМЛ. Туда выбираете нужную группу. Ну или устанавливаете параметр программно.

В ПКО, по которому выгружаем справочник, в событии ПередВыгрузкойДанных() пишем
Если Источник.Родитель <> Параметры.ГруппаСправочника Тогда
    Отказ = Истина;
КонецЕсли;

Единственное - не будут выгружаться элементы из нужной группы, которые находятся еще в какой нить группе.
В этом случае в ПВД меняем "стандартную выборку" на "произвольный запрос"...
А если конкретнее про стандартную выборку и на произвольный запрос? Я просто учусь на конвертации, первый раз что-то делаю=) я просто хочу сделать отбор, чтобы к примеру номенклатура вся загрузилась только из конкркетной группы в иерархии.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: КД и отбор
« Ответ #3: 03 Июн 2014, 13:45 »
Ставим способ выборки - Произвольный запрос.
У ПВД, по которому переносится справочник, в событии ПередОбработкой() пишем запрос
(отладить можно в консоли запросов на самой базе).
Результат запроса (Запрос.Выполнить()) присваиваем переменной ВыборкаДанных.
Соответственно поля запроса должны соответствовать ПКС'ам...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: КД и отбор
« Ответ #4: 04 Июн 2014, 00:25 »
в ПКО перед выгрузкой ставите условие
Если Источник.ЭтоГруппа Тогда
Если Источник.Наименование <> "Нужная группа" Тогда
Отказ = Истина;
КонецЕсли;
Иначе
Если Источник.Родитель.Наименование <> "Нужная группа" Тогда
Отказ = Истина;
КонецЕсли;
КонецЕсли;
примечание: выгружается вся номенклатура в группе "Нужная группа" вместе с группой, работает правильно только если один уровень вложенности

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: КД и отбор
« Ответ #5: 04 Июн 2014, 12:31 »
в ПКО перед выгрузкой ставите условие
Если Источник.ЭтоГруппа Тогда
Если Источник.Наименование <> "Нужная группа" Тогда
Отказ = Истина;
КонецЕсли;
Иначе
Если Источник.Родитель.Наименование <> "Нужная группа" Тогда
Отказ = Истина;
КонецЕсли;
КонецЕсли;
примечание: выгружается вся номенклатура в группе "Нужная группа" вместе с группой, работает правильно только если один уровень вложенности


ИМХО лучше в ПВД отсекать ненужные....
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: КД и отбор
« Ответ #6: 04 Июн 2014, 15:07 »
ИМХО лучше в ПВД отсекать ненужные....
для освоения КД и так пойдет

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: КД и отбор
« Ответ #7: 04 Июн 2014, 17:07 »
Дальнейший спор считаю нерациональным, однако пусть сразу учится как правильно :befhbt:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4245
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3095
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 43
Последний ответ 12 Дек 2017, 20:56
от alex0402
Отбор по номенклатуре в отчете "ВЕдомость выдачи мц"

Автор notaSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2326
Последний ответ 08 Авг 2015, 15:40
от ppkmlite
Отбор по дате проведения документа в обработке "Универсальные подбор и обработка объектов"

Автор rooflessРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2571
Последний ответ 25 Июн 2014, 15:30
от roofless

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 258
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal