Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 04:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Двухсторонняя печать в "Пакетной выписки"  (Прочитано 4974 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день, вопрос не однократно поднимался про двухстороннюю, но разобраться не получилось, может быть поможете.
Печают путевой лист - нажимаю печать выставляю галочку двух-сторонняя, переворот по короткому краю, масштаб 75. - печается превосходно.
Этот же путевой лист путаюсь напечатать из Пакетной выписки ( там активна только кнопка печать и сразу посылает на принтер). В итоге - мелко напечатанный документ.
Не пойму почему??? Обработка обращается к той же процедуре. Через отладчик смотрю параметры - те же.
Функция уатПечать_3(ИмяМакета, ФлагПечати="") Экспорт
Перем мВодительскоеУдСерия, мВодительскоеУдНомер, мВодительскоеУдКатегория;
мМаксСтрок = 18;
ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПутевойЛист_ПутевойЛист";
Макет = ПолучитьМакет(ИмяМакета);
ТабДокумент.МасштабПечати = 75;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДокумент.ПолеСверху = 0;
ТабДокумент.ПолеСлева = 0;
ТабДокумент.ПолеСнизу = 0;
ТабДокумент.ПолеСправа = 0;
//печатаем лицевую сторону п/л
Если ФлагПечати <> 2 Тогда
Обл   = Макет.ПолучитьОбласть("Лицевая");

........
ТабДокумент.Вывести(Обл);
КонецЕсли;

Если ФлагПечати = 0 Тогда //Новая страница для печати полного пут. листа
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

//печатаем обратную сторону п/л
Если ФлагПечати <> 1 Тогда
        Обл   = Макет.ПолучитьОбласть("Оборотная");
ТабДокумент.Вывести(Обл);
КонецЕсли;

Возврат ТабДокумент;
КонецФункции


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Еще влияют настройки принтера. Может перед пакетной печатью следует пройтись по каждой печатной форме и установить настройки принтера.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
скопировала принтер. Указала настройки необходимые (двух-сторонняя печать, переворот через короткий край). Печатаю путевой лист - выбираю нужный принтер. Печатает нормально. Предполагаю что ТабДокумент.ИмяПараметровПечати сохранились эти настройки.
Захожу в Пакетную выписку - печать - печатает мелко и на двух листах.
Пробовала в ручную прописать ИмяПринтера. Не помогло.


Теги:
 

Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 797
Последний ответ 15 Май 2017, 08:59
от ZSS
Платформа - 8.3 (8.3.7.1776). Бухгалтерия предприятия, редакция (3.0.43.100). Интерфейс управляемый. Печать счета на оплату.

Автор tucson56Раздел Беседка

Ответов: 0
Просмотров: 1449
Последний ответ 10 Фев 2016, 13:45
от tucson56
При выводе на печать программа зависает на 1-3 минуты до появления окошка выбора принтера

Автор Анатолий СергеевичРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6032
Последний ответ 22 Мар 2014, 00:38
от MuI_I_Ika
Когда вывожу документ на печать в графе количество вместо цифр появляется ####

Автор Hard ХардРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 212
Последний ответ 12 Фев 2018, 11:53
от Геннадий ОбьГЭС
Где найти добавление картинок (подпись, печать) в макет - счет на оплату!

Автор Alex554Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 10253
Последний ответ 07 Окт 2011, 20:10
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
60 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
33 Сообщений
buketov.av buketov.av
28 Сообщений
Alter
22 Сообщений
alexandr_ll
19 Сообщений
Анюта17
19 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal