Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Результат простого запроса "Ошибка чтения значения"  (Прочитано 11660 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 2Casp

  • Руслан
  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет!
Подскажите не могу понять почему в отладчике значение Результат.Выбрать().ОсновнойТехник значение равно Ошибка чтения значения. Хотя запрос в консоли выполняется верно. Куда смотреть?
Конфигурация УТ 11.1.6.17

&НаКлиенте
Процедура КлиентОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Объект.Исполнитель = ПолучитьИсполнителяНаСервере(ВыбранноеЗначение);
КонецПроцедуры


&НаСервереБезКонтекста
Функция ПолучитьИсполнителяНаСервере(Партнер)
Запрос = Новый Запрос;

ТекстЗапроса = "
|ВЫБРАТЬ
| Партнеры.Ссылка,
| Партнеры.Наименование,
| Партнеры.ОсновнойТехник.Ссылка КАК ОсновнойТехник
|ИЗ
| Справочник.Партнеры КАК Партнеры
|ГДЕ
| Партнеры.Наименование = &Наименование
|
|";


Запрос.УстановитьПараметр("Наименование", Партнер);

Запрос.Текст = ТекстЗапроса;
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Пока Выборка.Следующий() Цикл
Выборка.ОсновнойТехник;
КонецЦикла;

КонецФункции // ПолучитьИсполнителяНаСервере()


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Потому что прежде чем получать значение из выборки сначала нужно спозиционироваться на конкретной записи.

Например это делается методом Следующий();

Оффлайн 2Casp

  • Руслан
  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
   
Пока Выборка.Следующий() Цикл
      Возврат Выборка.ОсновнойТехник;
   КонецЦикла;


Потому что прежде чем получать значение из выборки сначала нужно спозиционироваться на конкретной записи.

Например это делается методом Следующий();

Не совсем понял...

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Смотри в отладчике строчку после Выборка.Следующий()

Выборка.ОсновнойТехник;

Оффлайн 2Casp

  • Руслан
  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
Смотри в отладчике строчку после Выборка.Следующий()

Выборка.ОсновнойТехник;
В том то и дело, не пойму почему я даже в цикл Пока Выборка.Следующий() Цикл не захожу. Вся Выборка Ошибка чтения значения. Открываю этот запрос в консоли, там получаю Ссылку на ОсновнойТехник

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Вот эта строка выдает ошибку чтения значения?

 Результат.Выбрать()

Оффлайн 2Casp

  • Руслан
  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
Вот эта строка выдает ошибку чтения значения?

 Результат.Выбрать()

Да

Добавлено: 27 Май 2014, 17:29

Вот эта строка выдает ошибку чтения значения?

 Результат.Выбрать()

Да




Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А почему кстати пытаетесь отбирать по наименованию? Вполне можно по ссылке отбирать. Что будете делать когда появятся два контрагента с одним наименованием?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Я же объясняю пока выборка не спозиционирована на конкретном значении никаких значений вы в отладчике не получите, так что все правильно вам программа показывает.

Оффлайн 2Casp

  • Руслан
  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
А почему кстати пытаетесь отбирать по наименованию? Вполне можно по ссылке отбирать. Что будете делать когда появятся два контрагента с одним наименованием?

Спасибо. Поменял наименование на ссылку.


Теги:
 

Закрытие месеца, ошибка при закрытие 26сч

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4119
Последний ответ 26 Июл 2013, 11:00
от Gendelf
ОШИБКА 1С 8.3. Файл не найден в хранилище файлов. Возможно файл удален антивирусной программой. Обратитесь к администратору

Автор Сергей БатуринРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 6353
Последний ответ 18 Май 2016, 18:18
от Сергей Батурин
При попытке проведения документов по НДФЛ (справка 2 НДФЛ ) вылезает ошибка:

Автор klaus38Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2818
Последний ответ 19 Фев 2015, 20:54
от vitasw
При входе пользователя 1с77 по RDP (Server2008) выдается ошибка и выпадает 1с77

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1656
Последний ответ 07 Дек 2016, 09:17
от alex0402
Допущенная врачом ошибка в больничном листе, не может стать причиной отказа в возмещении расходов на выплату пособия

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1392
Последний ответ 29 Авг 2015, 21:13
от topics

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 272
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal