Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 00:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Присвоение переменной значения из регистра.  (Прочитано 2163 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Сережа Лэ

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
  • Профессия: Программист 1С
Есть Табличная часть "Разовое", в ней поле "Детский" с форматом булево. Когда он включен к полю "Сумма" прибавляется 150.  Значение 150 нужно взять из регистра сведений "ЦенаПосещения", подскажите как это лучшге сделать?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Обрабатывать событие ПриИзменении() поля "Детский".
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Сережа Лэ

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
  • Профессия: Программист 1С
Ну это понятно, Как мне значение из регистра вытащить в эту процедуру?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Запросом. Пример привести не могу - мало данных...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Сережа Лэ

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
  • Профессия: Программист 1С
В табличной части Разовое поля: Номер билета, Время, Детский, Инструктор, Стоимость инвентаря, Сумма. Табличная часть находиться в документе Посещения
В регистре сведений Посещение, Цена.
Вот так реализовал присваивая цену вручную

&НаКлиенте
Процедура РазовоеДетскийПриИзменении(Элемент)   
   ТекущаяСтрока = Элементы.Разовое.ТекущиеДанные;
       Если ТекущаяСтрока.Детский = Истина Тогда
   ТекущаяСтрока.Сумма = 0;
   ТекущаяСтрока.Сумма = ТекущаяСтрока.Сумма + 150;
Иначе ТекущаяСтрока.Сумма = ТекущаяСтрока.Сумма -150;
   КонецЕсли
Конецпроцедуры

Нужно 150 брать из регистра.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
&НаКлиенте
Процедура РазовоеДетскийПриИзменении(Элемент)   
   ТекущаяСтрока = Элементы.Разовое.ТекущиеДанные;
       Если ТекущаяСтрока.Детский = Истина Тогда
   ТекущаяСтрока.Сумма = 0;
   ТекущаяСтрока.Сумма = ТекущаяСтрока.Сумма + 150;
Иначе ТекущаяСтрока.Сумма = ТекущаяСтрока.Сумма -150;
   КонецЕсли
Конецпроцедуры

вот ЭТО - зачем????
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ЦеныНоменклатурыСрезПоследних.Цена
      |ИЗ
      |   РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&Дата, Номенклатура = &Номенклатура) КАК ЦеныНоменклатурыСрезПоследних";

   Запрос.УстановитьПараметр("Дата", Дата);
   Запрос.УстановитьПараметр("Номенклатура", Номенклатура);

   РезультатЗапроса = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
   
      ТекущаяЦена = ВыборкаДетальныеЗаписи.Цена;
   
   Иначе
   
      ТекущаяЦена = 0;
   
   КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 283
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 985
Последний ответ 11 Июл 2016, 09:00
от vitasw
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9361
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Как сложить значения Столбца "Объем"

Автор anton.kislovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 13536
Последний ответ 04 Май 2017, 10:48
от ospov11789
Ошибка "Итератор для значения не определён"

Автор КараулРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 846
Последний ответ 17 Авг 2016, 11:25
от Караул

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 185
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal