Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Хелп  (Прочитано 3158 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Хелп
« Первое сообщение: 17 Июн 2010, 08:58 »
Для Каждого ТекСтрокаОсновные Из Основные Цикл
      Движение = Движения.Результаты.Добавить();
      Движение.Сторно = Ложь;
      Движение.ВидРасчета = ТекСтрокаОсновные.ВидРасчета;
      Движение.ПериодДействияНачало = НачалоМесяца(ПериодРегистрации);
      Движение.ПериодДействияКонец = КонецМесяца(ПериодРегистрации);
      Движение.ПериодРегистрации = ПериодРегистрации;
   

      Если ТекСтрокаОсновные.ВидРасчета = ПланыВидовРасчета.ВидыРасчета.Премия Тогда
         Движение.БазовыйПериодНачало = НачалоМесяца(ПериодРегистрации);
         Движение.БазовыйПериодКонец = КонецМесяца(ПериодРегистрации);
      КонецЕсли;
      
      Движение.Сотрудник = ТекСтрокаОсновные.Сотрудник;
      
      Если ТекСтрокаОсновные.ВидРасчета = ПланыВидовРасчета.ВидыРасчета.Штраф Тогда
         Движение.Результат = ТекСтрокаОсновные.Величина;
      КонецЕсли;
      
      Движение.Величина = ТекСтрокаОсновные.Величина; //Вот сдесь сотрудника видит , а величину не видит
   КонецЦикла;
   
   Движения.Результаты.Записать();
   Ресурсы  = Новый Массив(1);
   Ресурсы[0] = "Результаты.Результат";
   Измерения = Новый Структура("Сотрудник","Результаты","Сотрудник");
   
   Для Каждого Движение из Движения.Результаты Цикл
      Если Движение.ВидРасчета = ПланыВидовРасчета.ВидыРасчета.Оклад Тогда
         Движение.ПолучитьДанныеГрафика(ВидПериодаРегистраРасчета.ФактическийПериодДействия);
         Отработано = Движение.ПолучитьДанныеГрафика(ВидПериодаРегистраРасчета.ФактическийПериодДействия);
         Норма = Движение.ПолучитьДанныеГрафика(ВидПериодаРегистраРасчета.ФактическийПериодДействия);
         Движение.Результат = Движение.Величина*Отработано[0].Значение/Норма[0].Значение;
      КонецЕсли;
   КонецЦикла;
   
   Движения.Результаты.Записать();
   
   Для Каждого Движение из Движения.Результаты Цикл
      Если Движение.ВидРасчета = ПланыВидовРасчета.ВидыРасчета.Премия Тогда
         ДанныеБазы = Движение.ПолучитьБазу(Ресурсы,Измерения);
         Движение.Результат  = Движение.Величина * ДанныеБазы[0].Результат/100;
        КонецЕсли;
   КонецЦикла;

почему Движение не видит Величину не могу понять?


Оффлайн tat6428

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-12
  • Сайт: 
Re: Хелп
« Ответ #1: 30 Июл 2010, 10:30 »
Эта процедура взята из методички "Введение в конфигурирование..."? У меня тоже здесь проблемы, но у меня ругается, что делить на 0 нельзя в строке:"Движение.Результат=Движение.Результат*Отработано[0].Значение/Норма[0].Значение;" Помогите кто-нибудь!!

Slin
  • Гость
Re: Хелп
« Ответ #2: 30 Июл 2010, 11:06 »
tat6428
Очевидно, что Норма[0].Значение равно 0. Это означает, что значение нормы не заполнено. Значит, не выполнена предварительная последовательность действий.
В крайнем случае, можно поставить проверку на равенство 0.

макс
Здесь проблема?
Движение.Величина = ТекСтрокаОсновные.Величина; //Вот сдесь сотрудника видит , а величину не видит 
Проверь структуру регистра "Результаты"

Оффлайн tat6428

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-12
  • Сайт: 
Re: Хелп
« Ответ #3: 30 Июл 2010, 11:12 »
tat6428
Очевидно, что Норма[0].Значение равно 0. Это означает, что значение нормы не заполнено. Значит, не выполнена предварительная последовательность действий.
В крайнем случае, можно поставить проверку на равенство 0.

Какая последовательность действий? Где можно заполнить значение нормы?

Slin
  • Гость
Re: Хелп
« Ответ #4: 30 Июл 2010, 11:19 »
Ну я тебе точно не скажу...
Если ты занимаешься по книжке, судя по вышенаписанному, то в книге должны быть прописаны все этапы. Что-то ты не сделал. Вообще, насколько помню, норма должна содержаться в регистре сведений. Вероятно, в виде графика.
Кстати, возможно ты используешь период, на который не забиты значения.

Оффлайн tat6428

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-12
  • Сайт: 
Re: Хелп
« Ответ #5: 30 Июл 2010, 12:44 »
Да я работаю по книжке, там надо было завести регистр сведений График, не периодический, Измерение -Дата, реквизит - Значение. ПериодРегистрации ставлю 27.07.2010, на эту же дату забиты значния в регистре, но все равно отработано видит значение 0 и норма тоже 0.

Slin
  • Гость
Re: Хелп
« Ответ #6: 30 Июл 2010, 13:16 »
не знаю...
но копать надо здесь

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Re: Хелп
« Ответ #7: 13 Авг 2010, 11:01 »
тоже столкнулась, нашла решение:  В регистреРеасчетов Результаты в Измерении Сотрудник и в Ресурсе Сумма убрала связь с графиком, но считает что Норма равно Отработано


Теги:
 

ХЕЛП!!! Заполнение Табличной части документа Реквизитами Бизнес процессв

Автор KuBeR12Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1490
Последний ответ 25 Ноя 2013, 19:27
от MuI_I_Ika
Хелп!!!Подскажите пожалуйста как мне быть со счетами фактур!!!!!!!!!!!!!!!

Автор Женя1990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 7820
Последний ответ 05 Апр 2012, 12:48
от Женя1990
Добовление в меню кнопок? нид хелп

Автор AlexanderZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1108
Последний ответ 08 Июл 2011, 11:30
от AlexanderZ
Хелп - помогите научиться писать код

Автор nr1Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 29
Просмотров: 15912
Последний ответ 19 Ноя 2012, 11:17
от Gunner
Очень нужен ХЕЛП!!!!

Автор dorsajРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1618
Последний ответ 22 Май 2010, 14:11
от dorsaj

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 131
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal