Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2020, 21:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с обработкой  (Прочитано 11544 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
Ругается на половину кода, как в 1с 8.1 реализовать этот синтаксис, такие операторы типа "Выбрать" , "Получить" , "ВыбратьСтроки" и т.д, подскажите плиз кто знает синтаксис 1с 8.1


ПЛ = Документы.БС_ПутевойЛистАвтомобиля.СоздатьДокумент();
   Док = Документы.ТребованиеНакладная.СоздатьДокумент();
   
   
   ПЛ.Выбрать(НачалоПериода,КонецПериода);
   Пока ПЛ.Получить()=1 Цикл
      
            
      ПЛ.ВыбратьСтроки();
      Пока ПЛ.ПолучитьСтроку() = 1 Цикл
         
         Если  ПЛ.РасходГорючегоФакт<>0 тогда           
            Док.ЭтоНовый();
            Док.ПутевойЛист = ПЛ;
            
            Док.Дата=Пл.Дата;
            Док.Материалы =ПЛ.ТранспортноеСредство.МаркиТоплива.Материал;
            
            Для А = 1 По 3 Цикл
               Док.НазначитьТип("Субконто"+А,ПЛ.Видработ.СчетБУ.ВидСубконто(А));
            КонецЦикла; 
            
            Док.СчетЗатрат=ПЛ.СчетБУ;
            Док.Субконто1=ПЛ.СубконтоБУ1;
            Док.Субконто2=ПЛ.СубконтоБУ2;
            Док.Субконто3=ПЛ.СубконтоБУ3;
         КонецЕсли;
         Док.НоваяСтрока() ;
         Док.НоменклатурнаяГруппа = ПЛ.МаркиТоплива;
         Док.Количество = ПЛ.РасходГорючегоФакт;
         
         
      КонецЦикла;   
   
   Сообщить("Обработка завершена!");   


Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
C синтаксисом немного разобрался уже B)
Теперь проблема в следующем, как обратится к реквизиту табличной части документа

Док.Материалы.Номенклатура= ПЛ.ТранспортноеСредство.МаркиТоплива.Материал.Наименование;

вот как мне в данной строчке обратится к реквизиту Номенклатура который находится в табличной части документа
через элементыформы не прокатило

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
так тыж только создал документ ПЛ как ты к ниму обратишьсо? эго необходимо записать

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
ПЛ.Записать(РежимЗаписиДокумента.Проведение);

сразу после создания вот так записать его?
и еще вопрос как мне обратится к реквизиту документа который находится в табличной части?
Док.СчетЗатрат=ПЛ.ТабличнаяЧасть1...... а дальше что писать не знаю

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
а ти отладчиком пользуешься???:))

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
Пользуюсь, тут просто дело в неправильности синтаксиса....
Вот подскажи как мне обратится к табличной части документа из обработки
Вот как в модуле документа пишется типа Документ= элементыформы.текущиеданные.табличнаячасть.Реквизит
как точно также обратится из обработки??

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
докк = ПолучитьОбъект(Некий док);
докк.ТабЧасть.Номенклатура

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Таб часть для чиво???для чтения иль записи!!!

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
Док.Субконто1=ПЛ.ЭлементыФормы.ТабличнаяЧасть1.Видработ.СубконтоБУ1;

для записи из одного документа в другой....
вообщем делаю я обработку списанияГСМ через документ Требование Накладная

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Ну воть получай объект функцией "ПолучитьОбъект(Некий док)" и рули им!


Теги:
 

Помогите выразить код Объект.Наименование = Объект.Подразделение + " " + Объект.Должность + " " + Объект.ФизическоеЛицо через строки.

Автор LedgikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1133
Последний ответ 05 Мар 2019, 19:28
от Ledgik
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6812
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите правильно настроить справочник "Единицы измерения" и "Номенклатура"

Автор perminovandrРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1336
Последний ответ 23 Янв 2019, 07:21
от Геннадий ОбьГЭС
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 1625
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7228
Последний ответ 07 Сен 2010, 12:01
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
33 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
25 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 183
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal