Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с обработкой  (Прочитано 7517 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
Ругается на половину кода, как в 1с 8.1 реализовать этот синтаксис, такие операторы типа "Выбрать" , "Получить" , "ВыбратьСтроки" и т.д, подскажите плиз кто знает синтаксис 1с 8.1


ПЛ = Документы.БС_ПутевойЛистАвтомобиля.СоздатьДокумент();
   Док = Документы.ТребованиеНакладная.СоздатьДокумент();
   
   
   ПЛ.Выбрать(НачалоПериода,КонецПериода);
   Пока ПЛ.Получить()=1 Цикл
      
            
      ПЛ.ВыбратьСтроки();
      Пока ПЛ.ПолучитьСтроку() = 1 Цикл
         
         Если  ПЛ.РасходГорючегоФакт<>0 тогда           
            Док.ЭтоНовый();
            Док.ПутевойЛист = ПЛ;
            
            Док.Дата=Пл.Дата;
            Док.Материалы =ПЛ.ТранспортноеСредство.МаркиТоплива.Материал;
            
            Для А = 1 По 3 Цикл
               Док.НазначитьТип("Субконто"+А,ПЛ.Видработ.СчетБУ.ВидСубконто(А));
            КонецЦикла; 
            
            Док.СчетЗатрат=ПЛ.СчетБУ;
            Док.Субконто1=ПЛ.СубконтоБУ1;
            Док.Субконто2=ПЛ.СубконтоБУ2;
            Док.Субконто3=ПЛ.СубконтоБУ3;
         КонецЕсли;
         Док.НоваяСтрока() ;
         Док.НоменклатурнаяГруппа = ПЛ.МаркиТоплива;
         Док.Количество = ПЛ.РасходГорючегоФакт;
         
         
      КонецЦикла;   
   
   Сообщить("Обработка завершена!");   


Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
C синтаксисом немного разобрался уже B)
Теперь проблема в следующем, как обратится к реквизиту табличной части документа

Док.Материалы.Номенклатура= ПЛ.ТранспортноеСредство.МаркиТоплива.Материал.Наименование;

вот как мне в данной строчке обратится к реквизиту Номенклатура который находится в табличной части документа
через элементыформы не прокатило

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
так тыж только создал документ ПЛ как ты к ниму обратишьсо? эго необходимо записать

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
ПЛ.Записать(РежимЗаписиДокумента.Проведение);

сразу после создания вот так записать его?
и еще вопрос как мне обратится к реквизиту документа который находится в табличной части?
Док.СчетЗатрат=ПЛ.ТабличнаяЧасть1...... а дальше что писать не знаю

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
а ти отладчиком пользуешься???:))

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
Пользуюсь, тут просто дело в неправильности синтаксиса....
Вот подскажи как мне обратится к табличной части документа из обработки
Вот как в модуле документа пишется типа Документ= элементыформы.текущиеданные.табличнаячасть.Реквизит
как точно также обратится из обработки??

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
докк = ПолучитьОбъект(Некий док);
докк.ТабЧасть.Номенклатура

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Таб часть для чиво???для чтения иль записи!!!

Оффлайн Zeratul

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-06-02
  • Сайт: 
Док.Субконто1=ПЛ.ЭлементыФормы.ТабличнаяЧасть1.Видработ.СубконтоБУ1;

для записи из одного документа в другой....
вообщем делаю я обработку списанияГСМ через документ Требование Накладная

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Ну воть получай объект функцией "ПолучитьОбъект(Некий док)" и рули им!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4300
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5556
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5895
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4381
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1982
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 118
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal