Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 07:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Регистр Накопления и ЗАПРОС  (Прочитано 2872 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн malvina_l

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-08
  • Сайт: 
  • Профессия: Программист 1С
Помогите , что-то не срабатывает. ЗАДАЧА: Есть Регистр с полями "Номенклатура " (соответственно из справочника номенклатура, "Ответственные лица " (справочник физлица) . нужно у сотрудника1, сотрудника2,сотрудника3 , удалить номенклатуру,которая находиться в папке "Корзина" из регистра.

   Корзина=Справочники.Номенклатура.НайтиПоКоду("13825");
     Запрос=Новый Запрос;
          Запрос.Текст=
         "ВЫБРАТЬ
         |Товары.Регистратор
         |ИЗ
         |РегистрНакопления.Товары КАК Товары
         |ГДЕ
              | Товары.Номенклатура в ИЕРАРХИИ (&Корзина)";
         
         Запрос.УстановитьПараметр("Корзина", Корзина);
         Результат=Запрос.Выполнить().Выбрать();
         ФИО=Новый Массив;
         ФИО.Добавить("Иванов Е.С.");
         ФИО.Добавить("Иванов2 И.А.");
         ФИО.Добавить("Иванов3 Е.В.");
         ФИО.Добавить("Иванов4 З.Н.");
          Рег = РегистрыНакопления.Товары;
            НаборЗаписей = Рег.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Регистратор.Установить("Товары");
            ОсновныеДанные = НаборЗаписей.Прочитать();
             Для каждого Запись из НаборЗаписей цикл
             Если Результат=истина тогда
                НаборЗаписей.Удалить();
                КонецЕсли;
                КонецЦикла;
                 НаборЗаписей.Записать();


Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Что имеется ввиду под "папка Корзина"? Группа в справочнике?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн malvina_l

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-08
  • Сайт: 
  • Профессия: Программист 1С
Что имеется ввиду под "папка Корзина"? Группа в справочнике?
да группа

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Точно не уверен, что получится, но попробуйте вот так:

Корзина = Справочники.Номенклатура.НайтиПоКоду("13825");
Сотр1 = Справочники.ФизическиеЛица.НайтиПоНаименованию("ФИО сотра");
Сотр2 = Справочники.ФизическиеЛица.НайтиПоНаименованию("ФИО сотра");
Сотр3 = Справочники.ФизическиеЛица.НайтиПоНаименованию("ФИО сотра");

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Товары.Номерклатура.Наименование
|ИЗ
| РегистрНакопления.Товары КАК Товары
|ГДЕ
| Товары.ФизЛицо.Наименование = &Сотр1
| И &Сотр2
| И &Сотр3
| И Товары.Номерклатура.Наименование В ИЕРАРХИИ(&Корзина)
|
|УПОРЯДОЧИТЬ ПО
| Товары.Физлицо.Наименование"

Запрос.УстановитьПараметр("Сотр1", Сотр1);
Запрос.УстановитьПараметр("Сотр2", Сотр2);
Запрос.УстановитьПараметр("Сотр3", Сотр3);
Запрос.УстановитьПараметр("Корзина", Корзина);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
    Спр = Справочники.Номенклатура.НайтиПоНаименованию(Выборка.Наименование).ПолучитьОбъект();
    Спр.Удалить();
КонецЦикла;
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
TreeDogNight, ТС'у надо записи в регистре очистить, а не элементы справочника удалить.

Может пойти другим путем? Отобрать документы, которые делают движения в этот регистр, отредактировать их табличные части и перепровести.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн malvina_l

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-08
  • Сайт: 
  • Профессия: Программист 1С
TreeDogNight, ТС'у надо записи в регистре очистить, а не элементы справочника удалить.

Может пойти другим путем? Отобрать документы, которые делают движения в этот регистр, отредактировать их табличные части и перепровести.
Я с этим кое-как , новичок, поэтому тяжеловато (

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вам вообще зачем номенклатуру удалять из регистра?
Может вам надо ОСТАТКИ ОБНУЛИТЬ?

(встроенный модуль ясновидения уже дымится от перегруза)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн malvina_l

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-08
  • Сайт: 
  • Профессия: Программист 1С
Вам вообще зачем номенклатуру удалять из регистра?
Может вам надо ОСТАТКИ ОБНУЛИТЬ?

(встроенный модуль ясновидения уже дымится от перегруза)
нужно номенклатуру из регистра удалить . такое задание

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Нуу тогда как описал...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9323
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2990
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 975
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 676
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
8.2 Бух. Запрос с условием "комментарий содержит текст"

Автор bolobolРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 16497
Последний ответ 02 Сен 2011, 01:14
от bolobol

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 298
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal