Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Работа с журналом расчетов  (Прочитано 2371 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Делаю выборку из журнала расчета "Зарплата":
ЖрнЗарплата.ВыбратьПоЗначению("МестоРаботыПолное",подр,ТекПер,ТекПер);
но почему-то возвращает мне 0 (не выполняется), хотя в самом Журнале есть значения, удовлетворяющие подр. Спасибо.


Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Помогите. Бьюсь над кодом, не могу понять:
ТекПер=ЖрнЗарплата.ТекущийПериод(); 
    если тзр.количествострок()>0 тогда
   тзр.выбратьстроки();   
   пока тзр.получитьстроку()=1 цикл
      если ПустоеЗначение(тзр.место)=0 тогда   
            подр=тзр.место;   
            ЖрнЗарплата.ВыбратьПоЗначению("МестоРаботыПолное",подр,ТекПер,ТекПер);
         Пока ЖрнЗарплата.ПолучитьЗапись() = 1 Цикл
             Если ВходитВГруппу(ЖрнЗарплата.ВидРасч, ЖрнЗарплата.Вид, "ДляПрофВзносов", ЖрнЗарплата.ДатаНачала) = 1 Тогда
            Если ЖрнЗарплата.Перерасчет=0 тогда
               Сум = Сум + ЖрнЗарплата.Результат;
            КонецЕсли;
         КонецЕсли;
         КонецЦикла; 
           Результат = Округл(Сум * Процент * 0.01);   
          ЖрнЗарплата.УстановитьРеквизит("МестоРаботыПолное", тзр.место);
          ЖрнЗарплата.УстановитьРеквизит("Участок", тзр.участок);
   конецесли;
   КонецЦикла;
   конецесли;

проверяю в отладчике количество строк в таблице значений выдает две (правильно), но при прохождении цикла получитьстроку первую берут, но она пустая, поэтому цикл пропускает, а при переходе на вторую выходит из цикла.   

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
подр и ТекПер чему равны? ТекПер какой тип имеет?

Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
подр - это значение из справочника Подразделения, ТекПер - это текущий период журнала расчетов ТекПер=ЖрнЗарплата.ТекущийПериод();

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
"МестоРаботыПолное" это графа отбора журнала? Она так называется?
Если "подр" имеет тип справочник, можно попробовать еще подр.ТекущийЭлемент()

Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Да, МестоРаботыПолное- это графа отбора. Но сама переменную подр в отладчике есть, значение определяется. И в самом Журнале расчетов это графа заполнена. Но при вызове метода выдает ошибку.:dfbsdfbsdf:

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Но при вызове метода выдает ошибку.
какую ошибку то?

Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Не производит отбор, возвращает 0.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
43 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal