Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 21:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Почему не сохраняет документ  (Прочитано 1919 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergey_lb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-07
  • Сайт: 
  • Профессия: Программист 1С
Потребовалось слить несколько документов в один. Написал обработку. Но сохранения измененного документа не происходит. Не пойму почему. Помогите кто может.

&НаСервере
Процедура Слияние()
Док2 = Объект.Док2.ПолучитьОбъект();
Для Каждого ТекСтрокаДок1 из Объект.Док1.Товары Цикл
Тов1 = ТекСтрокаДок1.Номенклатура;
Кол1 = ТекСтрокаДок1.КоличествоФакт;
НайденнаяСтрока = Док2.Товары.Найти(Тов1, "Номенклатура");
Если НайденнаяСтрока = Неопределено Тогда
НоваяСтрока = Док2.Товары.Добавить();
НоваяСтрока.Номенклатура = ТекСтрокаДок1.Номенклатура;
НоваяСтрока.Характеристика = ТекСтрокаДок1.Характеристика;
НоваяСтрока.Упаковка = ТекСтрокаДок1.Упаковка;
НоваяСтрока.Количество = ТекСтрокаДок1.Количество;
НоваяСтрока.КоличествоФакт = ТекСтрокаДок1.КоличествоФакт;
НоваяСтрока.Цена = ТекСтрокаДок1.Цена;
НоваяСтрока.Сумма = ТекСтрокаДок1.Сумма;
НоваяСтрока.СуммаФакт = ТекСтрокаДок1.СуммаФакт;
Иначе
НайденнаяСтрока.КоличествоФакт = НайденнаяСтрока.КоличествоФакт + Кол1;
НайденнаяСтрока.СуммаФакт = НайденнаяСтрока.КоличествоФакт * НайденнаяСтрока.Цена;
КонецЕсли;
КонецЦикла;
Док2.Записать();
КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 07 Май 2014, 10:18


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Должно записывать. Ошибки никакой не выдает?

Оффлайн sergey_lb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-07
  • Сайт: 
  • Профессия: Программист 1С
Но почему-то не сохраняет. А существуют альтернативные способы?

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Надо поотлаживать. Может он на самом деле все сохраняет, просто сам документ не меняется.


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 235
Последний ответ 23 Окт 2017, 23:14
от Ivan94
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4401
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9342
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3916
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 19034
Последний ответ 10 Ноя 2010, 14:08
от Lexius

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 327
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal