Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 15:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Номер телефона  (Прочитано 2474 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dronspartak9@gmail.com

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-16
  • Сайт: 
Подскажите как вызвать эту процедуру для получения телефона физического лица:
Функция ПолучитьТелефонИзКонтактнойИнформации(Объект, ВидТелефона = Неопределено) Экспорт    // change

   Если ВидТелефона = Неопределено Тогда
      ВидТелефона = Справочники.ВидыКонтактнойИнформации.ТелефонОрганизации;
   КонецЕсли;

   Запрос = Новый Запрос;
   
   Запрос.УстановитьПараметр("Объект", Объект);
   Запрос.УстановитьПараметр("Тип"   , Перечисления.ТипыКонтактнойИнформации.Телефон);
   Запрос.УстановитьПараметр("Вид"   , ВидТелефона);
   
   Запрос.Текст =
   "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
   |   КонтактнаяИнформация.Представление
   |ИЗ
   |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
   |ГДЕ
   |   КонтактнаяИнформация.Объект = &Объект
   |   И КонтактнаяИнформация.Тип = &Тип
   |   И КонтактнаяИнформация.Вид = &Вид";
   
   РезультатЗапроса = Запрос.Выполнить();
   
   Если РезультатЗапроса.Пустой() Тогда
      Возврат "";
   Иначе
      Возврат РезультатЗапроса.Выгрузить()[0].Представление;
   КонецЕсли;

КонецФункции // ПолучитьТелефонИзКонтактнойИнформации()


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Номер телефона
« Ответ #1: 06 Май 2014, 10:48 »
ТелефонФизЛица = ПолучитьТелефонИзКонтактнойИнформации(Справочники.ФизическиеЛица.НайтиПоНаименованию("Пупкин", Истина), Справочники.ВидыКонтактнойИнформации.ТелефонМобильный);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн dronspartak9@gmail.com

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-16
  • Сайт: 
Re: Номер телефона
« Ответ #2: 06 Май 2014, 11:22 »
Спасибо


Теги:
 

При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8485
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6824
Последний ответ 18 Сен 2011, 16:07
от Хеля
Регламентные задания "Недопустимое значение параметра (параметр номер "1")

Автор pyvfРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 17203
Последний ответ 27 Фев 2013, 11:57
от reshkra
Длина поля "Код" (Таб. номер) в ЗИУП 3.0

Автор igor447Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 693
Последний ответ 15 Фев 2016, 03:49
от cska-fanat-kz
в строке номер документа основания (108)не сохраняется "0"

Автор NadinAstraРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 1551
Последний ответ 04 Май 2016, 14:23
от Игорь Иванов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 858
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal