Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: заполнение данных из excel  (Прочитано 1357 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн runtiks

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Доброе время суток. Прошу помощи знающих людей. Стоит УТ 11.1.4.14
Есть обработка (ссылка на саму обработку http://yadi.sk/d/PAT2tZ84PAAyJ) по созданию номенклатуры
Хотелось-бы еще и с помощью ее формировать документы поступления. Как перенести наименование, количество и цену в табличную часть поступления товаров и услуг?

Добавлено через 15 минут
Гугол рассказал мне что для этого нужно нарисовать кнопку которая при нажатии вызывает команду а команду описать в модуле формы. Самый удачный вариант переносит в документ только цену:

То что я пытался написать:

&НаКлиенте
Процедура Поступление(Команда)
ПоступлениеНаСервере();   
КонецПроцедуры


&НаСервере
Процедура ПоступлениеНаСервере()

Док = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент( );

//Заполняю документ
док.Дата = ТекущаяДата();

//Заполняю Табличную часть документа
Массив = Объект.СписокЗагрузки.Выгрузить();
Док.Товары.Загрузить(Массив);



Док.Записать();

КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
При
Док.Товары.Загрузить(Массив);
заполняются только те колонки, имена которых совпадают. в противном случае - крутите цикл и вручную заполняйте.

Для каждого СтрокаТЗ Из ОбъектСписокЗагрузки Цикл
    НоваяСтрока = Док.Товары.Добавить();
    НоваяСтрока.Номенклатура = СтрокаТЗ.Номенклатура;
    НоваяСтрока.Количество = СтрокаТЗ.Количество;
/////////////
    и т.д.
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7434
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3882
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2113
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7325
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6952
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 295
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal