Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2018, 05:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Вопрос) дополнительные внешние обработки табличных частей  (Прочитано 2469 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KazakOFF

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Делаю внешнюю обработку.

Всем привет, проблема собственно такая при выгрузке данных в таблицу данные которые уже есть почему-то затераются, как сделать что-бы они остались?   

Процедура Инициализировать(Объект, ТабЧасть, ТабПоле) Экспорт

ЭтотОбъект.СсылкаНаОбъект = Объект;

РезультатОбработки = ЭтотОбъект.ПолучитьФорму("ФормаОбработки").ОткрытьМодально();

Если ТипЗНЧ(РезультатОбработки) = Неопределено Тогда
Сообщить("Заполнение табличной части не произведено");
Иначе

Объект.Суммыдолга.Загрузить(РезультатОбработки);


КонецЕсли;
КонецПроцедуры



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
не "почему-то", а потому что делаете методом Загрузить().
если нужно просто добавить к таблице другую, то...

Для каждого СтрокаТЗ Из РезультатОбработки Цикл
    НоваяСтрока = Объект.Суммыдолга.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаТЗ);
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн KazakOFF

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Большое спасибо надо запомнить :)

не "почему-то", а потому что делаете методом Загрузить().
если нужно просто добавить к таблице другую, то...

Для каждого СтрокаТЗ Из РезультатОбработки Цикл
    НоваяСтрока = Объект.Суммыдолга.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаТЗ);
КонецЦикла;

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Так же не забудь 4 параметр данной функции, там пишем те поля которые нужны исключить из заполнения:
ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаТЗ,,"Количество,СуммаНДС")
Типа того)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
markgenuine, нуу не все ж сразу ;)
Задача была просто добавить строки из одной ТЗ в другую.

ЗЫ у этой процедуры есть и третий параметр ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9595
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5985
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3354
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3599
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2454
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
100 Сообщений
AIFrame
57 Сообщений
alex0402
29 Сообщений
kiksi
24 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
16 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 299
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal