Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 11:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Спрятать от менеджера в табличной части кассу / Вывести определенную кассу  (Прочитано 1654 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн avangarddv

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-05
  • Сайт: 
  • Профессия: Ученик 1С
ДД!

Имеется 1C 8.2. УНФ

В перемещении денег, в табличной части, необходимо ограничить вывод Касс. А именно, что бы у одного менеджера была возможность видеть в табличной части только одну кассу - Кассу Москвы.

Что делаю:
1. Сделал роль - Кассы Москвы.
2. Написал условие выбора касс:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
Если РольКассыМосквы() Тогда
ОтборКасса=ПолучитьКассаМосква();
КонецЕсли;
КонецПроцедуры


&НаСервере
Функция РольКассыМосквы()
Возврат РольДоступна("КассыМосквы");
конецФункции

&НаСервере
Функция ПолучитьКассаМосква()
Возврат Справочники.Кассы.НайтиПоНаименованию("Касса Москва");
КонецФункции

Но что то видимо не-то делаю.. ? Может есть другой способ вывода нужных данных в табличной части?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для программного добавления отбора в динамический список надо юзать условное оформление.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн avangarddv

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Не подскажите каким образом составить там условие?

Т.е. зашел в раздел - Условное оформление. Далее ставлю условие - Список.Касса = Отбор.Касса

В оформляемые полях задаю - Список.Касса.

Никакого вывода, не понимаю как задать Отбор.Касса = Нужная мне касса.

Список.Касса - это как раз тот реквизит, в табличной части, где выводятся кассы.



Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1947
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3058
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3090
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 666
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 248
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 868
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal