Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод объекта не обнаружен Печать  (Прочитано 4896 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн webmastersb

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!

Только начинаю изучать 1с на уровне программирования.

Возникла ошибка с внешней печатной формой

Форму делал не на запросах, а через СсылкаНаОбъект. (всвязи с тем, что смотрел видео по созданию формы для версии 8)

Ошибка возникает когда открываю ее уже в 1с предприятие, в конфигураторе при проверке показывает что ошибок не обнаружено.

Вот код:

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = Новый Структура;

МассивНазначений = Новый Массив;
МассивНазначений.Добавить("Документ.ЗаказКлиента");

ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //возможны варианты - ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов,
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "Упаковочный Лист"); //имя под kt обработка зарегистрирована будет в справочнике внешних обработок
ПараметрыРегистрации.Вставить("Версия", "1.1");
ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
ПараметрыРегистрации.Вставить("Информация", "Дополнительная печатная форма к документу ЗаказКлиента ");

//команды
ТаблицаКоманд = Новый ТаблицаЗначений;
ТаблицаКоманд.Колонки.Добавить("Представление"); //как будет выглядеть описание печ.формы для пользователя
ТаблицаКоманд.Колонки.Добавить("Идентификатор"); //имя нашего макета
ТаблицаКоманд.Колонки.Добавить("Использование"); //ВызовСерверногоМетода
ТаблицаКоманд.Колонки.Добавить("ПоказыватьОповещение"); //Истина
ТаблицаКоманд.Колонки.Добавить("Модификатор"); //ПечатьМХL

НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = "Упаковочный Лист";
НоваяКоманда.Идентификатор = "УпаковочныйЛист"; //Внешняя печатная форма
НоваяКоманда.Использование = "ВызовКлиентскогоМетода"; //здесь можно прописать использование как серверного так и клиентского, отличие в том, что серверный метод будет обращаться к экспортной процедуре из модуля объекта, клиентский - к экспортной процедуре из модуля формы объекта
НоваяКоманда.ПоказыватьОповещение = Истина;
НоваяКоманда.Модификатор = "ПечатьMXL";

ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;

КонецФункции

Процедура Печать() Экспорт


Процедура Печать() Экспорт


ТабДок = Новый ТабличныйДокумент;

//ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_УпаковочныйЛист";

Макет = ПолучитьМакет("УпаковочныйЛист");

СекцияШапка = Макет.ПолучитьОбласть("Шапка");

СекцияТело = Макет.ПолучитьОбласть("Тело");

СекцияПодвал = Макет.ПолучитьОбласть("Подвал");

СекцияЗаголовок = Макет.ПолучитьОбласть("Заголовок");

СекцияСтрока = Макет.ПолучитьОбласть("Строка");

СекцияПодвалТаб = Макет.ПолучитьОбласть("ПодвалТаб");

СекцияШапка.Параметры.Организация = СсылкаНаОбъект.Организация;
СекцияШапка.Параметры.номер = СсылкаНаОбъект.НомерПоДаннымКлиента;
СекцияШапка.Параметры.Дата = СсылкаНаОбъект.Дата;
ТабДок.Вывести("СекцияШапка");

СекцияТело.Параметры.Покупатель = СсылкаНаОбъект.Контрагент;
СекцияТело.Параметры.АдресДоставки = СсылкаНаОбъект.АдресДоставки;
ТабДок.Вывести("СекцияТело");

ТабДок.Вывести("СекцияЗаголовок");

Для каждого СтрТаб из СсылкаНаОбъект.Товары Цикл

ЗаполнитьЗначенияСвойств(СекцияСтрока.Параметры,СтрТаб);
ТабДок.Вывести("СекцияСтрока");

КонецЦикла;

СсылкаНаОбъект = СсылкаНаОбъект.Товары[0];

ТабДок.Вывести("СекцияПодвалТаб");

СекцияТело.Параметры.ОтветственноеЛицо = СсылкаНаОбъект.Автор;
ТабДок.Вывести("СекцияПодвал");

//ТабДок.ОтображатьЗаголовки=Ложь;
//ТабДок.ОтображатьСетку=Ложь;
//ТабДок.ТолькоПросмотр=Истина;

ТабДок.АвтоМасштаб = Истина;


//Возврат ТабДок;
КонецПроцедуры // Печать()

Вывод Возврат ТабДок;
закоментировал, т.к. была ошибка



Последний раз редактировалось: MuI_I_Ika; 30 Апр 2014, 14:54


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Возврат ПараметрыРегистрации;

КонецФункции

Процедура Печать() Экспорт


Процедура Печать() Экспорт



ТабДок = Новый ТабличныйДокумент;

а ЗАЧЕМ два раза?? :o
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн webmastersb

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Это я опечатался

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
ошибка УШЛА??

код расположен в МОДУЛЕ обработки?
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн webmastersb

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-30
  • Сайт: 
  • Профессия: Ученик 1С
ошибка УШЛА??

код расположен в МОДУЛЕ обработки?

Код в модуле объекта
Ошибка осталась, она возникает именно в предпрриятиии, в конфигураторе после провекри ошибок не обнаружено

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СчетЗаказВн") Тогда

ТабличныйДокумент = ПечатьДокумента(МассивОбъектов, ОбъектыПечати);
       
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
КоллекцияПечатныхФорм,
"СчетЗаказВн",
НСтр("ru = 'Счет на оплату'"),
ТабличныйДокумент,
,
"ПФ_MXL_СчетЗаказВн"
);
КонецЕсли;

КонецПроцедуры

скачайте какую-нибудь ВПФ и посмотрите код


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal